Package: eclipse
Version: 3.8.0~rc4-1
Severity: normal

Dear Maintainer,
*** Please consider answering these questions, where appropriate ***

   * What led up to the situation?
   * What exactly did you do (or not do) that was effective (or
     ineffective)?
   * What was the outcome of this action?
   * What outcome did you expect instead?

*** End of the template - remove these lines ***

Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
From: Shai Berger <s...@platonix.com>
To: Debian Bug Tracking System <sub...@bugs.debian.org>
Subject: eclipse: upgrade hides locally installed plugins
Message-ID: <20120710082327.5117.44702.reportbug@shaijitsu>
X-Mailer: reportbug 6.4
Date: Tue, 10 Jul 2012 11:23:27 +0300

Package: eclipse
Version: 3.8.0~rc4-1
Severity: normal

Dear Maintainer,

I've just upgraded my eclipse, to find my plugins "missing";
they were not active, and not in the "installed software" reports.

I wanted to install them, and found:

The EGit plug-in (installed as a Debian package) still had its
"software site" in the list of update sources. Updating from there
reported that the software is already installed; I added more
packages from this site, and it made the plug-in live again.

Aptana Studio (which I had installed directly from their site) was
nowhere to be found, and had to be completely reinstalled.
Aptana Studio - http://download.aptana.com/studio3/plugin/install

Aptana Studio, among other things, defines perspectives. Some of the
perspective settings were lost.

Thanks for your good work,

Shai.

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-3-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages eclipse depends on:
ii  eclipse-jdt  3.8.0~rc4-1
ii  eclipse-pde  3.8.0~rc4-1

eclipse recommends no packages.

eclipse suggests no packages.

Versions of packages eclipse-platform depends on:
ii  ant                            1.8.2-4
ii  ant-optional                   1.8.2-4
ii  default-jre [java6-runtime]    1:1.6-47
ii  eclipse-platform-data          3.8.0~rc4-1
ii  eclipse-rcp                    3.8.0~rc4-1
ii  gconf-service                  3.2.5-1
ii  java-common                    0.47
ii  libc6                          2.13-33
ii  libcommons-codec-java          1.6-1
ii  libcommons-httpclient-java     3.1-10
ii  libcommons-logging-java        1.1.1-9
ii  libgconf-2-4                   3.2.5-1
ii  libglib2.0-0                   2.32.3-1
ii  libjetty8-java                 8.1.3-4
ii  libjsch-java                   0.1.42-2
ii  liblucene2-java                2.9.4+ds1-4
ii  libservlet3.0-java             7.0.28-1
ii  multiarch-support              2.13-33
ii  openjdk-6-jre [java6-runtime]  6b24-1.11.3-2
ii  openjdk-7-jre [java6-runtime]  7~u3-2.1.1-1
ii  sat4j                          2.3.1-1

Versions of packages eclipse-platform recommends:
ii  eclipse-pde  3.8.0~rc4-1

Versions of packages eclipse-platform suggests:
ii  eclipse-jdt  3.8.0~rc4-1

Versions of packages eclipse-pde depends on:
ii  default-jre [java6-runtime]    1:1.6-47
ii  eclipse-jdt                    3.8.0~rc4-1
ii  eclipse-platform               3.8.0~rc4-1
ii  libasm3-java                   3.3.2-1
ii  openjdk-6-jre [java6-runtime]  6b24-1.11.3-2
ii  openjdk-7-jre [java6-runtime]  7~u3-2.1.1-1

eclipse-pde suggests no packages.

Versions of packages eclipse-jdt depends on:
ii  default-jre [java6-runtime]    1:1.6-47
ii  eclipse-platform               3.8.0~rc4-1
ii  junit                          3.8.2-8
ii  junit4                         4.10-3
ii  libhamcrest-java               1.2-2
ii  openjdk-6-jre [java6-runtime]  6b24-1.11.3-2
ii  openjdk-7-jre [java6-runtime]  7~u3-2.1.1-1

Versions of packages eclipse-jdt recommends:
ii  default-jdk  1:1.6-47

eclipse-jdt suggests no packages.

-- no debconf information

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-3-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages eclipse depends on:
ii  eclipse-jdt  3.8.0~rc4-1
ii  eclipse-pde  3.8.0~rc4-1

eclipse recommends no packages.

eclipse suggests no packages.

Versions of packages eclipse-platform depends on:
ii  ant                            1.8.2-4
ii  ant-optional                   1.8.2-4
ii  default-jre [java6-runtime]    1:1.6-47
ii  eclipse-platform-data          3.8.0~rc4-1
ii  eclipse-rcp                    3.8.0~rc4-1
ii  gconf-service                  3.2.5-1
ii  java-common                    0.47
ii  libc6                          2.13-33
ii  libcommons-codec-java          1.6-1
ii  libcommons-httpclient-java     3.1-10
ii  libcommons-logging-java        1.1.1-9
ii  libgconf-2-4                   3.2.5-1
ii  libglib2.0-0                   2.32.3-1
ii  libjetty8-java                 8.1.3-4
ii  libjsch-java                   0.1.42-2
ii  liblucene2-java                2.9.4+ds1-4
ii  libservlet3.0-java             7.0.28-1
ii  multiarch-support              2.13-33
ii  openjdk-6-jre [java6-runtime]  6b24-1.11.3-2
ii  openjdk-7-jre [java6-runtime]  7~u3-2.1.1-1
ii  sat4j                          2.3.1-1

Versions of packages eclipse-platform recommends:
ii  eclipse-pde  3.8.0~rc4-1

Versions of packages eclipse-platform suggests:
ii  eclipse-jdt  3.8.0~rc4-1

Versions of packages eclipse-pde depends on:
ii  default-jre [java6-runtime]    1:1.6-47
ii  eclipse-jdt                    3.8.0~rc4-1
ii  eclipse-platform               3.8.0~rc4-1
ii  libasm3-java                   3.3.2-1
ii  openjdk-6-jre [java6-runtime]  6b24-1.11.3-2
ii  openjdk-7-jre [java6-runtime]  7~u3-2.1.1-1

eclipse-pde suggests no packages.

Versions of packages eclipse-jdt depends on:
ii  default-jre [java6-runtime]    1:1.6-47
ii  eclipse-platform               3.8.0~rc4-1
ii  junit                          3.8.2-8
ii  junit4                         4.10-3
ii  libhamcrest-java               1.2-2
ii  openjdk-6-jre [java6-runtime]  6b24-1.11.3-2
ii  openjdk-7-jre [java6-runtime]  7~u3-2.1.1-1

Versions of packages eclipse-jdt recommends:
ii  default-jdk  1:1.6-47

eclipse-jdt suggests no packages.

-- no debconf information



__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to