On 2012-07-18 11:34, Christoph Berg wrote:
> Package: tomcat6-common
> Version: 6.0.35-1
> Severity: grave
> Tags: security
> 
> /usr/share/tomcat6/bin/catalina.sh line 276 reads
> 
>         -Djava.security.policy=="$CATALINA_BASE"/work/catalina.policy \
> 
> The double = looks like a mistake. When running with -security, the
> policy will not get loaded.
> 
> Admittedly, I haven't tested it here, but I figured I should still
> file a bug because this just looks too obvious. If the second = is on
> purpose there, some comment should document that.
> 
> Affected are both squeeze and unstable/testing.
> 
> Christoph
> 
> [...]

Hi,

I vaguely that there are special semantics regarding security settings
and the use of ==, so its use may be legitimate.  Admittedly it was a
while back I last looked at security settings ...

~Niels

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to