Package: libservlet3.0-java
Version: 7.0.28-3
Severity: minor

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Hi,

gerrit (and possibly other projects) refer to the servlet api 3.0 as

      <dependency>
        <groupId>org.apache.tomcat</groupId>
        <artifactId>tomcat-servlet-api</artifactId>
        <version>7.0.32</version>
      </dependency>

I can rewrite this dependency with maven.rules, but unfortunately gerrit also
depends on

      <dependency>
        <groupId>org.apache.tomcat</groupId>
        <artifactId>servlet-api</artifactId>
        <version>6.0.29</version>
      </dependency>

Both dependencies get rewritten to javax.servlet:servlet-api only with
different version numbers. It gets even worse since gerrit is multi-module and
the submodules don't include the version in their dependencies.

Could you please publish the servlet-api also under the above coordinate? I'll
also fill a similar issue for tomcat6 (servlet2.5).

Regards, Thomas Koch

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAEBCAAGBQJQjqRbAAoJEAf8SJEEK6Zas1QQAKsS90gSEM+k6SVIYnCnzKfk
KWjsSNEvZMCjJKJxUargc/oyRQjlje6o71El3+Ol3f6uAbihdTDRfvHGfMXRbF5Y
hDa4J4OUgouQRUkikZc+/lBDYJnGJCPahn9dsGLPaKr4qwWF5n0/wQfbbv10rC9Y
w7Juxfk0cyfl3BaY7B4sqR7xmRujqIUUWr76dGBDJDYoFrAyyJYlKDi2HYbDv2Ax
fXn/sDaNhPTcBIE9YwVmfAvERoUL60RMYWp/a1x2PW4LEcPwv2aFI0KKCbRtq5O4
IRyAldhdj1qOB/sHpfTX1DcfISE4O44K+n9vR2aVDP/JuMJKb7/Pe6KgR91O8sTH
YC2jwHjnIhTyePr7qN97YURAP2dBuJANsWBTSo5nhAdqy0g70ryr5m7nGVGttd5F
mtAK7q7aqnhYg0HA+ryPmSQVkJ8zBNa2wEUK9E9jn/t1AAPjMMZ6O3ueSAOR8Jh+
fNUP+ipTnTrhrfQKN5A9DnurG0KW1spNWfRSgINE7du9Opqwza7ygaGYxXBq6sWZ
Zx6Iw0wEKEnBGNY/qtjtcKh914NKUfNh3OoOCN/LC88iAj4k2c6bPrasmhsgYovU
5lWvB048MA8ZtGGShMTMcATylH/QKwBCxF/z9K68Bir60KwyLM2PoEKb02yIGqOr
A5pdewxavVV/+vhX0HvQ
=vh/4
-----END PGP SIGNATURE-----

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to