El dl 27 de 05 de 2013 a les 14:41 +0200, en/na Mathieu Malaterre va
escriure: 
> # as per OP report
> found 709950 1:1.1.dfsg-2
> thanks
> 
> On Mon, May 27, 2013 at 2:36 PM, Mònica Ramírez <mon...@debian.org> wrote:
> > found 709950 1:1.0.dfsg2-6
> > thanks
> ...
> > So, it failed with fop/1:1.0.dfsg2-6, but I've tested on a mips machine
> > with fop/1:1.1.dfsg-2 and it is still failing with the same error.
> >
> > It's not a regression, but still a bug :-(
> 
> Thanks ! Please copy/paste the exact output as found from mips (call
> stack and al.)

A build log on mips is attached. 

Moreover if I run fop with -d (debug) option, I get more details about
the exception:

---------------------- 
$ xmlstarlet -d -xml xmlstarlet-man.xml -xsl xmlstar-fodoc-style.xsl -pdf 
xmlstarlet.pdf
target-resolution set to: 72.0dpi (px2mm=0.35277778)
userconfig is null
userconfig is null
Registering: any,normal,400 under F5
Registering: any,italic,400 under F6
Registering: any,oblique,400 under F6
Registering: any,normal,700 under F7
Registering: any,italic,700 under F8
Registering: any,oblique,700 under F8
Registering: sans-serif,normal,400 under F1
Registering: sans-serif,oblique,400 under F2
Registering: sans-serif,italic,400 under F2
Registering: sans-serif,normal,700 under F3
Registering: sans-serif,oblique,700 under F4
Registering: sans-serif,italic,700 under F4
Registering: SansSerif,normal,400 under F1
Registering: SansSerif,oblique,400 under F2
Registering: SansSerif,italic,400 under F2
Registering: SansSerif,normal,700 under F3
Registering: SansSerif,oblique,700 under F4
Registering: SansSerif,italic,700 under F4
Registering: serif,normal,400 under F5
Registering: serif,oblique,400 under F6
Registering: serif,italic,400 under F6
Registering: serif,normal,700 under F7
Registering: serif,oblique,700 under F8
Registering: serif,italic,700 under F8
Registering: monospace,normal,400 under F9
Registering: monospace,oblique,400 under F10
Registering: monospace,italic,400 under F10
Registering: monospace,normal,700 under F11
Registering: monospace,oblique,700 under F12
Registering: monospace,italic,700 under F12
Registering: Monospaced,normal,400 under F9
Registering: Monospaced,oblique,400 under F10
Registering: Monospaced,italic,400 under F10
Registering: Monospaced,normal,700 under F11
Registering: Monospaced,oblique,700 under F12
Registering: Monospaced,italic,700 under F12
Registering: Helvetica,normal,400 under F1
Registering: Helvetica,oblique,400 under F2
Registering: Helvetica,italic,400 under F2
Registering: Helvetica,normal,700 under F3
Registering: Helvetica,oblique,700 under F4
Registering: Helvetica,italic,700 under F4
Registering: Times,normal,400 under F5
Registering: Times,oblique,400 under F6
Registering: Times,italic,400 under F6
Registering: Times,normal,700 under F7
Registering: Times,oblique,700 under F8
Registering: Times,italic,700 under F8
Registering: Courier,normal,400 under F9
Registering: Courier,oblique,400 under F10
Registering: Courier,italic,400 under F10
Registering: Courier,normal,700 under F11
Registering: Courier,oblique,700 under F12
Registering: Courier,italic,700 under F12
Registering: Symbol,normal,400 under F13
Registering: ZapfDingbats,normal,400 under F14
Registering: Times-Roman,normal,400 under F5
Registering: Times-Roman,oblique,400 under F6
Registering: Times-Roman,italic,400 under F6
Registering: Times-Roman,normal,700 under F7
Registering: Times-Roman,oblique,700 under F8
Registering: Times-Roman,italic,700 under F8
Registering: Times Roman,normal,400 under F5
Registering: Times Roman,oblique,400 under F6
Registering: Times Roman,italic,400 under F6
Registering: Times Roman,normal,700 under F7
Registering: Times Roman,oblique,700 under F8
Registering: Times Roman,italic,700 under F8
Registering: Computer-Modern-Typewriter,normal,400 under F9
Rendering areas via IF document handler 
(org.apache.fop.render.intermediate.EventProducingFilter)...
Exception
java.lang.IllegalArgumentException: Invalid profile data
        at sun.java2d.cmm.lcms.LCMS.loadProfile(Native Method)
        at java.awt.color.ICC_Profile.getInstance(ICC_Profile.java:778)
        at java.awt.color.ICC_Profile.getInstance(ICC_Profile.java:994)
        at 
org.apache.xmlgraphics.java2d.color.profile.ColorProfileUtil.getICC_Profile(ColorProfileUtil.java:114)
        at 
org.apache.fop.pdf.PDFICCBasedColorSpace.setupsRGBColorProfile(PDFICCBasedColorSpace.java:143)
        at 
org.apache.fop.pdf.PDFICCBasedColorSpace.setupsRGBAsDefaultRGBColorSpace(PDFICCBasedColorSpace.java:112)
        at 
org.apache.fop.render.pdf.PDFRenderingUtil.addsRGBColorSpace(PDFRenderingUtil.java:279)
        at 
org.apache.fop.render.pdf.PDFRenderingUtil.setupPDFDocument(PDFRenderingUtil.java:400)
        at 
org.apache.fop.render.pdf.PDFDocumentHandler.startDocument(PDFDocumentHandler.java:143)
        at 
org.apache.fop.render.intermediate.util.IFDocumentHandlerProxy.startDocument(IFDocumentHandlerProxy.java:110)
        at 
org.apache.fop.render.intermediate.IFRenderer.startRenderer(IFRenderer.java:264)
        at org.apache.fop.area.RenderPagesModel.<init>(RenderPagesModel.java:81)
        at 
org.apache.fop.area.AreaTreeHandler.setupModel(AreaTreeHandler.java:135)
        at org.apache.fop.area.AreaTreeHandler.<init>(AreaTreeHandler.java:105)
        at 
org.apache.fop.render.RendererFactory.createFOEventHandler(RendererFactory.java:358)
        at org.apache.fop.fo.FOTreeBuilder.<init>(FOTreeBuilder.java:105)
        at org.apache.fop.apps.Fop.createDefaultHandler(Fop.java:100)
        at org.apache.fop.apps.Fop.<init>(Fop.java:78)
        at org.apache.fop.apps.FopFactory.newFop(FopFactory.java:297)
        at org.apache.fop.cli.InputHandler.renderTo(InputHandler.java:109)
        at org.apache.fop.cli.Main.startFOP(Main.java:177)
        at org.apache.fop.cli.Main.main(Main.java:208)
----------------------

I hope it helps.
Feel free to ask me if I can help more.

Cheers,
Mònica
 dpkg-buildpackage -rfakeroot -D -us -uc
dpkg-buildpackage: warning: using a gain-root-command while being root
dpkg-buildpackage: source package xmlstarlet
dpkg-buildpackage: source version 1.4.2-2
dpkg-buildpackage: source changed by Mònica Ramírez Arceda <mon...@debian.org>
 dpkg-source --before-build xmlstarlet-1.4.2
dpkg-buildpackage: host architecture mips
 fakeroot debian/rules clean
dh clean --with autoreconf
   dh_testdir
   dh_auto_clean
   dh_autoreconf_clean
   dh_clean
	rm -f debian/xmlstarlet.substvars
	rm -f debian/xmlstarlet.*.debhelper
	rm -rf debian/xmlstarlet/
	rm -f debian/*.debhelper.log
	rm -f -- doc/xmlstarlet.1 doc/xmlstarlet.txt doc/xmlstarlet-ug.html doc/xmlstarlet-ug.pdf doc/xmlstarlet-ug.ps
	rm -f debian/files
	find .  \( \( -type f -a \
	        \( -name '#*#' -o -name '.*~' -o -name '*~' -o -name DEADJOE \
		 -o -name '*.orig' -o -name '*.rej' -o -name '*.bak' \
		 -o -name '.*.orig' -o -name .*.rej -o -name '.SUMS' \
		 -o -name TAGS -o \( -path '*/.deps/*' -a -name '*.P' \) \
		\) -exec rm -f {} \; \) -o \
		\( -type d -a -name autom4te.cache -prune -exec rm -rf {} \; \) \)
	rm -f *-stamp
 dpkg-source -b xmlstarlet-1.4.2
dpkg-source: info: using source format `3.0 (quilt)'
dpkg-source: info: building xmlstarlet using existing ./xmlstarlet_1.4.2.orig.tar.gz
dpkg-source: warning: ignoring deletion of file Makefile.in
dpkg-source: warning: ignoring deletion of file version.h
dpkg-source: warning: ignoring deletion of file solaris/package/sol8-sparc/pkginfo
dpkg-source: warning: ignoring deletion of file solaris/package/sol9-sparc/pkginfo
dpkg-source: warning: ignoring deletion of file doc/xmlstarlet-ug.html
dpkg-source: warning: ignoring deletion of file doc/xmlstarlet-ug.ps
dpkg-source: warning: ignoring deletion of file doc/xmlstarlet.txt
dpkg-source: warning: ignoring deletion of file doc/xmlstarlet-ug.pdf
dpkg-source: warning: ignoring deletion of file doc/xmlstarlet.1
dpkg-source: info: building xmlstarlet in xmlstarlet_1.4.2-2.debian.tar.gz
dpkg-source: info: building xmlstarlet in xmlstarlet_1.4.2-2.dsc
 debian/rules build
dh build --with autoreconf
   dh_testdir
   dh_autoreconf
	find ! -ipath "./debian/*" -a ! \( -path '*/.git/*' -o -path '*/.hg/*' -o -path '*/.bzr/*' -o -path '*/.svn/*' -o -path '*/CVS/*' \) -a  -type f -exec md5sum {} \; > debian/autoreconf.before
	autoreconf -f -i
	find ! -ipath "./debian/*" -a ! \( -path '*/.git/*' -o -path '*/.hg/*' -o -path '*/.bzr/*' -o -path '*/.svn/*' -o -path '*/CVS/*' \) -a  -type f -exec md5sum {} \; > debian/autoreconf.after
   debian/rules override_dh_auto_configure
make[1]: Entering directory `/root/debian/xmlstarlet/xmlstarlet-1.4.2'
dh_auto_configure -- --program-transform-name=s/xml$/xmlstarlet/ --enable-build-docs
	./configure --build=mips-linux-gnu --prefix=/usr --includedir=\${prefix}/include --mandir=\${prefix}/share/man --infodir=\${prefix}/share/info --sysconfdir=/etc --localstatedir=/var --libdir=\${prefix}/lib/mips-linux-gnu --libexecdir=\${prefix}/lib/mips-linux-gnu --disable-maintainer-mode --disable-dependency-tracking --program-transform-name=s/xml\$/xmlstarlet/ --enable-build-docs
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... mips-unknown-linux-gnu
checking host system type... mips-unknown-linux-gnu
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... none
checking whether gcc and cc understand -c and -o together... yes
checking for a sed that does not truncate output... /bin/sed
checking for gawk... (cached) gawk
checking for xml2-config... /usr/bin/xml2-config
configure: using libxml-2.8.0
checking for xslt-config... /usr/bin/xslt-config
configure: using libxslt-1.1.26
checking for xsltproc... /usr/bin/xsltproc
checking for fop... /usr/bin/fop
checking for pdf2ps... /usr/bin/pdf2ps
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking whether lstat correctly handles trailing slash... yes
checking for stdlib.h... (cached) yes
checking for GNU libc compatible malloc... yes
checking for stdlib.h... (cached) yes
checking for GNU libc compatible realloc... yes
checking for mode_t... yes
checking for size_t... yes
checking for lstat... yes
checking for stat... yes
checking for setmode... no
checking whether O_BINARY is declared... no
checking whether exsltDateXpathCtxtRegister is declared... yes
configure: creating ./config.status
config.status: creating xmlstarlet.spec
config.status: creating Makefile
config.status: creating solaris/package/sol8-sparc/pkginfo
config.status: creating solaris/package/sol9-sparc/pkginfo
config.status: creating config.h
config.status: executing depfiles commands
make[1]: Leaving directory `/root/debian/xmlstarlet/xmlstarlet-1.4.2'
   dh_auto_build
	make -j1
make[1]: Entering directory `/root/debian/xmlstarlet/xmlstarlet-1.4.2'
make  all-am
make[2]: Entering directory `/root/debian/xmlstarlet/xmlstarlet-1.4.2'
  CC     src/trans.o
version.h: #define VERSION "1.4.2"
  CC     src/xml.o
  CC     src/xml_C14N.o
  CC     src/xml_depyx.o
  CC     src/xml_edit.o
src/xml_edit.c: In function ‘edInsert’:
src/xml_edit.c:363:27: warning: ‘node’ may be used uninitialized in this function [-Wuninitialized]
  CC     src/xml_elem.o
  CC     src/xml_escape.o
  CC     src/xml_format.o
  CC     src/xml_ls.o
src/xml_ls.c: In function ‘xml_print_dir’:
src/xml_ls.c:140:9: warning: ignoring return value of ‘chdir’, declared with attribute warn_unused_result [-Wunused-result]
  CC     src/xml_pyx.o
  CC     src/xml_select.o
  CC     src/xml_trans.o
  CC     src/xml_validate.o
  GEN    src/usage.c
  CC     src/usage.o
  GEN    src/c14n-usage.c
  CC     src/c14n-usage.o
  GEN    src/depyx-usage.c
  CC     src/depyx-usage.o
  GEN    src/edit-usage.c
  CC     src/edit-usage.o
  GEN    src/elem-usage.c
  CC     src/elem-usage.o
  GEN    src/escape-usage.c
  CC     src/escape-usage.o
  GEN    src/format-usage.c
  CC     src/format-usage.o
  GEN    src/ls-usage.c
  CC     src/ls-usage.o
  GEN    src/pyx-usage.c
  CC     src/pyx-usage.o
  GEN    src/select-usage.c
  CC     src/select-usage.o
  GEN    src/trans-usage.c
  CC     src/trans-usage.o
  GEN    src/unescape-usage.c
  CC     src/unescape-usage.o
  GEN    src/validate-usage.c
  CC     src/validate-usage.o
  CCLD   xml
  DBOOK	 doc/xmlstarlet.1
Note: Writing xmlstarlet.1
  DBOOK	 doc/xmlstarlet-ug.fo
Making portrait pages on USletter paper (8.5inx11in)
  FOP	 doc/xmlstarlet-ug.pdf
Exception
java.lang.IllegalArgumentException: Invalid profile data

make[2]: *** [doc/xmlstarlet-ug.pdf] Error 1
rm doc/xmlstarlet-ug.fo
make[2]: Leaving directory `/root/debian/xmlstarlet/xmlstarlet-1.4.2'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/root/debian/xmlstarlet/xmlstarlet-1.4.2'
dh_auto_build: make -j1 returned exit code 2
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2

Attachment: signature.asc
Description: This is a digitally signed message part

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to