Your message dated Sun, 11 Aug 2013 17:03:21 +0000
with message-id <e1v8z33-00038k...@franck.debian.org>
and subject line Bug#718960: fixed in gradle 1.4-2
has caused the Debian Bug report #718960,
regarding gradle doesn't work without libjetty-extra-java installed
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
718960: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=718960
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: gradle
Version: 1.4-1
Severity: important

gradle depends on libgradle-plugins-java, which in turn recommends libjetty-
extra-java.
This 'recommends' was working for version 1.1, but doesn't hold for 1.4. If not
installed, Gradle now fails always with:

Caused by: java.lang.IllegalArgumentException: Cannot find JAR 'jetty-plus.jar'
required by module 'gradle-jetty' using classpath or distribution directory
'/usr/share/gradle'

Defining libjetty-extra-java as a dependency instead of a recommendation for
libgradle-plugins-java will make the package conflict with other very popular
java tools as eclipse, but there's already another bug filed against jetty to
fix this: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=686876



-- System Information:
Debian Release: jessie/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 3.8-1-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages gradle depends on:
ii  ant                      1.8.2-4
ii  default-jre-headless     1:1.6-47
ii  libdom4j-java            1.6.1+dfsg.2-6
ii  libgradle-core-java      1.4-1
ii  libgradle-plugins-java   1.4-1
ii  libjaffl-java            0.5.9-4
ii  libjaxen-java            1.1.3-1
ii  libjna-java              3.2.7-4+b1
ii  libjnr-posix-java        1.1.8-2
ii  libkryo-java             2.20-3
ii  libnative-platform-java  0.3~rc2-2
ii  libwagon-java            1.0.0-2

gradle recommends no packages.

gradle suggests no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
Source: gradle
Source-Version: 1.4-2

We believe that the bug you reported is fixed in the latest version of
gradle, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 718...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Damien Raude-Morvan <draz...@debian.org> (supplier of updated gradle package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Sun, 11 Aug 2013 16:13:00 +0200
Source: gradle
Binary: gradle libgradle-core-java libgradle-plugins-java gradle-doc
Architecture: source all
Version: 1.4-2
Distribution: sid
Urgency: low
Maintainer: Debian Java Maintainers 
<pkg-java-maintainers@lists.alioth.debian.org>
Changed-By: Damien Raude-Morvan <draz...@debian.org>
Description: 
 gradle     - Groovy based build system
 gradle-doc - Documentation for gradle
 libgradle-core-java - Groovy based build system - Core library
 libgradle-plugins-java - Groovy based build system - All plugins
Closes: 707764 713171 718960
Changes: 
 gradle (1.4-2) unstable; urgency=low
 .
   * Fix compatibility with Apache Ivy 2.3 (Closes: #713171):
     - d/patches/35_ivy_23.diff: fix FTBFS on downloadRepositoryResource method
     - d/control: {Build,}-Depends on ivy (>= 2.3)
   * d/patches/34_disable_code_quality.diff: Disable some code analysis check
     to speed-up package build.
   * d/control: Merge Depends/Recommends field because Gradle just fails on
     missing dependencies (event if module is not used by user).
     (Closes: #718960, #707764).
Checksums-Sha1: 
 e9d2f4cb3865091ea4b12f550793704e399309d7 3351 gradle_1.4-2.dsc
 485ca6f5f8113091ae40b6b4c80def5c081b40df 22609 gradle_1.4-2.debian.tar.gz
 5eabc7e1893a25f4920391966e9a58125346191e 996864 gradle_1.4-2_all.deb
 fb7eee14841dbb695362b6d1b8f9b4e77f836246 3946990 
libgradle-core-java_1.4-2_all.deb
 3bf1a77c66892017ebcb13e46c1a3c3c8a2e6518 2931156 
libgradle-plugins-java_1.4-2_all.deb
 4464c897fb8b38b5f1b41691b3c7e467b0baed99 2522966 gradle-doc_1.4-2_all.deb
Checksums-Sha256: 
 3b8b142a5efc9e69770e7b56ec8155be40c6584bd588552726dd5c6a71083d87 3351 
gradle_1.4-2.dsc
 3d03898ca1470d7bec1d051b81bb93ba51dc2609a24476b81ffc3b49f992f721 22609 
gradle_1.4-2.debian.tar.gz
 cac03483e17a19fd52f063a5913491b8fe0ce83df99912fec9fda8c17ff4f7a8 996864 
gradle_1.4-2_all.deb
 3edaa757ab99972be56fc5ad550c4780b7b826e3f4b24a98f354704e2ae8ea90 3946990 
libgradle-core-java_1.4-2_all.deb
 19733163b4f217714f88cf1db9ad0b391b76f8f8734333c91f357ad480ae2c15 2931156 
libgradle-plugins-java_1.4-2_all.deb
 cdbd8f86434176f6f3506e8e1ea4eecb273f7b1fcf2c10e1d42c5aa2a364c73d 2522966 
gradle-doc_1.4-2_all.deb
Files: 
 3f8beac8c71b6aa53154b43d69a4f55d 3351 java optional gradle_1.4-2.dsc
 e6fdb4c798e50130e6829937e723d53f 22609 java optional gradle_1.4-2.debian.tar.gz
 cd3c72ca57d8149054915c336abd7245 996864 java optional gradle_1.4-2_all.deb
 ffcd3cf6402169fb30c8ac770180da64 3946990 java optional 
libgradle-core-java_1.4-2_all.deb
 754da8b949ec3fb50a3e703813ed4268 2931156 java optional 
libgradle-plugins-java_1.4-2_all.deb
 785383e29d98490023a28c1b165a9d45 2522966 doc optional gradle-doc_1.4-2_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.14 (GNU/Linux)

iQIcBAEBCAAGBQJSB7MVAAoJEHXiDM0z50n8XmAQAI/xV29Zh8n1sCfbv7jmuulr
Avakb0vMopVTLmB+jE6uZjkyYhF9n+px/zbQEUpF0m8Vgqz6Zv2vMsrT9TG6dL4s
L4g75NjFMhH1n6PR/ItqfuPiUj/JD0wDAZvMqSAEiwbJ5VZtCe82QP2darz5Az+k
RX5ZM03orZkubc5eHv1aan71Y0rBiXs+OW5tpy/CBUDOShSFbKFGAjB/62UBOOsv
7EWUYFxe/zlsR8Eys8eExQTcN7I5X+tnDxoUy7IBpl6SS11QCZTCiCw9hvXfeFrw
Z2USD1MGBhMB2MvF++0V0kJ9Kcx2yUBxulm1c7eR+Tr9ltzbTlO3OtnP+WNR2u2G
88klSnv5TSAdwmLdSHfnuwOQ/tnQ97V/CLMWcGr7quJmPRJYPYwiW/2z8RZjUVLE
lEY/M/E60QYk2C0DWgoVdoL8TVjEnqCspH4TIAfcO6bZWunUn1HCBPmteJaMmI0t
GWnDnoN4o2xeAyTZUuvCJQqnnN3va7wCd1CjXJpZlBCpXnJOqncgc9KNDgrM3etC
SY7SW81uFyiE1ZgTs2K2K67/dvCfeFjxr713X6Cqpo34acmQVjHygMppMVNXsWMe
x6v2a1SI9oHd/ME8ZGjE9QaGYEvW8C9N8g3SAI2f0LUNrUTcVfYqY72jChiN/+ia
rcKxER2OsicGZUvCnQ6U
=oZTX
-----END PGP SIGNATURE-----

--- End Message ---
__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to