Package: eclipse
Version: 3.8.1-4
Severity: important

Dear Maintainer,

   With recent versions of WebKitGTK+, Eclipse crashes whenever Javadoc
   hover help is to be displayed in the Java editor.

   Looks this happens because WebKit doesn't attach a default
   Authenticate listener and therefore
   WebKitGTK.soup_session_get_feature() returns 0 in WebKit.create().

   See linked eclipse bug report for fix that should be applied in
   debian/patches/.

   https://bugs.eclipse.org/bugs/show_bug.cgi?id=404776

-- System Information:
Debian Release: jessie/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.10-2-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages eclipse depends on:
ii  eclipse-jdt  3.8.1-4
ii  eclipse-pde  3.8.1-4

eclipse recommends no packages.

Versions of packages eclipse-platform depends on:
ii  ant                            1.9.1-1
ii  ant-optional                   1.9.1-1
ii  default-jre [java6-runtime]    1:1.7-49
ii  eclipse-platform-data          3.8.1-4
ii  eclipse-rcp                    3.8.1-4
ii  gconf-service                  3.2.6-1
ii  ibm-j2sdk1.6 [java6-runtime]   1.6.0.13.2-0
ii  java-common                    0.49
ii  libc6                          2.17-92
ii  libcommons-codec-java          1.8-1
ii  libcommons-httpclient-java     3.1-10.2
ii  libcommons-logging-java        1.1.3-1
ii  libgconf-2-4                   3.2.6-1
ii  libglib2.0-0                   2.36.4-1
ii  libjetty8-java                 8.1.3-8
ii  libjsch-java                   0.1.50-1
ii  liblucene2-java                2.9.4+ds1-4
ii  libservlet3.0-java             7.0.42-1
ii  multiarch-support              2.17-92
ii  openjdk-7-jre [java6-runtime]  7u21-2.3.9-5
ii  sat4j                          2.3.2-1

Versions of packages eclipse-platform recommends:
ii  eclipse-pde  3.8.1-4

Versions of packages eclipse-platform suggests:
ii  eclipse-jdt  3.8.1-4

Versions of packages eclipse-pde depends on:
ii  default-jre [java6-runtime]    1:1.7-49
ii  eclipse-jdt                    3.8.1-4
ii  eclipse-platform               3.8.1-4
ii  ibm-j2sdk1.6 [java6-runtime]   1.6.0.13.2-0
ii  libasm3-java                   3.3.2-2
ii  openjdk-7-jre [java6-runtime]  7u21-2.3.9-5

eclipse-pde suggests no packages.

Versions of packages eclipse-jdt depends on:
ii  default-jre [java6-runtime]    1:1.7-49
ii  eclipse-platform               3.8.1-4
ii  ibm-j2sdk1.6 [java6-runtime]   1.6.0.13.2-0
ii  junit                          3.8.2-8
ii  junit4                         4.11-2
ii  libhamcrest-java               1.3-2
ii  openjdk-7-jre [java6-runtime]  7u21-2.3.9-5

Versions of packages eclipse-jdt recommends:
ii  default-jdk                 1:1.7-49
ii  ibm-j2sdk1.6 [default-jdk]  1.6.0.13.2-0

eclipse-jdt suggests no packages.

-- no debconf information

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to