Package: gradle
Version: 1.4.2
Severity: important

Dear Maintainer,

if you installtomcat 7 gradle does not install. i think gradle has to use 
tomcat 7 but not sure how to deal with this bug.

root@debian:/home/martin/Downloads# apt-get install tomcat7
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  authbind libcommons-dbcp-java libcommons-pool-java libecj-java 
libgeronimo-jta-1.1-spec-java libtomcat7-java tomcat7-common
Suggested packages:
  libcommons-dbcp-java-doc ecj libecj-java-gcj libgeronimo-jta-java-doc 
tomcat7-docs tomcat7-admin tomcat7-examples tomcat7-user libtcnative-1
The following NEW packages will be installed:
  authbind libcommons-dbcp-java libcommons-pool-java libecj-java 
libgeronimo-jta-1.1-spec-java libtomcat7-java tomcat7 tomcat7-common
0 upgraded, 8 newly installed, 0 to remove and 102 not upgraded.
Need to get 5,331 kB of archives.
After this operation, 6,709 kB of additional disk space will be used.
Do you want to continue? [Y/n] yes
Get:1 http://debian.heanet.ie/debian/ testing/main authbind amd64 2.1.1 [20.2 
kB]
Get:2 http://debian.heanet.ie/debian/ testing/main libcommons-pool-java all 
1.6-2 [105 kB]
Get:3 http://debian.heanet.ie/debian/ testing/main libcommons-dbcp-java all 
1.4-3 [153 kB]
Get:4 http://debian.heanet.ie/debian/ testing/main libecj-java all 3.8.2-4 
[1,337 kB]
Get:5 http://debian.heanet.ie/debian/ testing/main 
libgeronimo-jta-1.1-spec-java all 1.1.1-3 [12.0 kB]
Get:6 http://debian.heanet.ie/debian/ testing/main libtomcat7-java all 7.0.42-1 
[3,597 kB]
Get:7 http://debian.heanet.ie/debian/ testing/main tomcat7-common all 7.0.42-1 
[59.7 kB]                                                                       
      
Get:8 http://debian.heanet.ie/debian/ testing/main tomcat7 all 7.0.42-1 [47.4 
kB]                                                                             
       
Fetched 5,331 kB in 6s (768 kB/s)                                               
                                                                                
     
Preconfiguring packages ...
Selecting previously unselected package authbind.
(Reading database ... 158908 files and directories currently installed.)
Unpacking authbind (from .../authbind_2.1.1_amd64.deb) ...
Selecting previously unselected package libcommons-pool-java.
Unpacking libcommons-pool-java (from .../libcommons-pool-java_1.6-2_all.deb) ...
Selecting previously unselected package libcommons-dbcp-java.
Unpacking libcommons-dbcp-java (from .../libcommons-dbcp-java_1.4-3_all.deb) ...
Selecting previously unselected package libecj-java.
Unpacking libecj-java (from .../libecj-java_3.8.2-4_all.deb) ...
Selecting previously unselected package libgeronimo-jta-1.1-spec-java.
Unpacking libgeronimo-jta-1.1-spec-java (from 
.../libgeronimo-jta-1.1-spec-java_1.1.1-3_all.deb) ...
Selecting previously unselected package libtomcat7-java.
Unpacking libtomcat7-java (from .../libtomcat7-java_7.0.42-1_all.deb) ...
Selecting previously unselected package tomcat7-common.
Unpacking tomcat7-common (from .../tomcat7-common_7.0.42-1_all.deb) ...
Selecting previously unselected package tomcat7.
Unpacking tomcat7 (from .../tomcat7_7.0.42-1_all.deb) ...
Processing triggers for man-db ...
Setting up authbind (2.1.1) ...
Setting up libcommons-pool-java (1.6-2) ...
Setting up libcommons-dbcp-java (1.4-3) ...
Setting up libecj-java (3.8.2-4) ...
Setting up libgeronimo-jta-1.1-spec-java (1.1.1-3) ...
Setting up libtomcat7-java (7.0.42-1) ...
Setting up tomcat7-common (7.0.42-1) ...
Setting up tomcat7 (7.0.42-1) ...
[ ok ] Starting Tomcat servlet engine: tomcat7.
root@debian:/home/martin/Downloads# apt-get install gradle
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gradle : Depends: libgradle-plugins-java (= 1.4-2) but it is not going to be 
installed
E: Unable to correct problems, you have held broken packages.
root@debian:/home/martin/Downloads# apt-get install libgradle-plugins-java
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgradle-plugins-java : Depends: libjetty-extra-java but it is not going to 
be installed
E: Unable to correct problems, you have held broken packages.
root@debian:/home/martin/Downloads# apt-get install libjetty-extra-java
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libjetty-extra-java : Depends: libtomcat6-java (>= 6.0.20-2) but it is not 
going to be installed
E: Unable to correct problems, you have held broken packages.



-- System Information:
Debian Release: jessie/sid
  APT prefers testing-updates
  APT policy: (500, 'testing-updates'), (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 3.10-3-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_IE.UTF-8, LC_CTYPE=en_IE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages gradle depends on:
ii  ant                      1.9.2-1
ii  default-jre-headless     1:1.7-49
ii  libdom4j-java            1.6.1+dfsg.3-2
pn  libgradle-core-java      <none>
pn  libgradle-plugins-java   <none>
ii  libjaffl-java            0.5.9-4
ii  libjaxen-java            1.1.6-1
ii  libjna-java              3.2.7-4+b1
ii  libjnr-posix-java        1.1.8-2
pn  libkryo-java             <none>
pn  libnative-platform-java  <none>
ii  libwagon-java            1.0.0-4

gradle recommends no packages.

gradle suggests no packages.

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to