Vincent Bernat a écrit , Le 16/12/2013 17:39:
  ❦  9 décembre 2013 18:53 CET, Gilles Filippini <p...@debian.org> :

You may encounter other NoClassDefFound errors which are solved by
adding
"/usr/share/java/asm3-commons.jar:/usr/share/java/antlr3-runtime.jar:/usr/share/java/jaffl.jar:/usr/share/java/jnr-posix.jar:/usr/share/java/constantine.jar:/usr/share/java/guava.jar:"
to the classpath into the launchers /usr/bin/sikuli*.

This solved the NoClassDefFound errors but I am now stuck later. I get a
popup "starting - pls. wait" but nothing happens. In the console, I

Please try again with "-Dsikuli.console=false" in the
/usr/bin/sikuli-ide launcher. You should have more messages in the
console then.

I get that in the console:

Exception in thread "main" java.lang.NoClassDefFoundError: 
com/explodingpixels/macwidgets/MacUtils
         at org.sikuli.ide.SikuliIDE.initToolbar(SikuliIDE.java:1661)
         at org.sikuli.ide.SikuliIDE.initSikuliIDE(SikuliIDE.java:315)
         at org.sikuli.ide.SikuliIDE.<init>(SikuliIDE.java:242)
         at org.sikuli.ide.SikuliIDE.getInstance(SikuliIDE.java:347)
         at org.sikuli.ide.SikuliIDE.main(SikuliIDE.java:235)
Caused by: java.lang.ClassNotFoundException: 
com.explodingpixels.macwidgets.MacUtils
         at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
         at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
         at java.security.AccessController.doPrivileged(Native Method)
         at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
         at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
         at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
         at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
         ... 5 more


Hmmm... That's strange because this class should be defined in /usr/share/java/mac_widgets.jar which is in the classpath defined into /usr/bin/sikuli-ide:
pini@pini:~$ unzip -l /usr/share/java/mac_widgets.jar | grep MacUtils
      957  2012-06-25 22:50   com/explodingpixels/macwidgets/MacUtils.class

Could you please check that this jar is present on your system, and is correctly specified in the classpath?

Thanks,

_g.

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to