Your message dated Wed, 5 Feb 2014 16:13:52 +0100
with message-id 
and subject line Re: Bug#695108: mh_make fails to find log4j for quartz
has caused the Debian Bug report #695108,
regarding mh_make fails to find log4j for quartz
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact

Debian Bug Tracking System
Contact with problems
--- Begin Message ---
Package: maven-debian-helper
Version: 1.1
Severity: normal


mh_make fails with the following:

[INFO] ------------------------------------------------------------------------
[INFO] Failed to resolve artifact.

1) log4j:log4j:jar:debian

  Try downloading the file manually from the project website.

  Then, install it using the command: 
      mvn install:install-file -DgroupId=log4j -DartifactId=log4j 
-Dversion=debian -Dpackaging=jar -Dfile=/path/to/file

  Alternatively, if you host your own repository you can deploy the file there: 
      mvn deploy:deploy-file -DgroupId=log4j -DartifactId=log4j 
-Dversion=debian -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] 

  Path to dependency: 
    1) org.quartz-scheduler:quartz:jar:2.1.6
    2) log4j:log4j:jar:debian

1 required artifact is missing.

for artifact: 

from the specified remote repositories:
  central (

-- System Information:
Debian Release: 6.0.6
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable'), (200, 'testing'), (100, 
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-0.bpo.3-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages maven-debian-helper depends on:
ii  default-jdk                1:1.6-40      Standard Java or Java compatible D
ii  libmaven-clean-plugin-java 2.3-3         Maven clean plugin
ii  libmaven-compiler-plugin-j 2.0.2-4       Maven compiler plugin
ii  libmaven-jar-plugin-java   2.2-4         Maven Jar plugin
ii  libmaven-resources-plugin- 2.3-5         Maven resources plugin
ii  libmaven-site-plugin-java  2.1-1         Maven Site Plugin for generating a
ii  libplexus-velocity-java    1.1.7-3       Plexus component interface to velo
ii  libsurefire-java           2.4.3-3       Surefire test framework for Java
ii  maven-repo-helper          1.7.1~bpo60+1 Helper tools for including Maven m
ii  maven2                     2.2.1-5       Java software project management a
ii  velocity                   1.6.2-4       Java-based template engine for web

Versions of packages maven-debian-helper recommends:
ii  apt-file                      2.4.0      search for files within Debian pac

Versions of packages maven-debian-helper suggests:
pn  libmaven-javadoc-plugin-java  <none>     (no description available)

-- no debconf information

--- End Message ---
--- Begin Message ---
Control: fixed -1 1.6.6

On Wed, Feb 5, 2014 at 4:05 PM, Emmanuel Bourg <> wrote:
> I tried with maven-debian-helper 1.6.6 and it worked fine. I don't know
> when this got fixed though.

At least someone can now work toward #694341 which is what all I cared :)

--- End Message ---
This is the maintainer address of Debian's Java team
Please use for discussions and questions.

Reply via email to