On 30 Mar 2014 20:16, "Steven Chamberlain" <ste...@pyro.eu.org> wrote:
>
> Control: tags 742405 + patch
>
> On 28/03/14 20:30, Steven Chamberlain wrote:
> > This doesn't seem right to me.  "zookeeper ftbfs without openjdk" sounds
> > like a build dependency should be more specific - instead of depending
> > on default-jdk (which may or may not be suitable).
>
> Yes, it builds fine if the build-dependency is changed from default-jdk
> to openjdk-7-jdk

Right, but this does not comply with the Java policy, which requires
default-jdk as the build dependency. This allows migrations between
different versions of openjdk, say.

Zookeeper has a versioned build-dep to require Java 1.6, but the epoch was
out of date. It's been fixed in git.

Tim
__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to