Package: lwjgl
Version: 2.7.1+dfsg-3
Severity: serious
Usertags: goto-cc

During a rebuild of all Debian packages in a clean sid chroot (using cowbuilder
and pbuilder) the build failed with the following error.

[...]
I: Running /usr/bin/dpkg-buildpackage -rfakeroot -us -uc ${DEBBUILDOPTS}
dpkg-buildpackage: source package lwjgl
dpkg-buildpackage: source version 2.7.1+dfsg-3
dpkg-buildpackage: source distribution unstable
dpkg-buildpackage: source changed by Michael Gilbert <mgilb...@debian.org>
 dpkg-source --before-build lwjgl-2.7.1+dfsg
dpkg-buildpackage: host architecture amd64

dpkg-source: warning: unknown information field 'Dm-Upload-Allowed' in input 
data in general section of control info file
dpkg-checkbuilddeps: Build conflicts: binutils-gold
dpkg-buildpackage: warning: build dependencies/conflicts unsatisfied; aborting
dpkg-buildpackage: warning: (Use -d flag to override.)

While you may with to cleanup the DM-Upload-Allowed bit, the build conflicts on
binutils-gold is the main problem:

~/lwjgl-2.7.1+dfsg# apt-cache show binutils
Package: binutils
Version: 2.24.51.20140425-1
Installed-Size: 18611
Maintainer: Matthias Klose <d...@debian.org>
Architecture: amd64
Replaces: binutils-gold (<< 2.20.51.20100415), binutils-mingw-w64-i686 (<< 
2.23.52.20130612-1+3), binutils-mingw-w64-x86-64 (<< 2.23.52.20130612-1+3)
Provides: binutils-gold, elf-binutils

Removing binutils is obviously not an option.

Best,
Michael

Attachment: pgpWF6utuZuiR.pgp
Description: PGP signature

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to