Source: openjpa
Version: 2.2.2-1
Severity: important
User: debian-j...@lists.debian.org
Usertags: openjdk-8-transition

Hi,

During a rebuild of all Java packages in sid with OpenJDK 8,
this package failed to build with the following error:


    [INFO] Compiling 161 source files to 
/«PKGBUILDDIR»/openjpa-lib/target/classes
    [INFO] -------------------------------------------------------------
    [ERROR] COMPILATION ERROR : 
    [INFO] -------------------------------------------------------------
    [ERROR] 
/«PKGBUILDDIR»/openjpa-lib/src/main/java/org/apache/openjpa/lib/util/concurrent/NullSafeConcurrentHashMap.java:[303,15]
 error: keySet() in NullSafeConcurrentHashMap cannot override keySet() in 
ConcurrentHashMap
    [INFO] 1 error
    [INFO] -------------------------------------------------------------


This issue has been fixed upstream and will be part of the 2.4.0 release:
    https://issues.apache.org/jira/browse/OPENJPA-2441

The full build log is available from:
    
http://87.98.165.193/debian/openjdk8-rebuild/logs-failed-jdk8/openjpa_2.2.2-1_unstable_jdk8.log

OpenJDK 8 packages are available for testing here:
    http://87.98.165.193/debian/openjdk-8u5-b13/

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to