Package: proguard
Version: 4.11-1
Severity: important
User: debian-j...@lists.debian.org
Usertags: openjdk-8-transition

proguard is unable to process the bytecode produced by Java 8. This
breaks the build of the mobile-atlas-creator package with OpenJDK 8:

http://87.98.165.193/debian/openjdk8-rebuild/logs-failed-jdk8/mobile-atlas-creator_1.9.16+dfsg1-1_unstable_jdk8.log

shrink:
 [proguard] ProGuard, version 4.8
 [proguard] Reading program jar
[/«BUILDDIR»/mobile-atlas-creator-1.9.16+dfsg1/Mobile_Atlas_Creator.jar]
 [proguard] Reading library jar
[/usr/lib/jvm/java-8-openjdk-amd64/jre/lib/rt.jar]

BUILD FAILED
/«BUILDDIR»/mobile-atlas-creator-1.9.16+dfsg1/build.xml:203: Can't read
[/usr/lib/jvm/java-8-openjdk-amd64/jre/lib/rt.jar] (Can't process class
[com/oracle/net/Sdp$1.class] (Unsupported class version number [52.0]
(maximum 51.0, Java 1.7)))

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to