Source: eclipse
Version: 3.8.1-5.1
Severity: important
User: debian-j...@lists.debian.org
Usertags: openjdk-8-transition

Hi,

During a rebuild of all Java packages in sid with OpenJDK 8,
this package failed to build with the following error:

    [mkdir] Created dir: 
/«PKGBUILDDIR»/build/eclipse-3.8.1-src/plugins/org.eclipse.equinox.event/@dot
    [javac] Compiling 14 source files to 
/«PKGBUILDDIR»/build/eclipse-3.8.1-src/plugins/org.eclipse.equinox.event/@dot
    [javac] javac: invalid target release: jsr14
    [javac] Usage: javac <options> <source files>
    [javac] use -help for a list of possible options

A fix for this issue has been committed in the Git repository on Alioth,
but another error still breaks the build with Java 8:

     [exec] org.eclipse.osgi error loading hook: 
org.eclipse.core.runtime.internal.adaptor.EclipseLogHook
     [exec] java.lang.Error: Unresolved compilation problem:
     [exec]     Duplicate methods named spliterator with the parameters () and 
() are inherited from the types Collection<K> and Iterable<K>
     [exec]
     [exec]     at 
org.eclipse.osgi.internal.baseadaptor.ArrayMap.<init>(ArrayMap.java:23)
     [exec]     at 
org.eclipse.equinox.log.internal.ExtendedLogReaderServiceFactory.<init>(ExtendedLogReaderServiceFactory.java:53)
     [exec]     at 
org.eclipse.equinox.log.internal.LogServiceManager.<init>(LogServiceManager.java:27)
     [exec]     at 
org.eclipse.core.runtime.internal.adaptor.EclipseLogHook.<init>(EclipseLogHook.java:71)
     [exec]     at 
sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

Note that unlike the similar errors in the eclipse-* packages,
this one is not fixed by upgrading the ecj package to the version 3.10.0.

Attachment: signature.asc
Description: OpenPGP digital signature

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to