Your message dated Thu, 16 Oct 2014 12:00:11 +0000
with message-id <e1xejj1-00021d...@franck.debian.org>
and subject line Bug#733488: fixed in libjna-java 4.1.0-1
has caused the Debian Bug report #733488,
regarding libjna-java: Update the jna library to a current upstream version
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
733488: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=733488
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: libjna-java
Version: 3.2.7-4
Severity: important

Dear Maintainer,

is it possible to update the libjna-java package to a current (or at least
newer than 3.4.0) version of the JNA library?

Version 3.2.7 has the following bug which makes the package more or less
unusable for my code:
https://java.net/jira/browse/JNA-185

Thanks in advance!
Jonas Wolz






-- System Information:
Debian Release: 7.3
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.2.0-4-amd64 (SMP w/8 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libjna-java depends on:
ii  libc6    2.13-38
ii  libffi5  3.0.10-3

libjna-java recommends no packages.

Versions of packages libjna-java suggests:
pn  libjna-java-doc  <none>

--- End Message ---
--- Begin Message ---
Source: libjna-java
Source-Version: 4.1.0-1

We believe that the bug you reported is fixed in the latest version of
libjna-java, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 733...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Emmanuel Bourg <ebo...@apache.org> (supplier of updated libjna-java package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Thu, 16 Oct 2014 00:23:15 +0200
Source: libjna-java
Binary: libjna-java libjna-jni libjna-platform-java libjna-java-doc
Architecture: source amd64 all
Version: 4.1.0-1
Distribution: unstable
Urgency: low
Maintainer: Debian Java maintainers 
<pkg-java-maintainers@lists.alioth.debian.org>
Changed-By: Emmanuel Bourg <ebo...@apache.org>
Description:
 libjna-java - Dynamic access of native libraries from Java without JNI
 libjna-java-doc - Dynamic access of native libraries from Java without JNI 
(documen
 libjna-jni - Dynamic access of native libraries from Java without JNI (native
 libjna-platform-java - Dynamic access of native libraries from Java without 
JNI (platfor
Closes: 654084 733488 743732
Changes:
 libjna-java (4.1.0-1) unstable; urgency=low
 .
   * Team upload
 .
   [ Andrew Ross ]
   * New upstream release (Closes: #733488)
   * Refreshed the patches (up to version 3.4.1)
   * Link javadoc to default-jdk API
   * Remove Michael Koch <konque...@gmx.de> from uploaders (Closes: #654084).
   * Use hardening-wrapper to correct lintian warnings.
   * Update d/watch for new upstream location
 .
   [ Emmanuel Bourg ]
   * Refreshed the patches (up to version 4.1.0)
   * Removed 08-multiarch-support.patch (merged upstream since JNA 3.5.0)
   * Removed 02-builddir.patch (merged upstream since 4.0.0)
   * Removed 05-support-gnu-kfreebsd.patch (merged upstream since 4.0.0)
   * Added a default implementation of Structure.getFieldOrder() to preserve
     the compatibility with JNA < 3.5.0
   * Moved libjnidispatch.so into its own new arch any libjna-jni package
   * Install libjnidispatch.so in a multiarch path
   * Install the Maven artifacts for the platform jar (Closes: #743732)
   * Moved platform.jar to its own libjna-platform-java package
   * Added a repack script to clean the upstream tarball
   * Install the upstream changelog
   * debian/control:
     - Use canonical URLs for the Vcs-* fields
     - Standards-Version updated to 3.9.6 (no changes)
   * Switch to debhelper level 9
   * debian/copyright:
     - Updated to the Copyright Format 1.0
     - Fixed the short name of the license applied to the debian/* files
     - JNA is now dual licensed under the LGPL-2.1+ or the Apache-2.0 license
Checksums-Sha1:
 fb88ed541353ad41bdee2f40608ddab11aa76339 2358 libjna-java_4.1.0-1.dsc
 e0ff231a0038445e5961c453ec2624db875d14d7 664704 libjna-java_4.1.0.orig.tar.xz
 ef22e8a57b426875b85dfa74a0b0fddcd69ab5a1 9220 libjna-java_4.1.0-1.debian.tar.xz
 ca284a2efa4461bfd4fb38b0828747c8988477e8 43848 libjna-jni_4.1.0-1_amd64.deb
 d298c0c95eb7fa5ca8787f1ffce81f7daffab596 163112 libjna-java_4.1.0-1_all.deb
 b4015f0df979247bd663a1ea1693036d300e7948 593686 
libjna-platform-java_4.1.0-1_all.deb
 0d3f58c2f3198f750922751b799ccdaab4873670 1101636 
libjna-java-doc_4.1.0-1_all.deb
Checksums-Sha256:
 1c19f4eca9ba588aa3cd0904245f27b2892cc359279f361bee7456cf97da5ab5 2358 
libjna-java_4.1.0-1.dsc
 7a3997a34f20a4fa0d5b0f4e35dd4d50616bcaf3d3104a2c86afa8bed49c94fb 664704 
libjna-java_4.1.0.orig.tar.xz
 556c62b2e5b08fb90a541f4c287db329127c2d407d7a57e1ab0abd71e203a5ca 9220 
libjna-java_4.1.0-1.debian.tar.xz
 a6195c6e9e0a25b713796efb5102633915453f3e59fc50fa9c62cb27645718e0 43848 
libjna-jni_4.1.0-1_amd64.deb
 08a0681dcf21ee20ad5249642ba64f3519676471ee82d43d57c6dc69193c8a82 163112 
libjna-java_4.1.0-1_all.deb
 b9123e84b2b70be9954bee4c7e96438f0507901f17be8d5edb60697afeddf530 593686 
libjna-platform-java_4.1.0-1_all.deb
 c22ee3ee02bba3811f90c6404dfccda5b36c0e7475244a469195d3d6213fa34e 1101636 
libjna-java-doc_4.1.0-1_all.deb
Files:
 da372dc88336bce2a404fc979929f7c7 2358 java optional libjna-java_4.1.0-1.dsc
 550be6ce04036cc5d60d538d3f53d54b 664704 java optional 
libjna-java_4.1.0.orig.tar.xz
 4dc27f7c8419706b96c0e0b131d149f6 9220 java optional 
libjna-java_4.1.0-1.debian.tar.xz
 d53c256338ffb5e6573e7af2edff7fd3 43848 java optional 
libjna-jni_4.1.0-1_amd64.deb
 3d5242e15b58ef4694ca5051443b6167 163112 java optional 
libjna-java_4.1.0-1_all.deb
 56969a6b6062cafb3b9162da7250fc47 593686 java optional 
libjna-platform-java_4.1.0-1_all.deb
 55d27610dab32ce25a3184d728c10791 1101636 doc optional 
libjna-java-doc_4.1.0-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBAgAGBQJUPvedAAoJEPUTxBnkudCsgPoP+gIHtpgUqXYcse+Xuu3HFzWo
744goyxaRMwD07xHbW3KyPKYvo2oiYR4EpxF+66jqq5w4QeKCdaDq1401kvubqMp
hl2L6qnUi8JUG/gAuKQbvbaEcdiPSZvn4FjvKyZpNSI1CohvVViUh2KjnAlNRa3B
tAWzpEP1Ej8aOLcwdArp3AOaLiBwEkrXyhtHlF/y+0d/IxgviICjY7hOtVZAOr9D
yY8fUlBHfV4CnUCChOjBpgGRiUHgtCY/rAN4MbjBIHm7ZALzhT5CxuoC6NJYatLd
nvOeeKHtpXyvZgVyWq9p1cYSqayeyZ2pmHDQYRGMd4JSk0WspAWc5jJLPNGFZU5M
daNOfW3A2xh+hdRxADEsgVx+GkyULV5T8Hqeigw+yaoyIQFGT0591VhroYS0iKmo
rHAnp5Yl/itzpTXIl2oUcxT4RDHPMBC1Di9+/QpdvFn8xCxNXq65fOCSuadUN/z1
JFVk2veXD33D92MbxiC4r+rBK6S86yttJ3HKF8d107hpScj8e0AbGacbW9jFXMUK
Zj2obc5dKYdqHgfjtve72TrJjh7qJX1K2zGoDkpc0KpfMgVTmMne6nF3BCJqgll+
zIaAMqhi73g75tMuV+9Ns0dkLOd5F1KVTMK/zO12xjxU6DWpdvkZlQhpAnVcITjx
3xF1tJI4WfBIj1TGT407
=z98W
-----END PGP SIGNATURE-----

--- End Message ---
__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to