Your message dated Tue, 28 Oct 2014 06:48:54 +0000
with message-id <e1xj0am-0001wv...@franck.debian.org>
and subject line Bug#729171: fixed in jruby 1.5.6-8
has caused the Debian Bug report #729171,
regarding jruby -S gem: EOFException in 
org.joda.time.tz.ZoneInfoProvider.readZoneInfoMap
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
729171: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=729171
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: jruby
Version: 1.5.6-6
Severity: normal

Dear Maintainer,

when I run 'jruby -S gem' as user I get the EOFException below. The expected 
behaviour would be that only the RubyGems help is printed.

Apparently some expected time zone data file cannot be read? I think a file 
"ZoneInfoMap" is read at this point. It is present in jruby.jar:

$ unzip -l /usr/lib/jruby/lib/jruby.jar "*ZoneInfoMap"
Archive:  /usr/lib/jruby/lib/jruby.jar
  Length      Date    Time    Name
---------  ---------- -----   ----
    11701  2013-08-22 22:46   org/joda/time/tz/data/ZoneInfoMap
---------                     -------
    11701                     1 file

My time zone is Europe/Berlin.

Exception message:

Exception in thread "main" java.io.EOFException
  at java.io.DataInputStream.readFully(DataInputStream.java:197)
  at java.io.DataInputStream.readUTF(DataInputStream.java:609)
  at java.io.DataInputStream.readUTF(DataInputStream.java:564)
  at 
org.joda.time.tz.ZoneInfoProvider.readZoneInfoMap(ZoneInfoProvider.java:278)
  at 
org.joda.time.tz.ZoneInfoProvider.loadZoneInfoMap(ZoneInfoProvider.java:256)
  at org.joda.time.tz.ZoneInfoProvider.<init>(ZoneInfoProvider.java:123)
  at org.joda.time.tz.ZoneInfoProvider.<init>(ZoneInfoProvider.java:82)
  at org.joda.time.DateTimeZone.getDefaultProvider(DateTimeZone.java:490)
  at org.joda.time.DateTimeZone.setProvider0(DateTimeZone.java:444)
  at org.joda.time.DateTimeZone.<clinit>(DateTimeZone.java:116)
  at org.jruby.RubyTime.getLocalTimeZone(RubyTime.java:96)
  at org.jruby.RubyTime$1.allocate(RubyTime.java:171)
  at org.jruby.RubyClass.allocate(RubyClass.java:220)
  at org.jruby.RubyTime.newInstance(RubyTime.java:655)
  at 
org.jruby.RubyTime$s_method_0_0$RUBYINVOKER$newInstance.call(org/jruby/RubyTime$s_method_0_0$RUBYINVOKER$newInstance.gen:65535)
  at 
org.jruby.runtime.callsite.CachingCallSite.cacheAndCall(CachingCallSite.java:289)
  at org.jruby.runtime.callsite.CachingCallSite.call(CachingCallSite.java:108)
  at org.jruby.ast.CallNoArgNode.interpret(CallNoArgNode.java:61)
  at org.jruby.ast.CallNoArgNode.interpret(CallNoArgNode.java:61)
  at org.jruby.ast.CallOneArgNode.interpret(CallOneArgNode.java:57)
  at org.jruby.ast.LocalAsgnNode.interpret(LocalAsgnNode.java:123)
  at org.jruby.ast.NewlineNode.interpret(NewlineNode.java:104)
  at org.jruby.ast.BlockNode.interpret(BlockNode.java:71)
  at 
org.jruby.evaluator.ASTInterpreter.evalClassDefinitionBody(ASTInterpreter.java:196)
  at org.jruby.ast.ClassNode.interpret(ClassNode.java:141)
  at org.jruby.ast.NewlineNode.interpret(NewlineNode.java:104)
  at org.jruby.ast.BlockNode.interpret(BlockNode.java:71)
  at org.jruby.ast.RootNode.interpret(RootNode.java:129)
  at org.jruby.Ruby.loadFile(Ruby.java:2553)
  at org.jruby.runtime.load.ExternalScript.load(ExternalScript.java:61)
  at 
org.jruby.runtime.load.LoadService.tryLoadingLibraryOrScript(LoadService.java:671)
  at org.jruby.runtime.load.LoadService.smartLoad(LoadService.java:314)
  at org.jruby.runtime.load.LoadService.require(LoadService.java:357)
  at org.jruby.runtime.load.LoadService.lockAndRequire(LoadService.java:289)
  at org.jruby.RubyKernel.requireCommon(RubyKernel.java:984)
  at org.jruby.RubyKernel.require(RubyKernel.java:967)
  at 
org.jruby.RubyKernel$s_method_1_0$RUBYFRAMEDINVOKER$require.call(org/jruby/RubyKernel$s_method_1_0$RUBYFRAMEDINVOKER$require.gen:65535)
  at 
org.jruby.internal.runtime.methods.JavaMethod$JavaMethodOneOrNBlock.call(JavaMethod.java:319)
  at 
org.jruby.runtime.callsite.CachingCallSite.cacheAndCall(CachingCallSite.java:309)
  at org.jruby.runtime.callsite.CachingCallSite.call(CachingCallSite.java:148)
  at org.jruby.ast.FCallOneArgNode.interpret(FCallOneArgNode.java:36)
  at org.jruby.ast.NewlineNode.interpret(NewlineNode.java:104)
  at org.jruby.ast.BlockNode.interpret(BlockNode.java:71)
  at org.jruby.ast.RootNode.interpret(RootNode.java:129)
  at org.jruby.Ruby.loadFile(Ruby.java:2553)
  at org.jruby.runtime.load.ExternalScript.load(ExternalScript.java:61)
  at 
org.jruby.runtime.load.LoadService.tryLoadingLibraryOrScript(LoadService.java:671)
  at org.jruby.runtime.load.LoadService.smartLoad(LoadService.java:314)
  at org.jruby.runtime.load.LoadService.require(LoadService.java:357)
  at org.jruby.runtime.load.LoadService.lockAndRequire(LoadService.java:289)
  at org.jruby.RubyKernel.requireCommon(RubyKernel.java:984)
  at org.jruby.RubyKernel.require(RubyKernel.java:967)
  at 
org.jruby.RubyKernel$s_method_1_0$RUBYFRAMEDINVOKER$require.call(org/jruby/RubyKernel$s_method_1_0$RUBYFRAMEDINVOKER$require.gen:65535)
  at 
org.jruby.internal.runtime.methods.JavaMethod$JavaMethodOneOrNBlock.call(JavaMethod.java:319)
  at 
org.jruby.runtime.callsite.CachingCallSite.cacheAndCall(CachingCallSite.java:309)
  at org.jruby.runtime.callsite.CachingCallSite.call(CachingCallSite.java:148)
  at org.jruby.ast.FCallOneArgNode.interpret(FCallOneArgNode.java:36)
  at org.jruby.ast.NewlineNode.interpret(NewlineNode.java:104)
  at org.jruby.ast.BlockNode.interpret(BlockNode.java:71)
  at org.jruby.ast.RootNode.interpret(RootNode.java:129)
  at org.jruby.Ruby.loadFile(Ruby.java:2553)
  at org.jruby.runtime.load.ExternalScript.load(ExternalScript.java:61)
  at 
org.jruby.runtime.load.LoadService.tryLoadingLibraryOrScript(LoadService.java:671)
  at org.jruby.runtime.load.LoadService.smartLoad(LoadService.java:314)
  at org.jruby.runtime.load.LoadService.require(LoadService.java:357)
  at org.jruby.runtime.load.LoadService.lockAndRequire(LoadService.java:289)
  at org.jruby.RubyKernel.requireCommon(RubyKernel.java:984)
  at org.jruby.RubyKernel.require(RubyKernel.java:967)
  at 
org.jruby.RubyKernel$s_method_1_0$RUBYFRAMEDINVOKER$require.call(org/jruby/RubyKernel$s_method_1_0$RUBYFRAMEDINVOKER$require.gen:65535)
  at 
org.jruby.internal.runtime.methods.JavaMethod$JavaMethodOneOrNBlock.call(JavaMethod.java:319)
  at 
org.jruby.runtime.callsite.CachingCallSite.cacheAndCall(CachingCallSite.java:309)
  at org.jruby.runtime.callsite.CachingCallSite.call(CachingCallSite.java:148)
  at usr.lib.jruby.bin.gem.__file__(gem:8)
  at usr.lib.jruby.bin.gem.load(gem)
  at org.jruby.Ruby.runScript(Ruby.java:692)
  at org.jruby.Ruby.runNormally(Ruby.java:575)
  at org.jruby.Ruby.runFromMain(Ruby.java:418)
  at org.jruby.Main.run(Main.java:286)
  at org.jruby.Main.run(Main.java:128)
  at org.jruby.Main.main(Main.java:97)
RubyGems is a sophisticated package manager for Ruby.  This is a
basic help message containing pointers to more information.

  Usage:
    gem -h/--help
    gem -v/--version
    gem command [arguments...] [options...]

  Examples:
    gem install rake
    gem list --local
    gem build package.gemspec
    gem help install

  Further help:
    gem help commands            list all 'gem' commands
    gem help examples            show some examples of usage
    gem help platforms           show information about platforms
    gem help <COMMAND>           show help on COMMAND
                                   (e.g. 'gem help install')
    gem server                   present a web page at
                                 http://localhost:8808/
                                 with info about installed gems
  Further information:
    http://rubygems.rubyforge.org

-- System Information:
Debian Release: jessie/sid
  APT prefers testing
  APT policy: (700, 'testing'), (650, 'unstable'), (600, 'experimental'), (500, 
'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.11-1-amd64 (SMP w/8 CPU cores)
Locale: LANG=de_DE.utf8, LC_CTYPE=de_DE.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages jruby depends on:
ii  libjffi-jni                    1.0.2-11
ii  openjdk-7-jre [java6-runtime]  7u21-2.3.9-5

Versions of packages jruby recommends:
ii  ri1.8  1.8.7.358-8

jruby suggests no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
Source: jruby
Source-Version: 1.5.6-8

We believe that the bug you reported is fixed in the latest version of
jruby, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 729...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
tony mancill <tmanc...@debian.org> (supplier of updated jruby package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Mon, 27 Oct 2014 23:27:54 -0700
Source: jruby
Binary: jruby
Architecture: source all
Version: 1.5.6-8
Distribution: unstable
Urgency: medium
Maintainer: Debian Java Maintainers 
<pkg-java-maintainers@lists.alioth.debian.org>
Changed-By: tony mancill <tmanc...@debian.org>
Description:
 jruby      - 100% pure-Java implementation of Ruby
Closes: 729171
Changes:
 jruby (1.5.6-8) unstable; urgency=medium
 .
   [ tony mancill ]
   * Team upload.
   * Recommend "ri" instead of "ri1.8" (ruby interpreter)
   * Use DH9 instead of version 6.
   * Rebuild against a non-broken joda-time. (Closes: #729171)
   * Bump Standards-Version to 3.9.6 (no changes).
 .
   [ Emmanuel Bourg ]
   * Removed the build dependency on libemma-java
Checksums-Sha1:
 2084faff6bdd244bec79859fb20e4c3a8ba03093 2283 jruby_1.5.6-8.dsc
 e166a1eaea0f617cb5749734a7ae78966fcb2eba 33388 jruby_1.5.6-8.debian.tar.xz
 074efb95715b2c6fb39a6fc540fa6679cfbe231d 7831442 jruby_1.5.6-8_all.deb
Checksums-Sha256:
 4b5cb667c781457cc3c98ca831be6e7e5b3ee5d614baf30cc5afe1b53ad0fc73 2283 
jruby_1.5.6-8.dsc
 830baf62c30457785980747474c5b74372bfb83957cecd4692e6c31e9de522a8 33388 
jruby_1.5.6-8.debian.tar.xz
 781f643b00211c1796901e31fefb4df37a72411cbe40b3de210baebbff08d6e0 7831442 
jruby_1.5.6-8_all.deb
Files:
 13a87936bc824a0a7135a6e2acef9080 2283 ruby optional jruby_1.5.6-8.dsc
 fb0f9abee27be8511787104296a0cc39 33388 ruby optional 
jruby_1.5.6-8.debian.tar.xz
 6b5fe0562d4aac106ef04858a9cde1d5 7831442 ruby optional jruby_1.5.6-8_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBCgAGBQJUTziwAAoJECHSBYmXSz6WwxcP/3frAEfL+1InIQRyMCOvar7M
OabzrRHZ+QQVhRJI21uNS4ZJEPVCakVjfzDHSI9eJucnDAdaqlkiYlIovEgL3Dvh
ExUMNBic8WrCkvSRr1QkmKcPJXcut/2lXMwvYz4s+EiITfUfqZ1w0DFNNDIITb6U
JTbhq1agxxPEgjirYdDtwrZ+a5NjKaAnmocTNpGTtsCoqIk6qBQ8/w4TrVn8PbXy
4RMpiQc8Tm3jlN8EptzElR/68BsK075yzJrJG6+6nhx29zI8T6S4NbAAbLXcQWxd
E3QFqh3kSaJOFH/2OcaBKsi0D9i+OxZ1T7LxGnGK5dpu+gZ7eE0umn+aUpxO7H34
VkObL79xQCHHHeAo1GZ4Ct2Q69vNJ9Lw7MC30tQP823z6yh3VL6jRGjQ9hX/okn3
+ICcAoiHVDu+7GiRDKrgZmdm3hW46XrWzg0v7sKRWb/HI29IdaKAsCifAOHKCL9c
lzMwfpZmFAaHihM6lSXkSAPcPrSpbAnuGBdLv9AVIDmLh1ylSUT6UAL7BXlsz42o
MWF5xvuJRzFy5YyNs7Yf811k2hqykjbw0NULgeD3x33XWl+aPKDWxXHM1/caGbMN
SGj57Nhyah46mdQi4sZHeBS5Bw2UaRMCwc40unWDge+vbljcAi3R3CohLWDdJwUL
fDJ8A0rXhJT58S94No5/
=xT+i
-----END PGP SIGNATURE-----

--- End Message ---
__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to