Hi Rogério,

Le 15/01/2015 20:56, Rogério Brito a écrit :

> Is there any way to keep the ability to run with gcj?

I don't think this is possible, the Clojure 1.6.0 documentation [1]
states that Java 6 is the minimum version required and gcj is stuck with
Java 5.

> If not, perhaps getting the dependency of clojure1.6 updated to be
> default-jdk would be better (but, if I recall correctly, openjdk 7 didn't
> work on some of the ports---perhaps the kfreebsd ones?---and the changed
> dependency wouldn't really fix this).

I'm not sure we can reliably set a minimum version on the
default-jre-headless dependency. If we set (>= 2:1.6) it will fail again
the next time the epoch is bumped (because 3:1.5 > 2:1.6). But at least
we should replace java2-runtime-headless with java6-runtime-headless.

Emmanuel Bourg

[1] http://clojure.org/getting_started

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to