Source: jython
Version: 2.5.3-6
Severity: grave
Justification: fails to build from source

Hi,

jython Build-Depends on "libjnr-posix-java (>= 3.0.10~)" but the version
of libjnr-posix-java in unstable is only 1.1.8-3. Here is the relevant
dose3 output for the build failure:

    native-architecture: amd64
    report:
     -
      package: src:jython
      version: 2.5.3-6
      architecture: all
      essential: false
      source: jython (= 2.5.3-6)
      status: broken
      reasons:
       -
        missing:
         pkg:
          package: src:jython
          version: 2.5.3-6
          architecture: all
          essential: false
          unsat-dependency: amd64:libjnr-posix-java (>= 3.0.10~)

and for the uninstallability of the jython binary package (thus setting
severity to grave):


    report:
     -
      package: amd64:jython
      version: 2.5.3-6
      architecture: all
      essential: false
      source: jython (= 2.5.3-6)
      status: broken
      reasons:
       -
        missing:
         pkg:
          package: amd64:jython
          version: 2.5.3-6
          architecture: all
          essential: false
          unsat-dependency: amd64:libjnr-posix-java (>= 3.0.10~)

Here is the FTBFS on the reproducible builds platform:

https://reproducible.debian.net/rbuild/unstable/amd64/jython_2.5.3-6.rbuild.log

And here the output from release.d.o about this problem:

https://release.debian.org/migration/testing.pl?package=jython

Since jython is part of the transitive essential set, its unbuildability
also currently makes Debian unbootstrappable:
http://bootstrap.debian.net/essential.html

Thanks!

cheers, josch

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to