Source: libspring-java
Version: 3.2.13-1
Severity: serious
Justification: fails to build from source

Dear Maintainer,

The package fails to build with dpkg-buildpackage and pbuilder in sid: it 
depends on jffi/jruby that's not available:

* What went wrong:
Could not resolve all dependencies for configuration ':spring-context:compile'.
> Could not resolve org.jruby.extras:jffi:debian.
  Required by:
      org.springframework:spring-context:3.2.13.RELEASE > org.jruby:jruby:debian
   > No cached version of org.jruby.extras:jffi:debian available for offline 
mode.

[...]

Caused by: 
org.gradle.api.internal.artifacts.ivyservice.ModuleVersionResolveException: No 
cached version of org.jruby.extras:jffi:debian available for offline mode.

Full build logs are available on the Reproducible Builds builder:
https://reproducible.debian.net/rb-pkg/unstable/amd64/libspring-java.html

-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.19.0-20-generic (SMP w/8 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to