Hi seamlik,

What is the motivation for merging the libraries into the main gradle
package? It's usually a good practice to separate the libraries.

Emmanuel Bourg


Le 09/07/2015 08:52, Kai-Chung Yan a écrit :
> This is an automated email from the git hooks/post-receive script.
> 
> seamlik-guest pushed a commit to branch master
> in repository gradle.
> 
> commit 5ed25919a9a8cd34a186d3bb7e56e431d80e223d
> Author: Kai-Chung Yan <seamli...@gmail.com>
> Date:   Thu Jul 9 03:54:01 2015 +0800
> 
>     Merge libgradle-core-java and libgradle-plugins-java into gradle
> ---
>  debian/changelog                                   |   1 +
>  debian/control                                     | 181 
> +++++++++------------
>  debian/gradle.install                              |   3 +-
>  debian/gradle.jlibs                                |   3 +-
>  ....lintian-overrides => gradle.lintian-overrides} |   0
>  debian/libgradle-core-java.jlibs                   |  13 --
>  debian/libgradle-plugins-java.install              |   1 -
>  debian/libgradle-plugins-java.jlibs                |  36 ----
>  debian/libgradle-plugins-java.lintian-overrides    |   3 -
>  debian/rules                                       |   4 +-
>  10 files changed, 81 insertions(+), 164 deletions(-)
> 
> diff --git a/debian/changelog b/debian/changelog
> index 40d1c5c..3585c03 100644
> --- a/debian/changelog
> +++ b/debian/changelog
> @@ -35,6 +35,7 @@ gradle (2.5-1) UNRELEASED; urgency=low
>      - relax_warnings.diff: strictCompile.gradle is too strict
>    * gradle-doc no longer provides Gradle User Guide and DSL Reference because
>      missing Sonar plugins causes their compilation produce errors.
> +  * Merge libgradle-core-java and libgradle-plugins-java into gradle
>  
>   -- Kai-Chung Yan <seamli...@gmail.com>  Wed, 08 Jul 2015 16:57:30 +0800
>  
> diff --git a/debian/control b/debian/control
> index 0552037..71adcd6 100644
> --- a/debian/control
> +++ b/debian/control
> @@ -77,140 +77,107 @@ Homepage: http://gradle.org
>  
>  Package: gradle
>  Architecture: all
> -Depends: default-jre-headless (>= 1:1.6),
> -         groovy2 (>= 2.3.10),
> -         libcommons-io-java,
> -         libdom4j-java,
> -         libgradle-core-java (>= ${binary:Version}),
> -         libgradle-plugins-java (>= ${binary:Version}),
> -         libjaxen-java,
> -         libslf4j-java,
> -         ${misc:Depends}
> -Replaces: libgradle-core-java (<< 1.12)
> -Recommends: default-jdk,
> -            libcodenarc-groovy-java,
> -            scala
> -Description: Groovy based build system
> - Gradle is a build system written in Groovy. It uses Groovy
> - also as the language for its build scripts. It has a powerful
> - multi-project build support. It has a layer on top of Ivy
> - that provides a build-by-convention integration for Ivy. It
> - gives you always the choice between the flexibility of Ant
> - and the convenience of a build-by-convention behavior.
> -
> -Package: libgradle-core-java
> -Architecture: all
>  Depends: ant,
> +         bnd (>= 2.1.0),
> +         default-jre-headless (>= 1:1.6),
> +         findbugs,
>           groovy2 (>= 2.3.10),
>           ivy,
> +         junit4,
> +         libantlr-java,
>           libasm4-java (>= 5),
>           libatinject-jsr330-api-java,
> +         libbcpg-java,
> +         libclassworlds-java,
> +         libcommons-cli-java,
>           libcommons-collections3-java,
>           libcommons-io-java,
>           libcommons-lang-java (>= 2.6),
> +         libdom4j-java,
> +         libgoogle-gson-java,
>           libguava-java,
>           libhttpclient-java,
>           libhttpcore-java,
>           libjansi-java,
>           libjarjar-java,
> +         libjatl-java,
> +         libjaxen-java,
>           libjcifs-java,
>           libjcip-annotations-java,
> +         libjcommander-java,
> +         libjetty-extra-java,
> +         libjetty-java,
>           libjna-java,
> +         libjs-jquery,
>           libjsch-java,
>           libkryo-java,
>           liblogback-java,
>           libnative-platform-java (>= 0.10),
>           libnekohtml-java,
> -         libreflectasm-java,
> -         libslf4j-java,
> -         libxbean-java,
> -         ${misc:Depends}
> -Breaks: libgradle-wrapper-java (<< 1.3~)
> -Replaces: libgradle-wrapper-java (<< 1.3~),
> -          libgradle-plugins-java (<< 1.12)
> -Description: Groovy based build system - Core library
> - Gradle is a build system written in Groovy. It uses Groovy
> - also as the language for its build scripts. It has a powerful
> - multi-project build support. It has a layer on top of Ivy
> - that provides a build-by-convention integration for Ivy. It
> - gives you always the choice between the flexibility of Ant
> - and the convenience of a build-by-convention behavior.
> - .
> - This package contains the Gradle Core API library.
> -
> -Package: libgradle-plugins-java
> -Architecture: all
> -Depends: bnd (>= 2.1.0),
> -         findbugs,
> -         groovy2 (>= 2.3.10),
> -         junit4,
> -         libantlr-java,
> -         libatinject-jsr330-api-java,
> -         libbcpg-java,
> -         libclassworlds-java,
> -         libcommons-cli-java,
> -         libdom4j-java,
> -         libgoogle-gson-java,
> -         libgradle-core-java (>= ${binary:Version}),
> -         libjatl-java,
> -         libjaxen-java,
> -         libjcommander-java,
> -         libjetty-java,
> -         libjetty-extra-java,
> -         libjs-jquery,
>           libobjenesis-java,
>           libplexus-containers1.5-java,
>           libplexus-interpolation-java,
>           libplexus-utils-java,
>           libpolyglot-maven-java,
> +         libreflectasm-java,
>           librhino-java,
>           libservlet2.5-java,
>           libslf4j-java,
>           libtomcat7-java,
> +         libxbean-java,
>           libxerces2-java,
>           maven (>= 3),
>           testng,
>           ${misc:Depends}
> -Breaks: libgradle-announce-java (<< 1.3~),
> -        libgradle-antlr-java (<< 1.3~),
> -        libgradle-code-quality-java (<< 1.3~),
> -        libgradle-cpp-java (<< 1.3~),
> -        libgradle-ear-java (<< 1.3~),
> -        libgradle-eclipse-java (<< 1.0~),
> -        libgradle-ide-java (<< 1.3~),
> -        libgradle-idea-java (<< 1.0~),
> -        libgradle-javascript-java (<< 1.3~),
> -        libgradle-jetty-java (<< 1.3~),
> -        libgradle-maven-java (<< 1.3~),
> -        libgradle-osgi-java (<< 1.3~),
> -        libgradle-scala-java (<< 1.3~),
> -        libgradle-signing-java (<< 1.3~),
> -        libgradle-core-java (<< 1.12)
> -Replaces: libgradle-announce-java (<< 1.3~),
> -          libgradle-antlr-java (<< 1.3~),
> -          libgradle-code-quality-java (<< 1.3~),
> -          libgradle-cpp-java (<< 1.3~),
> -          libgradle-ear-java (<< 1.3~),
> -          libgradle-eclipse-java (<< 1.0~),
> -          libgradle-ide-java (<< 1.3~),
> -          libgradle-idea-java (<< 1.0~),
> -          libgradle-javascript-java (<< 1.3~),
> -          libgradle-jetty-java (<< 1.3~),
> -          libgradle-maven-java (<< 1.3~),
> -          libgradle-osgi-java (<< 1.3~),
> -          libgradle-scala-java (<< 1.3~),
> -          libgradle-signing-java (<< 1.3~),
> -          libgradle-core-java (<< 1.12)
> -Description: Groovy based build system - All plugins
> - Gradle is a build system written in Groovy. It uses Groovy
> - also as the language for its build scripts. It has a powerful
> - multi-project build support. It has a layer on top of Ivy
> - that provides a build-by-convention integration for Ivy. It
> - gives you always the choice between the flexibility of Ant
> - and the convenience of a build-by-convention behavior.
> +Replaces: libgradle-announce-java,
> +          libgradle-antlr-java,
> +          libgradle-code-quality-java,
> +          libgradle-core-java,
> +          libgradle-cpp-java,
> +          libgradle-ear-java,
> +          libgradle-eclipse-java,
> +          libgradle-ide-java,
> +          libgradle-idea-java,
> +          libgradle-javascript-java,
> +          libgradle-jetty-java,
> +          libgradle-maven-java,
> +          libgradle-osgi-java,
> +          libgradle-plugins-java,
> +          libgradle-scala-java,
> +          libgradle-signing-java,
> +          libgradle-wrapper-java
> +Breaks: libgradle-announce-java,
> +        libgradle-antlr-java,
> +        libgradle-code-quality-java,
> +        libgradle-core-java,
> +        libgradle-cpp-java,
> +        libgradle-ear-java,
> +        libgradle-eclipse-java,
> +        libgradle-ide-java,
> +        libgradle-idea-java,
> +        libgradle-javascript-java,
> +        libgradle-jetty-java,
> +        libgradle-maven-java,
> +        libgradle-osgi-java,
> +        libgradle-plugins-java,
> +        libgradle-scala-java,
> +        libgradle-signing-java,
> +        libgradle-wrapper-java
> +Recommends: default-jdk,
> +            libcodenarc-groovy-java,
> +            scala
> +Description: A powerful build system for the JVM
> + Gradle is a build tool with a focus on build automation and support for
> + multi-language development. If you are building, testing, publishing, and
> + deploying software on any platform, Gradle offers a flexible model that can
> + support the entire development lifecycle from compiling and packaging code 
> to
> + publishing web sites. Gradle has been designed to support build automation
> + across multiple languages and platforms including Java, Scala, Android, 
> C/C++,
> + and Groovy, and is closely integrated with development tools and continuous
> + integration servers including Eclipse, IntelliJ, and Jenkins.
>   .
> - This package contains the standard Gradle plugins except the Sonar and the
> - Sonar Runner plugin, and it does not support Zinc Scala compiler.
> + The Gradle in this package contains the standard Gradle plugins except the
> + Sonar and the Sonar Runner plugin, and it does not support Zinc Scala 
> compiler.
>  
>  Package: gradle-doc
>  Architecture: all
> @@ -218,12 +185,14 @@ Section: doc
>  Depends: default-jdk-doc,
>           groovy2-doc,
>           ${misc:Depends}
> -Description: Documentation for Gradle
> - Gradle is a build system written in Groovy. It uses Groovy
> - also as the language for its build scripts. It has a powerful
> - multi-project build support. It has a layer on top of Ivy
> - that provides a build-by-convention integration for Ivy. It
> - gives you always the choice between the flexibility of Ant
> - and the convenience of a build-by-convention behavior.
> +Description: A powerful build system for the JVM - Documentation
> + Gradle is a build tool with a focus on build automation and support for
> + multi-language development. If you are building, testing, publishing, and
> + deploying software on any platform, Gradle offers a flexible model that can
> + support the entire development lifecycle from compiling and packaging code 
> to
> + publishing web sites. Gradle has been designed to support build automation
> + across multiple languages and platforms including Java, Scala, Android, 
> C/C++,
> + and Groovy, and is closely integrated with development tools and continuous
> + integration servers including Eclipse, IntelliJ, and Jenkins.
>   .
>   This package contains Gradle API Javadoc and Groovydoc.
> \ No newline at end of file
> diff --git a/debian/gradle.install b/debian/gradle.install
> index 5deda1f..42c0235 100644
> --- a/debian/gradle.install
> +++ b/debian/gradle.install
> @@ -1,2 +1,3 @@
>  subprojects/launcher/build/startScripts/gradle     usr/share/gradle/bin
> -subprojects/distributions/src/toplevel/init.d/     usr/share/gradle/
> \ No newline at end of file
> +subprojects/distributions/src/toplevel/init.d/     usr/share/gradle/
> +subprojects/distributions/src/toplevel/media/      usr/share/gradle/
> \ No newline at end of file
> diff --git a/debian/gradle.jlibs b/debian/gradle.jlibs
> index eb46391..36e1dd5 100644
> --- a/debian/gradle.jlibs
> +++ b/debian/gradle.jlibs
> @@ -1,2 +1 @@
> -subprojects/launcher/build/libs/*.jar
> -subprojects/ui/build/libs/*.jar
> \ No newline at end of file
> +subprojects/*/build/libs/*.jar
> \ No newline at end of file
> diff --git a/debian/libgradle-core-java.lintian-overrides 
> b/debian/gradle.lintian-overrides
> similarity index 100%
> rename from debian/libgradle-core-java.lintian-overrides
> rename to debian/gradle.lintian-overrides
> diff --git a/debian/libgradle-core-java.jlibs 
> b/debian/libgradle-core-java.jlibs
> deleted file mode 100644
> index 561f54f..0000000
> --- a/debian/libgradle-core-java.jlibs
> +++ /dev/null
> @@ -1,13 +0,0 @@
> -subprojects/base-services-groovy/build/libs/*.jar
> -subprojects/base-services/build/libs/*.jar
> -subprojects/cli/build/libs/*.jar
> -subprojects/core/build/libs/*.jar
> -subprojects/docs/build/libs/*.jar
> -subprojects/messaging/build/libs/*.jar
> -subprojects/model-core/build/libs/*.jar
> -subprojects/model-groovy/build/libs/*.jar
> -subprojects/native/build/libs/*.jar
> -subprojects/open-api/build/libs/*.jar
> -subprojects/resources/build/libs/*.jar
> -subprojects/tooling-api/build/libs/*.jar
> -subprojects/wrapper/build/libs/*.jar
> \ No newline at end of file
> diff --git a/debian/libgradle-plugins-java.install 
> b/debian/libgradle-plugins-java.install
> deleted file mode 100644
> index 1605337..0000000
> --- a/debian/libgradle-plugins-java.install
> +++ /dev/null
> @@ -1 +0,0 @@
> -subprojects/distributions/src/toplevel/media/     /usr/share/gradle/
> \ No newline at end of file
> diff --git a/debian/libgradle-plugins-java.jlibs 
> b/debian/libgradle-plugins-java.jlibs
> deleted file mode 100644
> index 5807a98..0000000
> --- a/debian/libgradle-plugins-java.jlibs
> +++ /dev/null
> @@ -1,36 +0,0 @@
> -subprojects/announce/build/libs/*.jar
> -subprojects/antlr/build/libs/*.jar
> -subprojects/build-comparison/build/libs/*.jar
> -subprojects/build-init/build/libs/*.jar
> -subprojects/code-quality/build/libs/*.jar
> -subprojects/dependency-management/build/libs/*.jar
> -subprojects/diagnostics/build/libs/*.jar
> -subprojects/ear/build/libs/*.jar
> -subprojects/ide-native/build/libs/*.jar
> -subprojects/ide/build/libs/*.jar
> -subprojects/ivy/build/libs/*.jar
> -subprojects/jacoco/build/libs/*.jar
> -subprojects/javascript/build/libs/*.jar
> -subprojects/jetty/build/libs/*.jar
> -subprojects/language-groovy/build/libs/*.jar
> -subprojects/language-java/build/libs/*.jar
> -subprojects/language-jvm/build/libs/*.jar
> -subprojects/language-native/build/libs/*.jar
> -subprojects/language-scala/build/libs/*.jar
> -subprojects/maven/build/libs/*.jar
> -subprojects/osgi/build/libs/*.jar
> -subprojects/platform-base/build/libs/*.jar
> -subprojects/platform-jvm/build/libs/*.jar
> -subprojects/platform-native/build/libs/*.jar
> -subprojects/platform-play/build/libs/*.jar
> -subprojects/plugin-development/build/libs/*.jar
> -subprojects/plugin-use/build/libs/*.jar
> -subprojects/plugins/build/libs/*.jar
> -subprojects/publish/build/libs/*.jar
> -subprojects/reporting/build/libs/*.jar
> -subprojects/resources-http/build/libs/*.jar
> -subprojects/resources-sftp/build/libs/*.jar
> -subprojects/scala/build/libs/*.jar
> -subprojects/signing/build/libs/*.jar
> -subprojects/testing-native/build/libs/*.jar
> -subprojects/tooling-api-builders/build/libs/*.jar
> \ No newline at end of file
> diff --git a/debian/libgradle-plugins-java.lintian-overrides 
> b/debian/libgradle-plugins-java.lintian-overrides
> deleted file mode 100644
> index d94b591..0000000
> --- a/debian/libgradle-plugins-java.lintian-overrides
> +++ /dev/null
> @@ -1,3 +0,0 @@
> -# Gradle maintains classpath outside of manifest and loads libraries using 
> its
> -# own mechanism.
> -missing-classpath
> \ No newline at end of file
> diff --git a/debian/rules b/debian/rules
> index 2e0e9ab..80628f6 100755
> --- a/debian/rules
> +++ b/debian/rules
> @@ -42,8 +42,8 @@ override_dh_install:
>       dh_install
>  
>       # Remove lintian warning zero-byte-file-in-doc-directory
> -     rm -f 
> debian/gradle-doc/usr/share/doc/gradle/groovydoc/org/gradle/api/distribution/Distribution.html
> -     rm -f 
> debian/gradle-doc/usr/share/doc/gradle/groovydoc/org/gradle/api/initialization/Settings.html
> +     rm 
> debian/gradle-doc/usr/share/doc/gradle/groovydoc/org/gradle/api/distribution/Distribution.html
> +     rm 
> debian/gradle-doc/usr/share/doc/gradle/groovydoc/org/gradle/api/initialization/Settings.html
>  
>  get-orig-source:
>       uscan --download-current-version --force-download --repack 
> --compression xz
> 


__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to