Package: java-package
Version: 0.56
Severity: wishlist

Dear Maintainer,

I'd like to sugest to allow the packages to be built with
ca-certificates-java support, in order to do that I have this patch applied
on my system which works ok, but for the java-package maybe you want to
allow it via an option and not forced.

--- /usr/share/java-package/common.sh~  2014-06-20 11:11:59.000000000 +0200
+++ /usr/share/java-package/common.sh   2014-12-03 14:25:13.000000000 +0100
@@ -123,6 +123,10 @@
 EOF
         error_exit
     fi
+    prepath=""
+    if [ -d "$files"/jre/ ];then prepath="/jre";fi
+    rm -f "$files$prepath"/lib/security/cacerts
+    ln -s /etc/ssl/certs/java/cacerts "$files$prepath"/lib/security/cacerts
     mv "$files" "$dest"
     echo -e " okay.\n"
     fi

Thanks in advance.

-- System Information:
Debian Release: 8.1
  APT prefers stable
  APT policy: (990, 'stable'), (500, 'stable-updates'), (500, 'unstable'), 
(500, 'testing'), (500, 'oldstable'), (101, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.16.0-4-amd64 (SMP w/4 CPU cores)
Locale: LANG=gl_ES.UTF-8, LC_CTYPE=gl_ES.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash
Init: sysvinit (via /sbin/init)

Versions of packages java-package depends on:
ii  debhelper   9.20150101
ii  dpkg-dev    1.17.25
ii  fakeroot    1.20.2-1
ii  libasound2  1.0.28-1
ii  libx11-6    2:1.6.2-3
ii  unzip       6.0-16

Versions of packages java-package recommends:
ii  gcc  4:4.9.2-2

Versions of packages java-package suggests:
ii  openjdk-7-jre  7u79-2.5.6-1~deb8u1

-- no debconf information

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to