On 09/05/2015 01:56 PM, Emmanuel Bourg wrote:
> Le 05/09/2015 22:35, tony mancill a écrit :
> 
>> Thank you for the update.  According to clirr, there are some API
>> differences between 2.7 and 2.8.2:
>>
>>> ERROR: 7004: org.joda.time.tz.ZoneInfoCompiler: In method 'public void 
>>> parseDataFile(java.io.BufferedReader)' the number of arguments has changed
>>> ERROR: 7002: org.joda.time.tz.ZoneInfoCompiler: Method 'public boolean 
>>> verbose()' has been removed
> 
> These errors affect only the zoneinfo compiler, I don't think common
> applications use this part of joda-time. Searching for ZoneInfoCompiler
> returns occurrences in the libjoda-time-java package only [1]. So the
> upgrade is safe.
> 
> Emmanuel Bourg
> 
> [1] https://codesearch.debian.net/results/ZoneInfoCompiler/page_0

Ah cool - thank you for the link to the codesearch page.  That saves me
a lot of time.  I didn't think it was likely that other packages would
use the ZoneInfoCompiler, but since it was public, I thought I should check.

I'll upload to unstable shortly.

Cheers,
tony



Attachment: signature.asc
Description: OpenPGP digital signature

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to