Package: libphonenumber7-java
Version: 7.0.11-2
Severity: serious
User: debian...@lists.debian.org
Usertags: piuparts

Hi,

during a test with piuparts I noticed your package fails to upgrade from
'jessie'.
It installed fine in 'jessie', then the upgrade to 'sid' fails
because it tries to overwrite other packages files without declaring a
Breaks+Replaces relation.

See policy 7.6 at
https://www.debian.org/doc/debian-policy/ch-relationships.html#s-replaces

>From the attached log (scroll to the bottom...):

  Selecting previously unselected package libphonenumber7-java.
  Preparing to unpack .../libphonenumber7-java_7.0.11-2_all.deb ...
  Unpacking libphonenumber7-java (7.0.11-2) ...
  dpkg: error processing archive 
/var/cache/apt/archives/libphonenumber7-java_7.0.11-2_all.deb (--unpack):
   trying to overwrite '/usr/share/java/geocoder.jar', which is also in package 
libphonenumber6-java 6.3~svn698-3
  dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
  Errors were encountered while processing:
   /var/cache/apt/archives/libphonenumber7-java_7.0.11-2_all.deb


cheers,

Andreas

Attachment: libphonenumber6-java=6.3~svn698-3_libphonenumber7-java=7.0.11-2.log.gz
Description: application/gzip

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to