Your message dated Sun, 18 Oct 2015 16:19:50 +0000
with message-id <e1znqgy-0000yn...@franck.debian.org>
and subject line Bug#801475: fixed in freeplane 1.3.15-3
has caused the Debian Bug report #801475,
regarding freeplane: Fails to build with JMapViewer 1.11
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
801475: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=801475
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Source: freeplane
Version: 1.3.15-2
Severity: important
Tags: upstream

Dear Maintainer,

The jmapviewer package in Debian has been updated to the recent
JMapViewer 1.11 upstream release as required for JOSM 8800
(both available in experimental).

Unfortunately freeplane (1.3.15-2) fails to build with
jmapviewer (1.11+dfsg-1~exp1) as can be seen in the partial build log
below.

Please update the openmaps plugin to support JMapViewer 1.11 or consider
adding skip_openmaps=true to debian/ant.properties.

The severity of this issue will be raised to serious when
jmapviewer (1.11+dfsg-1) is moved from experimental to unstable.
I expect to do that next week.


>From the freeplane (1.3.15-2) build log:

 build:
     [mkdir] Created dir: 
/tmp/buildd/freeplane-1.3.15/freeplane_plugin_openmaps/build
     [javac] 
/tmp/buildd/freeplane-1.3.15/freeplane_plugin_openmaps/ant/build.xml:23: 
warning: 'includeantruntime' was not set, defaulting to 
build.sysclasspath=last; set to false for repeatable builds
     [javac] Compiling 12 source files to 
/tmp/buildd/freeplane-1.3.15/freeplane_plugin_openmaps/build
     [javac] warning: [options] bootstrap class path not set in conjunction 
with -source 1.5
     [javac] 
/tmp/buildd/freeplane-1.3.15/freeplane_plugin_openmaps/src/org/freeplane/plugin/openmaps/mapelements/OpenMapsController.java:64:
 error: incompatible types
     [javac]             return map.getPosition(clickedLocation); 
     [javac]                                   ^
     [javac]   required: Coordinate
     [javac]   found:    ICoordinate
     [javac] 
/tmp/buildd/freeplane-1.3.15/freeplane_plugin_openmaps/src/org/freeplane/plugin/openmaps/mapelements/OpenMapsController.java:84:
 error: cannot find symbol
     [javac]         int x = (int)OsmMercator.LonToX(location.getLon(), zoom);
     [javac]                                 ^
     [javac]   symbol:   method LonToX(double,int)
     [javac]   location: class OsmMercator
     [javac] 
/tmp/buildd/freeplane-1.3.15/freeplane_plugin_openmaps/src/org/freeplane/plugin/openmaps/mapelements/OpenMapsController.java:85:
 error: cannot find symbol
     [javac]         int y = (int)OsmMercator.LatToY(location.getLat(), zoom);
     [javac]                                 ^
     [javac]   symbol:   method LatToY(double,int)
     [javac]   location: class OsmMercator
     [javac] Note: 
/tmp/buildd/freeplane-1.3.15/freeplane_plugin_openmaps/src/org/freeplane/plugin/openmaps/mapelements/OpenMapsViewer.java
 uses or overrides a deprecated API.
     [javac] Note: Recompile with -Xlint:deprecation for details.
     [javac] 3 errors
     [javac] 1 warning
 
 BUILD FAILED
 /tmp/buildd/freeplane-1.3.15/build.xml:4: The following error occurred while 
executing this line:
 /tmp/buildd/freeplane-1.3.15/freeplane_framework/ant/build.xml:139: The 
following error occurred while executing this line:
 /tmp/buildd/freeplane-1.3.15/freeplane_framework/ant/build.xml:55: The 
following error occurred while executing this line:
 /tmp/buildd/freeplane-1.3.15/freeplane_plugin_openmaps/ant/build.xml:23: 
Compile failed; see the compiler error output for details.

 Total time: 18 seconds


My appologies for the inconvenience,

Bas

--- End Message ---
--- Begin Message ---
Source: freeplane
Source-Version: 1.3.15-3

We believe that the bug you reported is fixed in the latest version of
freeplane, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 801...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Felix Natter <fnat...@gmx.net> (supplier of updated freeplane package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Sun, 18 Oct 2015 17:11:38 +0200
Source: freeplane
Binary: freeplane libjortho-freeplane-java
Architecture: source all
Version: 1.3.15-3
Distribution: unstable
Urgency: medium
Maintainer: Debian Java Maintainers 
<pkg-java-maintainers@lists.alioth.debian.org>
Changed-By: Felix Natter <fnat...@gmx.net>
Description:
 freeplane  - Java program for working with Mind Maps
 libjortho-freeplane-java - Java spell-checking library
Closes: 801475
Changes:
 freeplane (1.3.15-3) unstable; urgency=medium
 .
   * Upgrade JMapViewer to 1.11 (Closes: #801475)
   * Remove freeplane.menu because freeplane.desktop exists
   * Upgrade to debhelper 9
   * Fix debian/copyright (dep5-copyright-license-name-not-unique)
Checksums-Sha1:
 18ce640587fa3ad2beb83b9c68c4739491b8cd62 2527 freeplane_1.3.15-3.dsc
 4f8665ab7a45daffe059e868c6f9bad4060ee768 26360 freeplane_1.3.15-3.debian.tar.xz
 b0da780eb36d511ea778afdae8447eeaf66f6053 8842290 freeplane_1.3.15-3_all.deb
 5b5733b11d5c564c80487d36849643345f32fa51 69244 
libjortho-freeplane-java_1.3.15-3_all.deb
Checksums-Sha256:
 96ef63cf142da62c4b4c7f331a38eced298a9fc3080d9daaf0483c36f804717a 2527 
freeplane_1.3.15-3.dsc
 9c2e2c017451df25c6934474dc0cad32189c06c9b6356bbde1fb38227a8863f4 26360 
freeplane_1.3.15-3.debian.tar.xz
 e6969c6d879200706cc833e996a012f46c3d4030685a14cf158855b836f9c6f3 8842290 
freeplane_1.3.15-3_all.deb
 977f75f8bd0c8100d91d2612ee6350be6f0f1a132a374fb3d20ea4b50021cda0 69244 
libjortho-freeplane-java_1.3.15-3_all.deb
Files:
 c5e11a3a47732abfb6cd89896681cd74 2527 editors extra freeplane_1.3.15-3.dsc
 2c1b6fd0ffce3a9fbd587f6877b8361b 26360 editors extra 
freeplane_1.3.15-3.debian.tar.xz
 851c82e1a00906cb1555763585cc723d 8842290 editors extra 
freeplane_1.3.15-3_all.deb
 46ffbde6d679ce0ffbb50f35190c2f6b 69244 java extra 
libjortho-freeplane-java_1.3.15-3_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBCgAGBQJWI8MlAAoJECHSBYmXSz6WrSQP/A7XZ9T8SWVRU9m53ndiGS1r
DOWGxyhasd8OEYnwjLjhMurhH+9f2AdU8l448AWkQ6FJqHlMk60fZnlalwpQTJV2
7IOJcp8drwDEA6lmWCGz9efjBv5PZr/xUPv/JJ910yRy4tbz0U1FtrJCPv6cIizA
dU/SMeWAhab7Pz2t/W3XSHbTgYwks5K1PxMpBgjgjbq+CUzcg2i7DlCjlP2/LaLz
8VsT6byouuB3OWU1cYd2jn/lKN6IMif8LI6JeYRZY/HNX+DsRss2JmDL/vbdDeOf
jlVKd5GnKaPGxHO6gkQF5cIOj7WuaYN3z2TRTzsc8MeMmvgSP76qHa4V73R8R/am
eePLW+AQfG1KcJKQblzziMvCONH0q6M8/D4uJf+SGDxdjzxY5gbJseKoRVsdINYf
/GI0YqI4yWThcvbi13/TX5ihNYts57bmh1xYshLWAtMib+nC6LGrHmAoZjlGAUwS
kaY2VkCmQCfZGkGfu/26uTOBd8kURkk1CMl8cN7busmLCcxLzExCAI6RSBH1ZL9l
edgmQ6EVC9kwugSzbybKeOyK7EDoPBkGtR+OqC9oqPw2rHyyZxTwmdf23T1CmrY3
mk6RLbKhSHt9wxbJa286HACgpYuo+5kdHrakwRe+rn/P/2RBQbV2Fzpmvr6JP6zt
9pJiXvxVlX65DvzzOTFz
=AYqq
-----END PGP SIGNATURE-----

--- End Message ---
__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to