Your message dated Fri, 30 Oct 2015 12:48:48 +0000
with message-id <e1zs96u-0005at...@franck.debian.org>
and subject line Bug#796454: fixed in polyglot-maven 0.8~tobrien+git20120905-4
has caused the Debian Bug report #796454,
regarding polyglot-maven: FTBFS: /PolyglotModelUtil.java: error: cannot access 
Source
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
796454: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=796454
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Source: polyglot-maven
Version: 0.8~tobrien+git20120905-3
Severity: serious
Justification: fails to build from source
Tags: sid stretch
User: reproducible-bui...@lists.alioth.debian.org
Usertags: ftbfs
X-Debbugs-CC: reproducible-bui...@lists.alioth.debian.org

Dear Maintainer,

The package fails to build:

build.common:
    [javac] /polyglot-maven-0.8~tobrien+git20120905/debian/build.xml:255: 
warning: 'includeantruntime' was not set, defaulting to 
build.sysclasspath=last; set to false for repeatable builds
    [javac] Compiling 16 source files to 
/polyglot-maven-0.8~tobrien+git20120905/build/common
    [javac] warning: [options] bootstrap class path not set in conjunction with 
-source 1.5
    [javac] 
/polyglot-maven-0.8~tobrien+git20120905/pmaven-common/src/main/java/org/sonatype/maven/polyglot/PolyglotModelUtil.java:60:
 error: cannot access Source
    [javac]                 return ((ModelSource)tmp).getLocation();
    [javac]                                          ^
    [javac]   class file for org.apache.maven.building.Source not found
    [javac] Note: Some input files use or override a deprecated API.
    [javac] Note: Recompile with -Xlint:deprecation for details.
    [javac] 1 error
    [javac] 1 warning

Full build log:
https://reproducible.debian.net/rb-pkg/unstable/amd64/polyglot-maven.html

-- System Information:
Debian Release: stretch/sid
APT prefers unstable
APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.19.0-23-generic (SMP w/8 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

--- End Message ---
--- Begin Message ---
Source: polyglot-maven
Source-Version: 0.8~tobrien+git20120905-4

We believe that the bug you reported is fixed in the latest version of
polyglot-maven, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 796...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Emmanuel Bourg <ebo...@apache.org> (supplier of updated polyglot-maven package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Fri, 30 Oct 2015 12:53:42 +0100
Source: polyglot-maven
Binary: libpolyglot-maven-java libpolyglot-maven-java-doc
Architecture: source all
Version: 0.8~tobrien+git20120905-4
Distribution: unstable
Urgency: medium
Maintainer: Debian Java Maintainers 
<pkg-java-maintainers@lists.alioth.debian.org>
Changed-By: Emmanuel Bourg <ebo...@apache.org>
Description:
 libpolyglot-maven-java - modules to enable Maven usage in others JVM languages
 libpolyglot-maven-java-doc - modules to enable Maven usage in others JVM 
languages - docs
Closes: 796454 800865
Changes:
 polyglot-maven (0.8~tobrien+git20120905-4) unstable; urgency=medium
 .
   * Team upload.
   * Fixed the build failure with Maven 3.3.3 (Closes: #796454)
   * Removed the unused build dependency on libasm3-java (Closes: #800865)
   * Build depend on libmaven3-core-java instead of maven
   * Standards-Version updated to 3.9.6 (no changes)
Checksums-Sha1:
 84dc61fa90748acc272d334b99e31f6c75592a60 2444 
polyglot-maven_0.8~tobrien+git20120905-4.dsc
 7efcd99679bbe3cecf59e5dea743cf08f2b5896b 6132 
polyglot-maven_0.8~tobrien+git20120905-4.debian.tar.xz
 4c708325ec87d556a9b8704089586401973e5b84 57610 
libpolyglot-maven-java-doc_0.8~tobrien+git20120905-4_all.deb
 5927c890d0ad6df0999bccb633aaff8c34a38bf4 76384 
libpolyglot-maven-java_0.8~tobrien+git20120905-4_all.deb
Checksums-Sha256:
 654480b8991c2845341b4506e5bcca36ff71ce48f934b6de38d74b0c8dd833d4 2444 
polyglot-maven_0.8~tobrien+git20120905-4.dsc
 5354758c9870b33ab9791f5328f6a5681f8b7794a584b3ea6df5f94e60143e29 6132 
polyglot-maven_0.8~tobrien+git20120905-4.debian.tar.xz
 2a24f0a42c3a795ea480fea8dff639006faeabe60da4a33fb1ec41167b3288a5 57610 
libpolyglot-maven-java-doc_0.8~tobrien+git20120905-4_all.deb
 82087361453c1e8d5d4425b952d57a02a12facf6c7b8b9605d8a0d678eaa4381 76384 
libpolyglot-maven-java_0.8~tobrien+git20120905-4_all.deb
Files:
 400d9876c1adc8ac6cda15a4cfffdd07 2444 java optional 
polyglot-maven_0.8~tobrien+git20120905-4.dsc
 3fc78c2cc5059075c031013a04aff8a3 6132 java optional 
polyglot-maven_0.8~tobrien+git20120905-4.debian.tar.xz
 88b65b4b4af7e426168abbf0c7d201a1 57610 doc optional 
libpolyglot-maven-java-doc_0.8~tobrien+git20120905-4_all.deb
 75c2816c223eb8fd8baf405d43b3154e 76384 java optional 
libpolyglot-maven-java_0.8~tobrien+git20120905-4_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBAgAGBQJWM2NxAAoJEPUTxBnkudCs1bAP/014KYZuP7+TQG2yzET/TaRK
brB3wqcM7+ItnSjW0EkxVAe13w0DCB722oNEmJSOAJLviK3NnY631uNf7B1zvYnJ
KKcOuhcbtH5Wdtx/QCGYHoX4C4nhseVqAU5gli0NmC3LGcieqEssaHq+aFMkyDAs
6YJy4JhcYBYHawSU3M0T85KTF7kByWJtMQCd/7VsaPZqvlR46wpwB6AIDhqMSCpb
AA2Y2qPGXDQwzLCrsGdKz7AI+/yS6Bl+WHPWUIS5/2vrq2eAROfCZImvkDfVAebk
Zkn7yrtYiQ4o42Wh5erUnBReMgM0EuLBywJaKSGoB3273qUh5g7GAEhXGBsrAkI7
zRZXiDQ6/CIvJIDAeZ5upoqYRt2gDy4V+KpgUBDvp27BOMpjSuK/8dmCjhyGvztv
mvpG0lCqKriMe75F9v+/iH6lGMLDHw+GK3IPfu0aqWzqCFSbpYRSNQPKjzkVvXN+
HncM4pc39LCDfioDniXz7FuiIPGbfj0/sHYKXStNwamZ6nbS4wwXbapEPLe55at7
5vj451fdQs2BIAEA/U0R1TY0oE3Wt5zDw7uB4qP2JcoX1rl91PY/ZnUlM6JF+7Iz
Dl8M2cJn2wmbyx9GHoMkpXol4LOCfKEieerFawXLynCp/BAbrs0/Y1JUklCcgJHL
7nI4c7Qc9nLe1BelOC94
=l7af
-----END PGP SIGNATURE-----

--- End Message ---
__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to