Hi Tomas,

Thank you for reporting this issue, I have been able to reproduce it.
This is caused by an incompatibility between the dependency plugin 2.7
and Maven 3.3. You can work around this issue by forcing the use of a
more recent version of the plugin (2.8 or later):

    mvn org.apache.maven.plugins:maven-dependency-plugin:2.8:tree

To fix this we have to cancel the modification of the super pom
downgrading the version of the dependency plugin from 2.8 to 2.7:

http://anonscm.debian.org/cgit/pkg-java/maven.git/tree/debian/patches/plugins_version.diff?h=debian/3.3.9-2#n233

Emmanuel Bourg

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to