Your message dated Mon, 21 Dec 2015 10:53:10 +0000
with message-id <e1aay5w-0004nv...@franck.debian.org>
and subject line Bug#808498: fixed in antlr4 4.5.1-2
has caused the Debian Bug report #808498,
regarding antlr4: FTBFS: org.codehaus.plexus:plexus-compiler-api:jar:debian has 
not been downloaded
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
808498: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=808498
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Source: antlr4
Version: 4.5.1-1
Severity: serious
Justification: fails to build from source
Tags: sid stretch
User: reproducible-bui...@lists.alioth.debian.org
Usertags: ftbfs
X-Debbugs-CC: reproducible-bui...@lists.alioth.debian.org

Dear Maintainer,

The package fails to build:

[INFO] ------------------------------------------------------------------------
[INFO] Building ANTLR 4 Maven plugin 4.5.1
[INFO] ------------------------------------------------------------------------
[WARNING] The POM for org.codehaus.plexus:plexus-compiler-api:jar:debian is 
missing, no dependency information available
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO] 
[INFO] ANTLR 4 ............................................ SUCCESS [  0.287 s]
[INFO] ANTLR 4 Runtime .................................... SUCCESS [  6.361 s]
[INFO] ANTLR 4 Tool ....................................... SUCCESS [  6.611 s]
[INFO] ANTLR 4 Maven plugin ............................... FAILURE [  0.055 s]
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 13.455 s
[INFO] Finished at: 2015-12-20T13:32:24+00:00
[INFO] Final Memory: 19M/454M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project antlr4-maven-plugin: Could not 
resolve dependencies for project 
org.antlr:antlr4-maven-plugin:maven-plugin:4.5.1: Cannot access central 
(https://repo.maven.apache.org/maven2) in offline mode and the artifact 
org.codehaus.plexus:plexus-compiler-api:jar:debian has not been downloaded from 
it before. -> [Help 1]
...
/usr/share/cdbs/1/class/maven.mk:92: recipe for target 'mvn-build' failed
make: *** [mvn-build] Error 1
dpkg-buildpackage: error: debian/rules build gave error exit status 2

Full build log:
https://reproducible.debian.net/rb-pkg/unstable/amd64/antlr4.html

-- System Information:
Debian Release: stretch/sid
APT prefers unstable
APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

--- End Message ---
--- Begin Message ---
Source: antlr4
Source-Version: 4.5.1-2

We believe that the bug you reported is fixed in the latest version of
antlr4, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 808...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Emmanuel Bourg <ebo...@apache.org> (supplier of updated antlr4 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Mon, 21 Dec 2015 10:44:45 +0100
Source: antlr4
Binary: antlr4 antlr4-doc antlr4-maven-plugin libantlr4-runtime-java
Architecture: source all
Version: 4.5.1-2
Distribution: unstable
Urgency: medium
Maintainer: Debian Java Maintainers 
<pkg-java-maintainers@lists.alioth.debian.org>
Changed-By: Emmanuel Bourg <ebo...@apache.org>
Description:
 antlr4     - ANTLR Parser Generator
 antlr4-doc - ANTLR Parser Generator (documentation)
 antlr4-maven-plugin - Maven plugin for ANTLR 4
 libantlr4-runtime-java - Runtime library for ANTLR 4
Closes: 808498
Changes:
 antlr4 (4.5.1-2) unstable; urgency=medium
 .
   * Fixed the build failure with Maven 3 (Closes: #808498)
   * Build with the DH sequencer instead of CDBS
Checksums-Sha1:
 f9e8cf8113f33433c1aa87dd73652f5534b70bbb 2369 antlr4_4.5.1-2.dsc
 858514e5450092f9e7a96f7c02567e004934d2a1 9632 antlr4_4.5.1-2.debian.tar.xz
 73a5c83fc4a8dcfff748259a2eea49ed8c7d3fba 768620 antlr4-doc_4.5.1-2_all.deb
 9a0fe7d7cc4b6ade72cd112c2654f985778f6538 32344 
antlr4-maven-plugin_4.5.1-2_all.deb
 01ae85515b3145f3ffeb4f5368806e1976910517 679586 antlr4_4.5.1-2_all.deb
 b0c2c8ddb535f6dc1b30924cb70a2ecd84876fa7 287602 
libantlr4-runtime-java_4.5.1-2_all.deb
Checksums-Sha256:
 3e1e8bc0b88e73933a27821a3cb5b7cfc0a86f772bc2f8b753d9670d9b9d9584 2369 
antlr4_4.5.1-2.dsc
 febb23db5ff20295fef91712657fab3be79c02449611004cda8203af7a022a1c 9632 
antlr4_4.5.1-2.debian.tar.xz
 c4fecc9bd4398509067a872f889aad62647a69d24df7d6e7e8266608b5dca601 768620 
antlr4-doc_4.5.1-2_all.deb
 c217a9de419b8c70104dbf8fc6a16effab694bd951b27ce19df880af2ad9d210 32344 
antlr4-maven-plugin_4.5.1-2_all.deb
 6d14a5f1e33f62f99840e933e8d714af2602ee36e486cce960b21e4e68c79370 679586 
antlr4_4.5.1-2_all.deb
 cd88b293a8c95d81906fbe1fbc11f48eb24273f0cf4a88f246b242f6bb6d9956 287602 
libantlr4-runtime-java_4.5.1-2_all.deb
Files:
 2f0a9504ad1d10bf24f980b804b0d7b3 2369 java optional antlr4_4.5.1-2.dsc
 7ff1785795d2632c37932c61021118cc 9632 java optional 
antlr4_4.5.1-2.debian.tar.xz
 67223038c16958e224c17ad3cc1785a8 768620 doc optional antlr4-doc_4.5.1-2_all.deb
 61d6b29d951313eb949e247e2cdd2ab8 32344 java optional 
antlr4-maven-plugin_4.5.1-2_all.deb
 17e910c68c4073b2a6ff45a257b6c331 679586 java optional antlr4_4.5.1-2_all.deb
 92fe6d0c0cb177d12e5ea84899085d6e 287602 java optional 
libantlr4-runtime-java_4.5.1-2_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iQIcBAEBCAAGBQJWd8r/AAoJEPUTxBnkudCsCZQQALNp3v05Jn2E6mFFiEFbdqP8
YVqnBE2bteHY8+CpHZZInvVaMfAYLqLCwlYl3R2EbKGygS39x+wYTEpSvCSWsWvg
54czy0C5SeMwRjs1+GdBtdknqhx56F8lf67KGuQpNzY1xd9Fq2leXmEmtUtKrNzq
Op0niJevNmBQcy9p0PeCS5Ql5Injm40I4U4XH4CIB25ffmPFuoRhJQq6Zwag6uf7
9DG+Ft8bj++9QZPFXUOyNuE6tf8p1uveBsqqohR8xu7eM+kLQL163ifJaIDs+HVV
SjKGj2Jkysqu0OZw7nLO27Y6z4HrFhxudahQ2hKTNUdW0vLdv0fc0w8bxdiNDGS1
TMdJaw+v7QQN/PLB93jD1Y/W6d/hveKOw0RDYMR+ik9r0h6ht5Z1AwvI/8TV/gnT
erMBd/hjUKbtmbT3Y7k4HRahj3tRmGp1wdjFkEOuqjYhaRsTDwH8XESNdIuG2Syr
Jx02cWGbvw/BTJkZYxqFMEcm3Mv0mii45n7DOTD2U7+zwyjeJWc3Ly6mSIWknYD+
zvv7mZ1YUcG+tTo9jtcq54RKd6JN09FiryCDfkATbYwknP8TpG+OF3V7YTlFC3ka
xHqq1izTelq1Da9bhB8rA/OWB0Msrf7X8mrzCZoquT6xzf83ZzfG6XU/f4xgEqEO
63ctmuQhDb9Bmi4GJbt2
=/g+y
-----END PGP SIGNATURE-----

--- End Message ---
__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to