Am 17.02.2016 um 09:59 schrieb Hans-Christoph Steiner:
> 
> I remember getting odd errors like this while working with lombok-ast,
> my solution in the end was to try disabling chunks of lombok*, which
> obviously didn't work.

Yeah.

> Have you tried emailing upstream?  I did manage to get one or two
> responses from them.  This is a very specialized beast.

I think I have "fixed" it now but I can't explain how. Apparently the
old unpacked version of src:lombok works with src:lombok-patcher but the
new one doesn't. It took a while for me to realize that. Even if I
rename the old tarball into 1.16.1+ds2 it will also fail to build...
Perhaps it has something to do with the lombok.version string that is
injected into the build system but I'm not really sure about this. The
journey to find a solution for this bug sometimes reminded me of
Sherlock Holmes:

"When you have eliminated the impossible, whatever remains, however
improbable, must be the truth."


Attachment: signature.asc
Description: OpenPGP digital signature

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to