Le 31/01/2016 09:06, Chris Lamb a écrit :

> [ERROR] [...] the artifact org.codehaus.plexus:plexus-utils:jar:1.1 has not 
> been downloaded from it before.

This isn't the first time we see this error since the switch to Maven 3
and I've just figured out why it happens: Maven 3 injects a dependency
on plexus-utils 1.1 to any plugin (here paranamer-maven-plugin) that
doesn't declare a dependency on it already. And since we don't have the
version 1.1 in Debian the resolution fails.

The class responsible for this injection is PlexusUtilsInjector [1] in
the Maven project, we just have to redefine it to use plexus-utils 2.x
instead of 1.1 to fix this class of issues. I'll do that in the next
update of maven-debian-helper.

Emmanuel Bourg

[1]
https://github.com/apache/maven/blob/master/maven-core/src/main/java/org/apache/maven/plugin/internal/PlexusUtilsInjector.java

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to