Am 03.04.2016 um 19:36 schrieb Mattia Rizzolo:
> control: reopen -1
> control: tag -1 + patch pending
> 
> On Tue, Mar 08, 2016 at 08:29:19PM +0000, Markus Koschany <a...@debian.org> 
> wrote:
>> On Mon, 08 Feb 2016 20:27:41 +0000 Matthias Klose <d...@debian.org> wrote:
>>> Package: src:jalview
>>> Version: 2.7.dfsg-4
>>> Severity: serious
>>> User: debian-j...@lists.debian.org
>>> Usertags: openjdk-8-transition
>>>
>>> The package build-depends or depends one an openjdk-7-* package,
>>> which is scheduled for removal for stretch.  Please do not depend
>>> on a specific openjdk version, but on one of the default-java,
>>> default-java-headless or default-jdk packages instead.
>>>
>>> default-java defaulting to openjdk-8 on most architectures is now
>>> available in unstable.
>>
>> Hi,
>>
>> jalview neither depends or build-depends on openjdk-7-* packages. It
>> builds fine with OpenJDK 8. I am going to close this bug as invalid now.
> 
> Please be bothered to double check.
> 
> jalview has a Depends (a binary relationship) on openjdk-7-jdk.
> For this, a rebuild is enough to have it pick the right dep.
> 
> I uploaded a thing to DELEYED/7, please tell me if I should deley
> longer.

Hi,

thanks for spotting the runtime dependency on openjdk-7-jre. It is
somewhat strange that it exists though.

However please cancel the upload because the removal of the alternative
java6-runtime dependency is not correct. It is still provided by OpenJDK
8 and the non-free Oracle packages and it also simplifies backports. I
will take care of the upload afterwards.

Regards,

Markus



Attachment: signature.asc
Description: OpenPGP digital signature

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to