Package: libjmock-java,libjmock2-java
Version: libjmock-java/1.2.0-4
Version: libjmock2-java/2.8.2-1
Severity: serious
User: trei...@debian.org
Usertags: edos-file-overwrite

Date: 2016-09-28
Architecture: amd64
Distribution: sid

Hi,

automatic installation tests of packages that share a file and at the
same time do not conflict by their package dependency relationships has
detected the following problem:



Extracting templates from packages: 42%
Extracting templates from packages: 85%
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 10971 files and directories currently installed.)
Preparing to unpack .../libtext-charwidth-perl_0.04-7+b5_amd64.deb ...
Unpacking libtext-charwidth-perl (0.04-7+b5) over (0.04-7+b2) ...
Processing triggers for man-db (2.7.5-1) ...
dpkg: perl-modules: dependency problems, but removing anyway as you requested:
 perl depends on perl-modules (>= 5.18.2-2).

(Reading database ... 10975 files and directories currently installed.)
Removing perl-modules (5.18.2-7) ...
(Reading database ... 10163 files and directories currently installed.)
Preparing to unpack .../perl_5.24.1~rc3-3_amd64.deb ...
Unpacking perl (5.24.1~rc3-3) over (5.18.2-2) ...
Selecting previously unselected package perl-modules-5.24.
Preparing to unpack .../perl-modules-5.24_5.24.1~rc3-3_all.deb ...
Unpacking perl-modules-5.24 (5.24.1~rc3-3) ...
Selecting previously unselected package libdb5.3:amd64.
Preparing to unpack .../libdb5.3_5.3.28-12_amd64.deb ...
Unpacking libdb5.3:amd64 (5.3.28-12) ...
Selecting previously unselected package libperl5.24:amd64.
Preparing to unpack .../libperl5.24_5.24.1~rc3-3_amd64.deb ...
Unpacking libperl5.24:amd64 (5.24.1~rc3-3) ...
Preparing to unpack .../perl-base_5.24.1~rc3-3_amd64.deb ...
Unpacking perl-base (5.24.1~rc3-3) over (5.18.2-2) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for libc-bin (2.24-3) ...
Setting up perl-base (5.24.1~rc3-3) ...
(Reading database ... 11007 files and directories currently installed.)
Preparing to unpack .../liblocale-gettext-perl_1.07-3+b1_amd64.deb ...
Unpacking liblocale-gettext-perl (1.07-3+b1) over (1.05-7+b2) ...
Preparing to unpack .../libtext-iconv-perl_1.7-5+b4_amd64.deb ...
Unpacking libtext-iconv-perl (1.7-5+b4) over (1.7-5+b1) ...
Selecting previously unselected package libfdisk1:amd64.
Preparing to unpack .../libfdisk1_2.28.2-1_amd64.deb ...
Unpacking libfdisk1:amd64 (2.28.2-1) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for libc-bin (2.24-3) ...
Setting up libfdisk1:amd64 (2.28.2-1) ...
Processing triggers for libc-bin (2.24-3) ...
Selecting previously unselected package libsmartcols1:amd64.
(Reading database ... 11008 files and directories currently installed.)
Preparing to unpack .../libsmartcols1_2.28.2-1_amd64.deb ...
Unpacking libsmartcols1:amd64 (2.28.2-1) ...
Processing triggers for libc-bin (2.24-3) ...
Setting up libsmartcols1:amd64 (2.28.2-1) ...
Processing triggers for libc-bin (2.24-3) ...
Selecting previously unselected package libgcrypt20:amd64.
(Reading database ... 11014 files and directories currently installed.)
Preparing to unpack .../libgcrypt20_1.7.3-1_amd64.deb ...
Unpacking libgcrypt20:amd64 (1.7.3-1) ...
Processing triggers for libc-bin (2.24-3) ...
Setting up libgcrypt20:amd64 (1.7.3-1) ...
Processing triggers for libc-bin (2.24-3) ...
Selecting previously unselected package libsystemd0:amd64.
(Reading database ... 11024 files and directories currently installed.)
Preparing to unpack .../libsystemd0_231-7_amd64.deb ...
Unpacking libsystemd0:amd64 (231-7) ...
Processing triggers for libc-bin (2.24-3) ...
Setting up libsystemd0:amd64 (231-7) ...
Processing triggers for libc-bin (2.24-3) ...
(Reading database ... 11029 files and directories currently installed.)
Preparing to unpack .../sysvinit-utils_2.88dsf-59.8_amd64.deb ...
Unpacking sysvinit-utils (2.88dsf-59.8) over (2.88dsf-51) ...
Replacing files in old package initscripts (2.88dsf-59) ...
Preparing to unpack .../init-system-helpers_1.45_all.deb ...
Unpacking init-system-helpers (1.45) over (1.21) ...
Replacing files in old package sysv-rc (2.88dsf-51) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up init-system-helpers (1.45) ...
(Reading database ... 11021 files and directories currently installed.)
Preparing to unpack .../util-linux_2.28.2-1_amd64.deb ...
Unpacking util-linux (2.28.2-1) over (2.20.1-5.11) ...
Replacing files in old package initscripts (2.88dsf-59) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up util-linux (2.28.2-1) ...
Installing new version of config file /etc/init.d/hwclock.sh ...
Selecting previously unselected package libxau6:amd64.
(Reading database ... 11165 files and directories currently installed.)
Preparing to unpack .../libxau6_1%3a1.0.8-1_amd64.deb ...
Unpacking libxau6:amd64 (1:1.0.8-1) ...
Selecting previously unselected package libxdmcp6:amd64.
Preparing to unpack .../libxdmcp6_1%3a1.1.2-1.1_amd64.deb ...
Unpacking libxdmcp6:amd64 (1:1.1.2-1.1) ...
Selecting previously unselected package libxcb1:amd64.
Preparing to unpack .../libxcb1_1.12-1_amd64.deb ...
Unpacking libxcb1:amd64 (1.12-1) ...
Selecting previously unselected package libx11-data.
Preparing to unpack .../libx11-data_2%3a1.6.3-1_all.deb ...
Unpacking libx11-data (2:1.6.3-1) ...
Selecting previously unselected package libx11-6:amd64.
Preparing to unpack .../libx11-6_2%3a1.6.3-1_amd64.deb ...
Unpacking libx11-6:amd64 (2:1.6.3-1) ...
Selecting previously unselected package libxext6:amd64.
Preparing to unpack .../libxext6_2%3a1.3.3-1_amd64.deb ...
Unpacking libxext6:amd64 (2:1.3.3-1) ...
Selecting previously unselected package libxi6:amd64.
Preparing to unpack .../libxi6_2%3a1.7.6-1_amd64.deb ...
Unpacking libxi6:amd64 (2:1.7.6-1) ...
Selecting previously unselected package x11-common.
Preparing to unpack .../x11-common_1%3a7.7+16_all.deb ...
Unpacking x11-common (1:7.7+16) ...
Selecting previously unselected package libxtst6:amd64.
Preparing to unpack .../libxtst6_2%3a1.2.2-1+b1_amd64.deb ...
Unpacking libxtst6:amd64 (2:1.2.2-1+b1) ...
Selecting previously unselected package libssl1.0.2:amd64.
Preparing to unpack .../libssl1.0.2_1.0.2j-1_amd64.deb ...
Unpacking libssl1.0.2:amd64 (1.0.2j-1) ...
Selecting previously unselected package openssl.
Preparing to unpack .../openssl_1.0.2j-1_amd64.deb ...
Unpacking openssl (1.0.2j-1) ...
Selecting previously unselected package ca-certificates.
Preparing to unpack .../ca-certificates_20160104_all.deb ...
Unpacking ca-certificates (20160104) ...
Selecting previously unselected package java-common.
Preparing to unpack .../java-common_0.57_all.deb ...
Unpacking java-common (0.57) ...
Selecting previously unselected package default-jre-headless.
Preparing to unpack .../default-jre-headless_2%3a1.8-57_amd64.deb ...
Unpacking default-jre-headless (2:1.8-57) ...
Selecting previously unselected package libnspr4:amd64.
Preparing to unpack .../libnspr4_2%3a4.12-6_amd64.deb ...
Unpacking libnspr4:amd64 (2:4.12-6) ...
Selecting previously unselected package libnss3:amd64.
Preparing to unpack .../libnss3_2%3a3.26-2_amd64.deb ...
Unpacking libnss3:amd64 (2:3.26-2) ...
Selecting previously unselected package ca-certificates-java.
Preparing to unpack .../ca-certificates-java_20160321_all.deb ...
Unpacking ca-certificates-java (20160321) ...
Selecting previously unselected package libavahi-common-data:amd64.
Preparing to unpack .../libavahi-common-data_0.6.32-1_amd64.deb ...
Unpacking libavahi-common-data:amd64 (0.6.32-1) ...
Selecting previously unselected package libavahi-common3:amd64.
Preparing to unpack .../libavahi-common3_0.6.32-1_amd64.deb ...
Unpacking libavahi-common3:amd64 (0.6.32-1) ...
Selecting previously unselected package libdbus-1-3:amd64.
Preparing to unpack .../libdbus-1-3_1.10.10-1_amd64.deb ...
Unpacking libdbus-1-3:amd64 (1.10.10-1) ...
Selecting previously unselected package libavahi-client3:amd64.
Preparing to unpack .../libavahi-client3_0.6.32-1_amd64.deb ...
Unpacking libavahi-client3:amd64 (0.6.32-1) ...
Selecting previously unselected package libgmp10:amd64.
Preparing to unpack .../libgmp10_2%3a6.1.1+dfsg-1_amd64.deb ...
Unpacking libgmp10:amd64 (2:6.1.1+dfsg-1) ...
Selecting previously unselected package libnettle6:amd64.
Preparing to unpack .../libnettle6_3.2-1_amd64.deb ...
Unpacking libnettle6:amd64 (3.2-1) ...
Selecting previously unselected package libhogweed4:amd64.
Preparing to unpack .../libhogweed4_3.2-1_amd64.deb ...
Unpacking libhogweed4:amd64 (3.2-1) ...
Selecting previously unselected package libffi6:amd64.
Preparing to unpack .../libffi6_3.2.1-6_amd64.deb ...
Unpacking libffi6:amd64 (3.2.1-6) ...
Preparing to unpack .../libp11-kit0_0.23.2-5_amd64.deb ...
Unpacking libp11-kit0:amd64 (0.23.2-5) over (0.18.5-3) ...
Selecting previously unselected package libtasn1-6:amd64.
Preparing to unpack .../libtasn1-6_4.9-4_amd64.deb ...
Unpacking libtasn1-6:amd64 (4.9-4) ...
Selecting previously unselected package libgnutls30:amd64.
Preparing to unpack .../libgnutls30_3.5.4-2_amd64.deb ...
Unpacking libgnutls30:amd64 (3.5.4-2) ...
Selecting previously unselected package libkeyutils1:amd64.
Preparing to unpack .../libkeyutils1_1.5.9-9_amd64.deb ...
Unpacking libkeyutils1:amd64 (1.5.9-9) ...
Selecting previously unselected package libkrb5support0:amd64.
Preparing to unpack .../libkrb5support0_1.14.3+dfsg-2_amd64.deb ...
Unpacking libkrb5support0:amd64 (1.14.3+dfsg-2) ...
Selecting previously unselected package libk5crypto3:amd64.
Preparing to unpack .../libk5crypto3_1.14.3+dfsg-2_amd64.deb ...
Unpacking libk5crypto3:amd64 (1.14.3+dfsg-2) ...
Selecting previously unselected package libkrb5-3:amd64.
Preparing to unpack .../libkrb5-3_1.14.3+dfsg-2_amd64.deb ...
Unpacking libkrb5-3:amd64 (1.14.3+dfsg-2) ...
Selecting previously unselected package libgssapi-krb5-2:amd64.
Preparing to unpack .../libgssapi-krb5-2_1.14.3+dfsg-2_amd64.deb ...
Unpacking libgssapi-krb5-2:amd64 (1.14.3+dfsg-2) ...
Selecting previously unselected package libcups2:amd64.
Preparing to unpack .../libcups2_2.2.0-2_amd64.deb ...
Unpacking libcups2:amd64 (2.2.0-2) ...
Selecting previously unselected package liblcms2-2:amd64.
Preparing to unpack .../liblcms2-2_2.7-1_amd64.deb ...
Unpacking liblcms2-2:amd64 (2.7-1) ...
Selecting previously unselected package libjpeg62-turbo:amd64.
Preparing to unpack .../libjpeg62-turbo_1%3a1.5.1-1_amd64.deb ...
Unpacking libjpeg62-turbo:amd64 (1:1.5.1-1) ...
Selecting previously unselected package libexpat1:amd64.
Preparing to unpack .../libexpat1_2.2.0-1_amd64.deb ...
Unpacking libexpat1:amd64 (2.2.0-1) ...
Selecting previously unselected package libpng16-16:amd64.
Preparing to unpack .../libpng16-16_1.6.25-1_amd64.deb ...
Unpacking libpng16-16:amd64 (1.6.25-1) ...
Selecting previously unselected package libfreetype6:amd64.
Preparing to unpack .../libfreetype6_2.6.3-3+b1_amd64.deb ...
Unpacking libfreetype6:amd64 (2.6.3-3+b1) ...
Selecting previously unselected package ucf.
Preparing to unpack .../archives/ucf_3.0036_all.deb ...
Moving old data out of the way
Unpacking ucf (3.0036) ...
Selecting previously unselected package fonts-dejavu-core.
Preparing to unpack .../fonts-dejavu-core_2.37-1_all.deb ...
Unpacking fonts-dejavu-core (2.37-1) ...
Selecting previously unselected package fontconfig-config.
Preparing to unpack .../fontconfig-config_2.11.0-6.7_all.deb ...
Unpacking fontconfig-config (2.11.0-6.7) ...
Selecting previously unselected package libfontconfig1:amd64.
Preparing to unpack .../libfontconfig1_2.11.0-6.7_amd64.deb ...
Unpacking libfontconfig1:amd64 (2.11.0-6.7) ...
Selecting previously unselected package libpcsclite1:amd64.
Preparing to unpack .../libpcsclite1_1.8.18-1_amd64.deb ...
Unpacking libpcsclite1:amd64 (1.8.18-1) ...
Selecting previously unselected package libxrender1:amd64.
Preparing to unpack .../libxrender1_1%3a0.9.9-2_amd64.deb ...
Unpacking libxrender1:amd64 (1:0.9.9-2) ...
Selecting previously unselected package openjdk-8-jre-headless:amd64.
Preparing to unpack .../openjdk-8-jre-headless_8u102-b14.1-2_amd64.deb ...
Unpacking openjdk-8-jre-headless:amd64 (8u102-b14.1-2) ...
Selecting previously unselected package junit.
Preparing to unpack .../archives/junit_3.8.2-8_all.deb ...
Unpacking junit (3.8.2-8) ...
Selecting previously unselected package libhamcrest-java.
Preparing to unpack .../libhamcrest-java_1.3-5_all.deb ...
Unpacking libhamcrest-java (1.3-5) ...
Selecting previously unselected package junit4.
Preparing to unpack .../archives/junit4_4.12-4_all.deb ...
Unpacking junit4 (4.12-4) ...
Selecting previously unselected package libasm-java.
Preparing to unpack .../libasm-java_5.1-1_all.deb ...
Unpacking libasm-java (5.1-1) ...
Selecting previously unselected package libbsh-java.
Preparing to unpack .../libbsh-java_2.0b4-18_all.deb ...
Unpacking libbsh-java (2.0b4-18) ...
Selecting previously unselected package libcglib-java.
Preparing to unpack .../libcglib-java_3.2.4-1_all.deb ...
Unpacking libcglib-java (3.2.4-1) ...
Selecting previously unselected package libjmock-java.
Preparing to unpack .../libjmock-java_1.2.0-4_all.deb ...
Unpacking libjmock-java (1.2.0-4) ...
Selecting previously unselected package libobjenesis-java.
Preparing to unpack .../libobjenesis-java_2.4-1_all.deb ...
Unpacking libobjenesis-java (2.4-1) ...
Selecting previously unselected package libjmock2-java.
Preparing to unpack .../libjmock2-java_2.8.2-1_all.deb ...
Unpacking libjmock2-java (2.8.2-1) ...
dpkg: error processing archive 
/var/cache/apt/archives/libjmock2-java_2.8.2-1_all.deb (--unpack):
 trying to overwrite '/usr/share/java/jmock.jar', which is also in package 
libjmock-java 1.2.0-4
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for libc-bin (2.24-3) ...
Processing triggers for man-db (2.7.5-1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/libjmock2-java_2.8.2-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


This is a serious bug as it makes installation fail, and violates
sections 7.6.1 and 10.1 of the policy. An optimal solution would
consist in only one of the packages installing that file, and renaming
or removing the file in the other package. Depending on the
circumstances you might also consider Replace relations or file
diversions. If the conflicting situation cannot be resolved then, as a
last resort, the two packages have to declare a mutual
Conflict. Please take into account that Replaces, Conflicts and
diversions should only be used when packages provide different
implementations for the same functionality.

Here is a list of files that are known to be shared by both packages
(according to the Contents file for sid/amd64, which may be
slightly out of sync):

  /usr/share/java/jmock.jar

This bug has been filed against both packages. If you, the maintainers of
the two packages in question, have agreed on which of the packages will
resolve the problem please reassign the bug to that package. You may then
also register in the BTS that the other package is affected by the bug.

-Ralf.

PS: for more information about the detection of file overwrite errors
of this kind see http://qa.debian.org/dose/file-overwrites.html.

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to