Emmanuel Bourg a écrit le 11/12/2016 à 00:02 :
> Le 10/12/2016 à 14:56, Gilles Filippini a écrit :
> 
>> It's too late for stretch, because it would trigger a transition.
>> Anyway, I've made a package for release 2.7.0.
>> Emmanuel, permission to upload to experimental?
> 
> Hi Gilles, I don't give permissions, you don't need it actually, but I'm
> happy to give some advices.

Thanks. I asked in case you were working on this release too.

> What is the level of compatibility between jython 2.5 and 2.7? There
> aren't many package using jython, so if you have the version 2.7 ready I
> wouldn't mind if it was uploaded to unstable. And if the transition is
> too difficult we could upload a new jython-2.7 package, that would be
> less disruptive.

AFAICT the compatibility level is good: I've tested it against sikulix.
*But* this is Java, and some buildtime and runtime java dependencies
were changed and might cause FTBFS or runtime breakage to reverse
dependencies du to broken classpath. It does to at least sikulix, plm,
and monkeyrunner.

Hence I'd rather upload to experimental.

_g.

Attachment: signature.asc
Description: OpenPGP digital signature

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to