Package: libresteasy-java
Version: 3.0.19-2
Severity: serious

Dear maintainer,

The META-INF/MANIFEST.MF of the JAR files in this package state that
this package depends on servlet-api-2.5.jar which has now been removed
from testing/stretch and unstable/sid:

Class-Path: /usr/share/java/servlet-api-2.5.jar /usr/share/java/log4j-1.
 2.jar /usr/share/java/slf4j-api.jar /usr/share/java/slf4j-simple.jar /us
 r/share/java/scannotation.jar /usr/share/java/httpclient.jar /usr/share/
 java/commons-io.jar /usr/share/java/tomcat-annotations-api.jar /usr/shar
 e/java/el-api-2.1.jar

While a binNMU would correct the immediate issue, a larger issue exists
in that the Debian package does not state this dependency, and so I have
ended up with broken libresteasy-java JARs on my system.

Disclaimer: I am no Java developer, but an application I use is failing
to start because it indirectly depends on servlet-api-2.5.jar.

HTH,
Chris

-- System Information:
Debian Release: stretch/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.8.0-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages libresteasy-java depends on:
ii  libcommons-io-java     2.5-1
ii  libhttpclient-java     4.5.2-2
ii  libjackson-json-java   1.9.2-8
ii  libjaxb-java           2.2.5-2
ii  libjaxrs-api-java      2.0.1-1
ii  libjboss-logging-java  3.3.0-2
ii  libjettison-java       1.2-3
ii  libtomcat8-java        8.5.9-2
ii  libyaml-snake-java     1.17-1

Versions of packages libresteasy-java recommends:
ii  libjboss-logging-tools-java  2.0.2-1

libresteasy-java suggests no packages.

-- no debconf information

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to