Your message dated Tue, 10 Jan 2017 11:34:37 +0000
with message-id <e1cquhj-000fsf...@fasolo.debian.org>
and subject line Bug#836100: fixed in java-gnome 4.1.3-5
has caused the Debian Bug report #836100,
regarding java-gnome: please take screenshots using dbus-run-session, not 
dbus-launch
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
836100: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=836100
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Source: java-gnome
Version: 4.1.3-4
Severity: normal
Tags: upstream
User: d...@packages.debian.org
Usertags: dbus-launch dbus-launch-for-infra

As described in <https://lists.debian.org/debian-devel/2016/08/msg00554.html>
I'm trying to reduce how much dbus-launch is used in Debian.

This package currently has build-time code that depends on dbus-x11 and
explicitly runs dbus-launch as a wrapper around metacity:

    windowManager = r.exec("/usr/bin/dbus-launch /usr/bin/metacity --display=" 
+ DISPLAY);

Instead please use dbus-run-session, which will avoid leaking a dbus-daemon 
process:

    windowManager = r.exec("/usr/bin/dbus-run-session -- /usr/bin/metacity 
--display=" + DISPLAY);

and change the build-dependency from dbus-x11 to dbus (>= 1.8).

Thanks,
    S

--- End Message ---
--- Begin Message ---
Source: java-gnome
Source-Version: 4.1.3-5

We believe that the bug you reported is fixed in the latest version of
java-gnome, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 836...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Emmanuel Bourg <ebo...@apache.org> (supplier of updated java-gnome package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Tue, 10 Jan 2017 12:05:43 +0100
Source: java-gnome
Binary: libjava-gnome-java libjava-gnome-jni libjava-gnome-java-doc
Architecture: source all amd64
Version: 4.1.3-5
Distribution: unstable
Urgency: medium
Maintainer: Debian Java Maintainers 
<pkg-java-maintainers@lists.alioth.debian.org>
Changed-By: Emmanuel Bourg <ebo...@apache.org>
Description:
 libjava-gnome-java - Java-gnome language bindings project
 libjava-gnome-java-doc - Java-gnome language bindings project documentation
 libjava-gnome-jni - Java-gnome language bindings project JNI layer
Closes: 779344 836100 849669
Changes:
 java-gnome (4.1.3-5) unstable; urgency=medium
 .
   * Team upload.
   * Build with the DH sequencer instead of CDBS (Closes: #849669)
   * Use dbus-run-session instead of dbus-launch to run metacity
     and depend on dbus (>= 1.8) instead of dbus-x11 (Closes: #836100)
   * Disabled parallel building (Closes: #779344)
   * Standards-Version updated to 3.9.8
   * Switch to debhelper level 10
   * Use secure Vcs-* URLs
Checksums-Sha1:
 0f68de9ddea4d81a71884a6355582c9a09742213 2489 java-gnome_4.1.3-5.dsc
 c40b1c89acf92999ee36bc628af3604685cead99 8576 java-gnome_4.1.3-5.debian.tar.xz
 9f43ba28e466f1c09e32b5c51bd918ceccb568e2 15189 
java-gnome_4.1.3-5_amd64.buildinfo
 5eab56599d8fc77f4b4ffeb1cdfa7cebbb0b6eaa 940948 
libjava-gnome-java-doc_4.1.3-5_all.deb
 f80e4d893ff8718169037066cba3fc7e486ce964 1261164 
libjava-gnome-java_4.1.3-5_all.deb
 f48a4d5d1452fcc7179764beb7c39ec6c883baf7 1180588 
libjava-gnome-jni-dbgsym_4.1.3-5_amd64.deb
 6c828436da0b2c67e5b744d9588fc085820f387d 167212 
libjava-gnome-jni_4.1.3-5_amd64.deb
Checksums-Sha256:
 c7db4cf898cde024e415a8e1135bc8e85a7f1e98d61c5c71f92e7b72e650551d 2489 
java-gnome_4.1.3-5.dsc
 7eec82661f76b9236cbe82413060b8ac0ab90cad9f31de91a054b8be51b892a3 8576 
java-gnome_4.1.3-5.debian.tar.xz
 fa0180533d13291366c2697a7874a9cfe9ce65e130dec15240bc17ec55c5b133 15189 
java-gnome_4.1.3-5_amd64.buildinfo
 f18c25e28541fc8c128209a4a001db1c6b2e9fa4a40381e7273a5ab5f0637f19 940948 
libjava-gnome-java-doc_4.1.3-5_all.deb
 256d4d0f898def673424298ccab0b6d820c4ec0abe2eaf12a432024551fc9b81 1261164 
libjava-gnome-java_4.1.3-5_all.deb
 eb2126c009a71f34d71011e79ac9c414b3a5555ea1ba23f32acd4bb421bfcf25 1180588 
libjava-gnome-jni-dbgsym_4.1.3-5_amd64.deb
 de4f22f0cf5fbc411ad21a8dc45ebab855f3366c277c402692a262a4e0e64783 167212 
libjava-gnome-jni_4.1.3-5_amd64.deb
Files:
 7985051ab4e0a1405a34b5b045681597 2489 java optional java-gnome_4.1.3-5.dsc
 9487953f9ce0ad5f75e433abd2368286 8576 java optional 
java-gnome_4.1.3-5.debian.tar.xz
 bf8e0e7f1fca650d9141d6ac409a2323 15189 java optional 
java-gnome_4.1.3-5_amd64.buildinfo
 e49e3b1c78edbdf03fe07ec793f75840 940948 doc optional 
libjava-gnome-java-doc_4.1.3-5_all.deb
 484dfc4ee1245b345b156470568bdab8 1261164 java optional 
libjava-gnome-java_4.1.3-5_all.deb
 3ea51375a332f950558cb01dfd3e82b3 1180588 debug extra 
libjava-gnome-jni-dbgsym_4.1.3-5_amd64.deb
 707a8af0c9b9ce7c22ebcaa39df321d3 167212 java optional 
libjava-gnome-jni_4.1.3-5_amd64.deb

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEuM5N4hCA3PkD4WxA9RPEGeS50KwFAlh0wkUACgkQ9RPEGeS5
0Kzz+g//SF69zUrHzVLIaghcXMVwL63CFS04qv+BwIwo5NDxRZ/Y7jLriYsRVcHr
rX/9BzIH0XCedD1BRB+OssmlXpNFe0xzfaJNZ8O9gmSb+RFG46iX1JlDAT2xgOsv
orlkChF5GlYkldBWaZuKowp314RcMjsHBhsvH44OMe76LwEwYRPufuTbzAyiNAHg
MwT4yIBEn4ZQDwjj46fzjyAo/+0pD4ffmkDP1DEF988BQy/cdCyMCu9uMEjpU7Yb
GHFmg39Egj/2gi7h9A9I6QAxpOCqn/0pYg/Plxpj3E+nv3szzXa6NHx/z5wh2EjQ
yDPazIqiAckPNKyC0xjZLwktqquQWLWvKSBr+wkSmgkicyjy6F1/zgMXfAQWtNmT
yGvVyFs2CwV16MPnKyZvX0IXHUkrASffbz6KJKpYdT2oW5EV7h+YIIi46jp6jQvn
uU+GGE6th51IL+GE9eDmUPZZPfEQdYHEIqAOociTqWSfaP2cUnYi+GQu/vpdS8wt
m4m3U7L5dy7VC6STEwcOYAGrGpibGiIHazF6xKmYddWBwc1d8fBQ3I3GpelE6p74
fcoUYA+2wZnxLS4E5uoh0gaADGOXD1yjgWBWdEDL+9SKYB6KGF7hHBAHmb022E/p
uLSWObCJCXPOSB55LtownFjWJd/297wP/X8rqbCP8YZMBW9sO2I=
=lrDb
-----END PGP SIGNATURE-----

--- End Message ---
__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to