Le 28/02/2017 à 18:59, Paride Legovini a écrit :

> Even better: as most packages with a hard dependency on proguard really
> depend only on the library, you could let this package Recommend: both
> proguard-cli and proguard-gui. The current behavior is not changed, as
> by default recommended packages are installed. Still, packages actually
> depending only on the library are installable without bringing in the
> cli and gui tools.

Hi Paride,

The packages using only the library should depend on libproguard-java.
proguard depends on proguard-cli and proguard-gui to preserve the
compatibility with the previous versions of the package (i.e. installing
proguard should pull the cli/gui, even if --no-install-recommends is
specified).

Emmanuel Bourg

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to