On Wed, Mar 15, 2017 at 05:22:27PM +0100, Emmanuel Bourg wrote:

Hi Emmanuel,

> Thank you for the patch Sven. This looks like a reasonable compromise to
> support multiple releases. Regarding the implementation, I wonder if
> this could be achieved with an override_dh_shlibdeps in the rules file
> used to generate the package.

Seems to work equally well. Patch attached.

Sven
diff --git a/lib/javase.sh b/lib/javase.sh
index fd025ca..3b11095 100644
--- a/lib/javase.sh
+++ b/lib/javase.sh
@@ -88,12 +88,21 @@ EOF
 override_dh_compress:
 	dh_compress \$(shell find $j2se_name/man/ -type f ! -name '*.gz' -printf '${jvm_base##/}/%p\n')
 
-override_dh_shlibdeps:
-	dh_shlibdeps \$(EXCLUDE_LIBS) -l\$(shell find $j2se_name -type f -name '*.so*' -printf '${jvm_base##/}/%h\n' | sort -u | tr '\n' ':' | sed 's/:\$\$//')
-
 override_dh_strip_nondeterminism:
 	# Disable dh_strip_nondeterminism to speed up the build
 EOF
+    if [ "${no_deps:-false}" == "true" ]; then
+	cat << EOF
+override_dh_shlibdeps:
+        # Disabled, aides to generate one package for different Debian releases - BTS #857847
+EOF
+    else
+	cat << EOF
+override_dh_shlibdeps:
+	dh_shlibdeps \$(EXCLUDE_LIBS) -l\$(shell find $j2se_name -type f -name '*.so*' -printf '${jvm_base##/}/%h\n' | sort -u | tr '\n' ':' | sed 's/:\$\$//')
+EOF
+    fi
+
 }
 
 j2se_doc_rules() {
@@ -106,6 +115,12 @@ j2se_doc_rules() {
 override_dh_strip_nondeterminism:
 	# Disable dh_strip_nondeterminism to speed up the build
 EOF
+    if [ "${no_deps:-false}" == "true" ]; then
+	cat << EOF
+override_dh_shlibdeps:
+        # Disabled, aides to generate one package for different Debian releases - BTS #857847
+EOF
+    fi
 }
 
 
diff --git a/make-jpkg b/make-jpkg
index 3db992c..6498b61 100755
--- a/make-jpkg
+++ b/make-jpkg
@@ -89,6 +89,7 @@ The following options are recognized:
   --source             build a source package instead of a binary deb package
   --with-system-certs  integrate with the system's keystore
   --jce-policy FILE    Replace cryptography files with versions from FILE
+  --no-deps            Adds override for dh_shlibdeps based "Depends"
 
   --help               display this help and exit
   --version            output version information and exit
@@ -146,6 +147,8 @@ while [[ $# -gt 0 && "x$1" == x--* ]]; do
     revision="-${1}"
     elif [[ "x$1" == x--changes ]]; then
     genchanges="true"
+    elif [[ "x$1" == x--no-deps ]]; then
+    no_deps="true"
     elif [[ "x$1" == x--source ]]; then
     build_source="true"
     elif [[ "x$1" == x--with-system-certs ]]; then
diff --git a/make-jpkg.1 b/make-jpkg.1
index 34a5462..47eb2f9 100644
--- a/make-jpkg.1
+++ b/make-jpkg.1
@@ -70,6 +70,10 @@ ca-certificates and ca-certificates-java packages.
 Replace cryptography files with versions
 from the specified JCE_POLICY_FILE.
 .TP
+.B --no-deps
+Adds override for dh_shlibdeps based "Depends". Allows to build a package
+without Debian release specific depdencies.
+.TP
 .B --help
 display help text and exit
 .TP
__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to