Emmanuel Bourg <ebo...@apache.org> (2017-06-15):
> Is this the only solution?

Probably not, but reverting the single change that triggered the
regression looks like a safe way to unbreak this situation. Especially
when the said change only happened many months after the relevant
package was removed from the archive (2017-05-31 vs. 2016-04-22)…

> That's a bit odd to retain the openjdk-7 dependency on
> ca-certificates-java and potentially stick with it forever.

This is incorrect. See my reply in:
  https://bugs.debian.org/864597#100

> Maybe we should simply remove the JRE dependency on
> ca-certificates-java and move the keystore generation to openjdk-8.
> That would also solve the circular dependency (#864657).

Tentative release date minus days isn't the time to deal with circular
dependencies IMHO.

> If you upload a NMU could you please push the changes to the Git
> repository?

Not possible since I'm not a member of pkg-java, and since you don't
seem to allow non-member access:
| $ git push origin HEAD $(git describe)
| Counting objects: 6, done.
| Delta compression using up to 4 threads.
| Compressing objects: 100% (6/6), done.
| Writing objects: 100% (6/6), 1.66 KiB | 0 bytes/s, done.
| Total 6 (delta 3), reused 0 (delta 0)
| remote: error: insufficient permission for adding an object to repository 
database ./objects
| remote: fatal: failed to write object
| error: unpack failed: unpack-objects abnormal exit
| To ssh://git.debian.org/git/pkg-java/ca-certificates-java.git
|  ! [remote rejected] HEAD -> master (unpacker error)
|  ! [remote rejected] debian/20170531+nmu1 -> debian/20170531+nmu1 (unpacker 
error)
| error: failed to push some refs to 
'ssh://git.debian.org/git/pkg-java/ca-certificates-java.git'

git format-patch -1 attached though.


KiBi.
From aff0969f1233ae2a60cd1d6679ce2abfe218facb Mon Sep 17 00:00:00 2001
From: Cyril Brulebois <k...@debian.org>
Date: Fri, 16 Jun 2017 08:01:25 +0200
Subject: [PATCH] Revert to depending on openjdk-7 instead of openjdk-8 (See:
 #864597).

This change triggered a failure to dist-upgrade, due to the triggers
loop.

The openjdk-7 package was dropped from stretch, but the
java7-runtime-headless alternative dependency is satisfied by openjdk-8.
---
 debian/changelog | 10 ++++++++++
 debian/rules     |  4 ++--
 2 files changed, 12 insertions(+), 2 deletions(-)

diff --git a/debian/changelog b/debian/changelog
index 7304327..8357713 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+ca-certificates-java (20170531+nmu1) unstable; urgency=high
+
+  * Non-maintainer upload.
+  * Revert to depending on openjdk-7 instead of openjdk-8, since this triggers
+    a failure to dist-upgrade, due to the triggers loop (See: #864597). The
+    openjdk-7 package was dropped from stretch, but the java7-runtime-headless
+    alternative dependency is satisfied by openjdk-8.
+
+ -- Cyril Brulebois <k...@debian.org>  Thu, 15 Jun 2017 17:33:00 +0200
+
 ca-certificates-java (20170531) unstable; urgency=medium
 
   * Team upload.
diff --git a/debian/rules b/debian/rules
index 28363d3..8f78b46 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,11 +6,11 @@
 
 ifeq ($(shell dpkg-vendor --derives-from Ubuntu && echo yes),yes)
 	SUBSTVARS = -Vnss:Depends="libnss3 (>= 3.12.9+ckbi-1.82-0ubuntu3~)" \
-				-Vjre:Depends="openjdk-8-jre-headless"
+				-Vjre:Depends="openjdk-7-jre-headless"
 	nss_lib = libnss3
 else
 	SUBSTVARS = -Vnss:Depends="libnss3 (>= 3.12.10-2~)" \
-				-Vjre:Depends="openjdk-8-jre-headless"
+				-Vjre:Depends="openjdk-7-jre-headless"
 	nss_lib = libnss3
 endif
 
-- 
2.1.4

Attachment: signature.asc
Description: Digital signature

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to