Your message dated Mon, 04 Sep 2017 06:19:28 +0000
with message-id <e1dokji-00039o...@fasolo.debian.org>
and subject line Bug#605063: fixed in batik 1.9-1
has caused the Debian Bug report #605063,
regarding batik is crashing (libbatik-java)
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
605063: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=605063
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: libbatik-java
Version: 1.7-7
Severity: normal

This bug was orinigally reported by Toufik against the Ubuntu package, 
see https://bugs.launchpad.net/ubuntu/+source/batik/+bug/579710 but it 
also affects the package in Debian.

It appears to be caused by a lack of Class-Path entries in the batik.jar 
file. The upstream batik.jar file is mostly classpath entries pointing 
to the other batik jars, plus some of the dependent libraries.

Original report:

Ubuntu Version : Ubuntu 9.10

$ apt-cache policy libbatik-java
libbatik-java:
  Installed: 1.7.ubuntu-4ubuntu1
  Candidate: 1.7.ubuntu-4ubuntu1
  Version table:
 *** 1.7.ubuntu-4ubuntu1 0
        500 http://nz.archive.ubuntu.com karmic/universe Packages
        100 /var/lib/dpkg/status

The repository version of batik (libbatik-java package) is crashing. Note that 
the official version from http://xmlgraphics.apache.org/batik/ (same version 
mumber) works fine

$ java -jar /usr/share/java/batik.jar
Exception in thread "main" java.lang.NoClassDefFoundError: 
org/w3c/dom/svg/SVGDocument
 at java.lang.Class.getDeclaredMethods0(Native Method)
 at java.lang.Class.privateGetDeclaredMethods(Class.java:2427)
 at java.lang.Class.getDeclaredMethod(Class.java:1935)
 at java.awt.Component.isCoalesceEventsOverriden(Component.java:5948)
 at java.awt.Component.access$500(Component.java:169)
 at java.awt.Component$3.run(Component.java:5902)
 at java.awt.Component$3.run(Component.java:5900)
 at java.security.AccessController.doPrivileged(Native Method)
 at java.awt.Component.checkCoalescing(Component.java:5899)
 at java.awt.Component.<init>(Component.java:5868)
 at java.awt.Container.<init>(Container.java:251)
 at java.awt.Window.<init>(Window.java:431)
 at java.awt.Frame.<init>(Frame.java:403)
 at java.awt.Frame.<init>(Frame.java:368)
 at javax.swing.JFrame.<init>(JFrame.java:158)
 at org.apache.batik.apps.svgbrowser.JSVGViewerFrame.<init>(Unknown Source)
 at org.apache.batik.apps.svgbrowser.Main.<init>(Unknown Source)
 at org.apache.batik.apps.svgbrowser.Main.main(Unknown Source)
Caused by: java.lang.ClassNotFoundException: org.w3c.dom.svg.SVGDocument
 at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
 at java.security.AccessController.doPrivileged(Native Method)
 at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
 at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
 at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
 at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
 ... 18 more

-- System Information:
Debian Release: squeeze/sid
  APT prefers lucid-updates
  APT policy: (500, 'lucid-updates'), (500, 'lucid-security'), (500, 'lucid')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-26-generic (SMP w/4 CPU cores)
Locale: LANG=en_GB.utf8, LC_CTYPE=en_GB.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libbatik-java depends on:
ii  default-jre-headless 1.6-34              Standard Java or Java compatible R
ii  java-wrappers        0.1.15              wrappers for java executables
ii  libavalon-framework- 4.2.0-7             Common framework for Java server a
ii  libbsf-java          1:2.4.0-3           Bean Scripting Framework to suppor
ii  libcommons-io-java   1.4-2ubuntu1        Common useful IO related classes
ii  libcommons-logging-j 1.1.1-7             commmon wrapper interface for seve
ii  libxalan2-java       2.7.1-5ubuntu1      XSL Transformations (XSLT) process
ii  libxml-commons-exter 1.3.05-1            XML Commons external code - DOM, S
ii  openjdk-6-jre-headle 6b18-1.8.2-4ubuntu2 OpenJDK Java runtime, using Hotspo
ii  sun-java6-jre [java2 6.22-0ubuntu1~10.04 Sun Java(TM) Runtime Environment (

Versions of packages libbatik-java recommends:
pn  fop                  <none>              (no description available)
ii  openjdk-6-jre        6b18-1.8.2-4ubuntu2 OpenJDK Java runtime, using Hotspo
ii  rhino                1.7R2-3             JavaScript engine written in Java

libbatik-java suggests no packages.

-- no debconf information



--- End Message ---
--- Begin Message ---
Source: batik
Source-Version: 1.9-1

We believe that the bug you reported is fixed in the latest version of
batik, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 605...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Christopher Hoskin <mans0...@debian.org> (supplier of updated batik package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Mon, 04 Sep 2017 06:57:58 +0100
Source: batik
Binary: libbatik-java
Architecture: source
Version: 1.9-1
Distribution: unstable
Urgency: medium
Maintainer: Debian Java Maintainers 
<pkg-java-maintainers@lists.alioth.debian.org>
Changed-By: Christopher Hoskin <mans0...@debian.org>
Description:
 libbatik-java - xml.apache.org SVG Library
Closes: 605063 860566
Changes:
 batik (1.9-1) unstable; urgency=medium
 .
   * Team upload.
   * Moved the package to Git
   * Updated signing keys from 
https://www.apache.org/dist/xmlgraphics/batik/KEYS
   * Exclude jar files from documentation-sources
   * Add repack script to remove non-free ICC profiles
   * New upstream (1.9)
       + Fix "CVE-2017-5662: information disclosure vulnerability" Upstream 
claim
         BATIK-1139 is fixed in 1.9 (Closes: #860566)
   * Disable old patches, pending further investigation
   * Get package building again
       +  maven-artifacts is no longer a target, explicitly add jars to
          DEB_ANT_BUILD_TARGET
       +  Add debian/debian/libbatik-java.poms, call mh_install to install jars
          and poms, for closer alignment to other pkg-java packages
   * Fix spellings in debian/manpages/rasterizer.1
   * Remove redundant remove-js.patch
   * Fix "batik is crashing (libbatik-java)" by patching build.xml to specify
     classpaths as appropriate for Debian (Closes: #605063)
   * Update Standards-Version from 3.9.8 to 4.0.0 (no change required)
   * Update 06_fix_paths_in_policy_files.patch
   * Remove bug805469.patch (fixed upstream
     http://svn.apache.org/viewvc?view=revision&revision=1687506)
   * Update debian/copyright
   * Remove unnecessary greater-than versioned dependencies from debian/control
Checksums-Sha1:
 6bb3201e990bc0061b7356a09d2c148908bd54c5 2195 batik_1.9-1.dsc
 eb839782910346fe98b50052438fefb52fd37943 5665818 batik_1.9.orig.tar.gz
 b567bf2f9110d0cfbb4f62c1a2f7bb4eaa90180c 32800 batik_1.9-1.debian.tar.xz
 34c2600a113eb576ec5141724c581e8c54493b1b 10649 batik_1.9-1_amd64.buildinfo
Checksums-Sha256:
 44e8df4c8abce1c285a83542d3efe655f5ae890cd0e5946097c10457252f96ba 2195 
batik_1.9-1.dsc
 a5ec2a8652411db69218ca3cbcaab877735e684af63de6c08f6629321f1b3761 5665818 
batik_1.9.orig.tar.gz
 b94691cd86c0833671e72765756829628ac16de7263d86fd51f85d4fb5653275 32800 
batik_1.9-1.debian.tar.xz
 95e714f25d3ac34414859c5119b23a7d6f218fde777342ff58507bda40052e5b 10649 
batik_1.9-1_amd64.buildinfo
Files:
 168ee81bc4e667c28d8657727cf0e745 2195 java optional batik_1.9-1.dsc
 7c94980690cecd4b86bbde1c72d4e54f 5665818 java optional batik_1.9.orig.tar.gz
 9bb270c7e492a329c1d171bf6bd07c81 32800 java optional batik_1.9-1.debian.tar.xz
 6bc3fd4a13958e32a6babe31bb3cc67c 10649 java optional 
batik_1.9-1_amd64.buildinfo

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEbctJ5K6JlvFsvhGhf6qUsnUUSpoFAlms7WIACgkQf6qUsnUU
Spr9oRAAlCtm1hHJjr0jorNTtomouiF7BfJv8l03T8L+UXQmi+DdIkJvCDluYF3n
ut92kLPaZvUCmQMr4Tf++QrT8AEpUxb6cL73OYjO/HxPBR92QUn8LRHC38I8UPxs
YCw8ZXKvMlWbsptG3V5hY27aqiPX27UsHUU3/Qpc3maI5PbpAY4Tfa/vv7jTCmAN
8krvhThSGLa087Hl0FOeKtRVSMGCWESv5psw8Pd52C6YsnSS3QDUFQP3L869M8vc
PgPV4hdA/86k13IXrbrpEvK7jsNLttwiB4xkcBXAtZl5Sdx3xwBsDhk+sryrhsVr
O4ghzf23nLQokfxsfQRg+H6m/FJS9VW/qh54E23xSwoan4qaXShxPZ9m6ewBQPPI
ZmUybev3/tChfr/tyY0U1CZf3W9Z9KLNkvr7IK7qja2Ol+e/XiYlQxKIj7ro6WpW
VL/45MG3qt2GV+bvbmGrwg/gb/vNMM4ol2d36H89FNsfxIoAsNjos8u8z5U7mRRg
4wVV8xn9fJxUvnzz5JXI+YPd+BovkPGNh37sjDDbOgbhoSymnZhDW5czcHSnNVRD
/Y37e0BQu42HoJI7hzVXOzU/Qf6znFoVzPTVIwCyMCtSwQXuN3xnzNWpTgHBz4dx
iXpoN9kqLzjG5BqD7HAYeion2UCa4P1C2KsA+vgG8FO0M3H+k2w=
=k5Jp
-----END PGP SIGNATURE-----

--- End Message ---
__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to