Your message dated Wed, 29 Nov 2017 22:34:47 +0000
with message-id <e1ekawj-000cgg...@fasolo.debian.org>
and subject line Bug#875583: fixed in jedit 5.4.0+dfsg-2
has caused the Debian Bug report #875583,
regarding FTBFS with Java 9: checks for java 8
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
875583: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=875583
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Source: jedit
Version: 5.4.0+dfsg
Severity: normal
User: debian-j...@lists.debian.org
Usertags: default-java9

This package fails to build with default-jdk pointing to openjdk-9-jdk.
Please fix it, so that we can start the transition to Java 9.
The wiki has some common problems and their solutions:
https://wiki.debian.org/Java/Java9Pitfalls

Build log:

init:
     [echo] Buildfile for jedit (/build/jedit-5.4.0+dfsg/build.xml)

BUILD FAILED
/build/jedit-5.4.0+dfsg/build.xml:78: Java 1.8 is needed for jEdit to build, 
please install it and rerun (found Java version: '9')


Cheers,
Chris.

--- End Message ---
--- Begin Message ---
Source: jedit
Source-Version: 5.4.0+dfsg-2

We believe that the bug you reported is fixed in the latest version of
jedit, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 875...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Markus Koschany <a...@debian.org> (supplier of updated jedit package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Wed, 29 Nov 2017 22:54:30 +0100
Source: jedit
Binary: jedit
Architecture: source
Version: 5.4.0+dfsg-2
Distribution: unstable
Urgency: medium
Maintainer: Debian Java Maintainers 
<pkg-java-maintainers@lists.alioth.debian.org>
Changed-By: Markus Koschany <a...@debian.org>
Description:
 jedit      - Plugin-based editor for programmers
Closes: 875583
Changes:
 jedit (5.4.0+dfsg-2) unstable; urgency=medium
 .
   * Team upload.
   * Declare compliance with Debian Policy 4.1.1.
   * Use canonical VCS address.
   * Remove override for dh_builddeb because xz is the default compressor now.
   * Remove source/options file because xz is the default now.
   * Fix FTBFS with OpenJDK 9.
     Thanks to Chris West for the report. (Closes: #875583)
   * Require at least Java 8 for compilation.
   * Fix jedit.sh script and require at least a Java 8 runtime.
Checksums-Sha1:
 7713b13782f62708bddbfabf9d26eefde2539765 2384 jedit_5.4.0+dfsg-2.dsc
 32fe84f62b28d534d6062ee8d4814e780d558341 22928 jedit_5.4.0+dfsg-2.debian.tar.xz
 d664cdd85488c9ae7dd9e605f1a382b413424a28 12676 
jedit_5.4.0+dfsg-2_amd64.buildinfo
Checksums-Sha256:
 b1e67bdf162278201aeb3fe4d99a6f8df5e91d500e4997e9bf80bbe82e38a89a 2384 
jedit_5.4.0+dfsg-2.dsc
 fcd04707c555b4f8f39db9e7df4ab90552c9af2a7a29b6cbb1a272419ae35e89 22928 
jedit_5.4.0+dfsg-2.debian.tar.xz
 004eda90cbe92a8db24949b69ce5e5a1887c6ad361de0acb40340504fc93cacc 12676 
jedit_5.4.0+dfsg-2_amd64.buildinfo
Files:
 4c84596c8ab1ea5295a121928dfde1b6 2384 editors optional jedit_5.4.0+dfsg-2.dsc
 f2b1474810616f367edc5491f2c2af12 22928 editors optional 
jedit_5.4.0+dfsg-2.debian.tar.xz
 f8f2ab0290f49fdaa3f3197442d2692f 12676 editors optional 
jedit_5.4.0+dfsg-2_amd64.buildinfo

-----BEGIN PGP SIGNATURE-----

iQKjBAEBCgCNFiEErPPQiO8y7e9qGoNf2a0UuVE7UeQFAlofMNRfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldEFD
RjNEMDg4RUYzMkVERUY2QTFBODM1RkQ5QUQxNEI5NTEzQjUxRTQPHGFwb0BkZWJp
YW4ub3JnAAoJENmtFLlRO1HkCWcP/ij51oWJvE1MEFiKT0IwoPi5AZyE30GYIDXe
o+Ryjbdn7tC5eC/MC273Gy5f+Ozno96sLNKWT56eIU4m+mFO7D5klDXn0zhR8Gyo
Pkea/hF8vJjdTEgIOOl4mzGugr6lqNJ87xMJTM20+OLv4eHdxmdgGvBENrzM41xx
j56l5oUdzPHxbuw/V0TAiYDuWSBE6702mpPqECDhr15H4sMcl91vhPnzlggzuBBe
I+8hXMD/cwyjmJ0DB6Oi7CRnmyipzpSaBvyzVsu/HF/VaOPcFTeCB6r7nc3LnS+x
ita0uaJrVkKD3R98lDbraCeFPGk623aLgWHbtJ6ewkXw9rzSeTiZkct8laranMEc
9IqNga/R42HR/Gfv5ahDl/MaKsbM/eWB0vHa8ygD95ljPLNY2aoBEM69O2gea6+u
hbwGN4BTd2OI6UYVjIwfDb7qPKf9YgL9BttDY3vYgl9N64YGigWSa9R2PVOUvF39
ooYT7NwSHPGso5/aCt6kZblF4HSpwNa4FWulSoImG+0SzrZbn5EhF7abMRKMGs3y
WJ4HmZ+zfb4V4yTrhVBQ2ueFBFpZd3qY6IC4OTC+AVmH8H69HBIXDeVZ3VrzM7ZP
dH9HzBfoSu8+34gFNJSiKiNMk+Dka1RwKBa9nN02X7hfcZAExmoMhYgFP15UzuY0
JF6WU18M
=Df5V
-----END PGP SIGNATURE-----

--- End Message ---
__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to