Package: libjaxb-java
Version: 2.3.0-3
Severity: serious
Control: affects -1 src:eclipselink

https://tests.reproducible-builds.org/debian/rb-pkg/unstable/amd64/eclipselink.html

...
   debian/rules override_dh_auto_build
make[1]: Entering directory '/build/1st/eclipselink-2.6.5'
ant -f debian/build.xml
Buildfile: /build/1st/eclipselink-2.6.5/debian/build.xml

init:
    [mkdir] Created dir: /build/1st/eclipselink-2.6.5/target/classes
    [mkdir] Created dir: /build/1st/eclipselink-2.6.5/target/jpql
    [mkdir] Created dir: /build/1st/eclipselink-2.6.5/target/modelgen

compile:
    [javac] Compiling 3151 source files to 
/build/1st/eclipselink-2.6.5/target/classes
    [javac] warning: [options] bootstrap class path not set in conjunction with 
-source 1.7
    [javac] 
/build/1st/eclipselink-2.6.5/org/eclipse/persistence/jaxb/plugins/BeanValidationPlugin.java:15:
 error: package com.sun.codemodel does not exist
    [javac] import com.sun.codemodel.JAnnotationArrayMember;
    [javac]                         ^
    [javac] 
/build/1st/eclipselink-2.6.5/org/eclipse/persistence/jaxb/plugins/BeanValidationPlugin.java:16:
 error: package com.sun.codemodel does not exist
    [javac] import com.sun.codemodel.JAnnotationUse;
    [javac]                         ^
    [javac] 
/build/1st/eclipselink-2.6.5/org/eclipse/persistence/jaxb/plugins/BeanValidationPlugin.java:17:
 error: package com.sun.codemodel does not exist
    [javac] import com.sun.codemodel.JAnnotationValue;
    [javac]                         ^
...


Woks after downgrading libjaxb-java to 2.3.0-2.

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to