Your message dated Fri, 08 Dec 2017 00:04:26 +0000
with message-id <e1en69s-000foo...@fasolo.debian.org>
and subject line Bug#800980: fixed in triplea 1.9.0.0.7062-1
has caused the Debian Bug report #800980,
regarding triplea: depends on obsolete libcommons-httpclient-java library
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
800980: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=800980
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: triplea
Severity: normal
User: pkg-java-maintainers@lists.alioth.debian.org
Usertags: oldlibs libcommons-httpclient-java

Hi,

triplea depends on libcommons-httpclient-java, which is obsolete and was
replaced by libhttpclient-java. It has reached EOL status in 2011! It is no
longer supported upstream [1] and was affected by multiple security issues in
the recent past. triplea should be ported to the new libhttpclient-java
version, so that we can remove the old, unmaintained one. Please forward this
issue upstream, if you can't migrate the package yourself.

We would like to see libcommons-httpclient-java removed during the Stretch
release cycle but due to the large number of reverse-dependencies the outcome
depends more than ever on your help.

Please help us to accomplish this goal. We will bump this issue to important
when the list of rdeps is getting smaller and we think that the removal is
possible. We will eventually raise the severity to serious when the number
of rdeps is small.

If you have any questions don't hesitate to ask and contact us on

debian-j...@list.debian.org

Regards,

Markus

[1] https://hc.apache.org/httpclient-3.x/

[2] 
https://security-tracker.debian.org/tracker/source-package/commons-httpclient

--- End Message ---
--- Begin Message ---
Source: triplea
Source-Version: 1.9.0.0.7062-1

We believe that the bug you reported is fixed in the latest version of
triplea, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 800...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Markus Koschany <a...@debian.org> (supplier of updated triplea package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Thu, 07 Dec 2017 23:55:25 +0100
Source: triplea
Binary: triplea
Architecture: source
Version: 1.9.0.0.7062-1
Distribution: unstable
Urgency: medium
Maintainer: Debian Java Maintainers 
<pkg-java-maintainers@lists.alioth.debian.org>
Changed-By: Markus Koschany <a...@debian.org>
Description:
 triplea    - Turn based strategy game
Closes: 800980
Changes:
 triplea (1.9.0.0.7062-1) unstable; urgency=medium
 .
   * Team upload.
   * New upstream version 1.9.0.0.7062-1.
   * Switch to compat level 10.
   * Declare compliance with Debian Policy 4.1.2.
   * Drop libcommons-httpclient-java from Build-Depends. (Closes: #800980)
   * New build system: Gradle.
   * Drop all patches and add these ones instead:
     - build.patch: Use Debian's system libraries.
     - disable-javazoom-audioplayer.patch: The javazoom-audioplayer is not
       available in Debian.
     - no-evil-json.patch: Do not depend on non-free org.json:json artifact.
     - no-Mac.patch: Do not depend on MacOS specific code.
     - JSONException.patch: Fix a FTBFS related to removed/replaced JSON code.
   * Create a proper triplea.manifest file.
   * Remove README.debian, triplea.manifest_old, triplea.links, triplea.doc-base
     and linkjars.
   * Drop deprecated menu file and xpm icon.
   * Remove imagemagick from Build-Depends. Add triplea.png to debian folder and
     avoid that the icons are downloaded at build time.
   * Update debian/copyright for new release.
   * Remove obsolete clean file.
   * Update debian/watch and track new releases at github.com.
   * Update Homepage field.
   * Remove triplea-server script and man page.
   * Remove debian/TODO file.
Checksums-Sha1:
 49c5846268bf95d7b80400af2f9df4d88d43de84 2492 triplea_1.9.0.0.7062-1.dsc
 e31e8f95314904f34459c0c3a924b08f51904429 6331032 
triplea_1.9.0.0.7062.orig.tar.xz
 f0e736b369131fa33ebcd5e1fb49f95bdf6c12ad 48960 
triplea_1.9.0.0.7062-1.debian.tar.xz
 aaa5f2a75ee590006c7398418b7eadf77d41591a 16814 
triplea_1.9.0.0.7062-1_amd64.buildinfo
Checksums-Sha256:
 142c7475741c59e610cb3be883d16e0ce44bbc7ebd91bd27cc7fae581bb844a1 2492 
triplea_1.9.0.0.7062-1.dsc
 6cb4c823677272cd33f8b7458f13a9eaaa69ec5c4bd1b7e124ce607d3e31be09 6331032 
triplea_1.9.0.0.7062.orig.tar.xz
 e3666d7b9b29395981a56662eb2493dd2f73de5c4cd607f5f58b820de3599025 48960 
triplea_1.9.0.0.7062-1.debian.tar.xz
 dc998c3de7015fc6a41c7c2b094b1740bcf13bdfe263e7e1aebd57424e19fcbf 16814 
triplea_1.9.0.0.7062-1_amd64.buildinfo
Files:
 eaac1c01ea7de15f3e24435ae856366c 2492 games optional triplea_1.9.0.0.7062-1.dsc
 f80250de55d40512f6fe7e03f71e5847 6331032 games optional 
triplea_1.9.0.0.7062.orig.tar.xz
 70bc9cf6264648422b614eb1d5d71228 48960 games optional 
triplea_1.9.0.0.7062-1.debian.tar.xz
 2f1a45c8c1368f20bdfc7c35aa62e557 16814 games optional 
triplea_1.9.0.0.7062-1_amd64.buildinfo

-----BEGIN PGP SIGNATURE-----

iQKjBAEBCgCNFiEErPPQiO8y7e9qGoNf2a0UuVE7UeQFAlop011fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldEFD
RjNEMDg4RUYzMkVERUY2QTFBODM1RkQ5QUQxNEI5NTEzQjUxRTQPHGFwb0BkZWJp
YW4ub3JnAAoJENmtFLlRO1Hk1toP/1rYMU8vTJlpHodisLCwlWiKgrBCey9dwhm9
PgPUFUg+F0710wXRDJBx3ruE8zKrXDioN4bnSutf3ZS4y60/R+gpIZZcjhU3D7fJ
/M/tjHfVgxp4AOA7gWLdyC5rD6cOAvfI36PUpART3Ld+/0RwrRqFQiUsKsVXlA6f
Q3hQxr256SfG9KimMXiafoMpjoya6U/3Zur7GWQI32uAAjAoEiLGwQP8SRPA3qnu
zeQ51C3E07pOPdkFAyLOuIb0j/E0jFVFwBMj6dMZBw01ARwC5j/YCIp85XKc6xRw
9jPDgA3Ji8/w9SC4M7KDUs3uV4cYCDjIgYn7AiYHIS8ZIX2YQoAm6Clq5rmdNgTB
oKVAi/ZP1XfJoSCbkOAMHXxMA7YAibSe2+trXblrouZtl2JAzvuawselg082rtLP
tH1ENztwpDoMhJvfrG5KAZffX0nhojscxC2qvxPfSL37iOc5z94/5QOZ24r8DlFZ
P7H9ZdmE3Eq3jGL2aR4oLFX5uNqyJj/gJxIGk4edQiq8pPP+QY930hn7EE+p8BIG
AqRrhBo62agLN1kEbW3XmzaBgal3gON9QANXZS6OTUfudtL1avY8MusGaxWrMFBO
JxLXgsqWoFMdwoORbtITWD4sq/pZo2AlaQoGI54EiI4o1FyCikI3sTyDPpUYnTZi
C/FGx2wK
=/JVn
-----END PGP SIGNATURE-----

--- End Message ---
__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to