Package: maven-debian-helper
Version: 2.2.8
Severity: normal

When a multi-modules project has two modules sharing the same dependency
but with different scopes, maven-debian-helper gets confused and doesn't
use the right dependency group for the associated packaged.

For example with activemq/5.15.2-1, the commons-net dependency is optional
in the activemq-client module but mandatory in the activemq-kahadb-store
module. In this case maven-debian-helper believes the dependency is
optional and puts libcommons-net-java in ${maven:OptionalDepends} instead
of ${maven:Depends}. I haven't checked if the dependencies with the
'provided' scope are also affected by this issue.

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to