Control: tags -1 +patch
Control: severity -1 serious

I am attaching a patch to drop the libswt-gnome-gtk4-jni package. It
has no reverse-depends and it depends on several libraries we are
trying to remove from Buster (libbonobo, libbonoboui, libgnome,
libgnomeui, libgnomevfs).

We'll also need to drop the libswt-gnome-gtk3-jni package but I think
we should wait on figuring out https://bugs.debian.org/880470 first
(we need the package to migrate to testing or it doesn't do much
good!). libswt-gnome-gtk3-jni has one reverse-depends zekr (already
removed from Testing because of webkitgtk) and one reverse-recommends
(eclipse-rcp, so we'd need to drop that recommends).

Thanks,
Jeremy Bicha
From 9a099e629cedbebb6960171d3b1617c0d74df86c Mon Sep 17 00:00:00 2001
From: Jeremy Bicha <jbi...@debian.org>
Date: Fri, 29 Dec 2017 10:18:58 -0500
Subject: [PATCH] Drop libswt-gnome-gtk-4-jni

Closes: #868404
---
 debian/control                        | 13 -------------
 debian/libswt-gnome-gtk-4-jni.install |  1 -
 debian/rules                          |  4 +---
 3 files changed, 1 insertion(+), 17 deletions(-)
 delete mode 100644 debian/libswt-gnome-gtk-4-jni.install

diff --git a/debian/control b/debian/control
index 9150466..553191e 100644
--- a/debian/control
+++ b/debian/control
@@ -13,7 +13,6 @@ Build-Depends:
  fastjar,
  javahelper,
  libglu1-mesa-dev,
- libgnomeui-dev,
  libgtk-3-dev,
  libgtk2.0-dev,
  libxt-dev,
@@ -34,7 +33,6 @@ Description: Standard Widget Toolkit for GTK+ Java library
 Package: libswt-gtk-4-jni
 Architecture: any
 Depends: ${shlibs:Depends}, ${misc:Depends}
-Suggests: libswt-gnome-gtk-4-jni
 Breaks: libswt-gtk-4-java (<< ${binary:Version}), libswt-gtk-4-java (>> ${binary:Version})
 Description: Standard Widget Toolkit for GTK+ JNI library
  The Standard Widget Toolkit (SWT) is a fast and rich Java GUI toolkit.
@@ -46,7 +44,6 @@ Description: Standard Widget Toolkit for GTK+ JNI library
 Package: libswt-gtk2-4-jni
 Architecture: any
 Depends: ${shlibs:Depends}, ${misc:Depends}
-Suggests: libswt-gnome-gtk-4-jni
 Description: Standard Widget Toolkit for GTK+ 2.0 JNI library
  The Standard Widget Toolkit (SWT) is a fast and rich Java GUI toolkit.
  For platforms with existing SWT implementations it provides efficient, portable
@@ -56,16 +53,6 @@ Description: Standard Widget Toolkit for GTK+ 2.0 JNI library
  its native GUI back end. Set environment variable SWT_GTK3=0 before launching
  the SWT application to use it.
 
-Package: libswt-gnome-gtk-4-jni
-Architecture: any
-Depends: libswt-gtk-4-jni (= ${binary:Version}), ${shlibs:Depends}, ${misc:Depends}
-Description: Standard Widget Toolkit for GTK+ GNOME JNI library
- The Standard Widget Toolkit (SWT) is a fast and rich Java GUI toolkit.
- For platforms with existing SWT implementations it provides efficient, portable
- and fast access to native controls and user interface facilities.
- .
- This package includes the GNOME JNI library.
-
 Package: libswt-cairo-gtk-4-jni
 Architecture: any
 Depends: libswt-gtk-4-jni (= ${binary:Version}), ${shlibs:Depends}, ${misc:Depends}
diff --git a/debian/libswt-gnome-gtk-4-jni.install b/debian/libswt-gnome-gtk-4-jni.install
deleted file mode 100644
index 5244427..0000000
--- a/debian/libswt-gnome-gtk-4-jni.install
+++ /dev/null
@@ -1 +0,0 @@
-libswt-gnome-*[0-9].so usr/lib/jni
diff --git a/debian/rules b/debian/rules
index 7067214..4040dc9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -35,11 +35,10 @@ override_dh_auto_build:
 	cp bundles/org.eclipse.swt/Eclipse\ SWT\ AWT/gtk/library/*.c     bundles/org.eclipse.swt/Eclipse\ SWT\ PI/gtk/library/
 	cp bundles/org.eclipse.swt/Eclipse\ SWT\ PI/cairo/library/*      bundles/org.eclipse.swt/Eclipse\ SWT\ PI/gtk/library/
 	cp bundles/org.eclipse.swt/Eclipse\ SWT\ OpenGL/glx/library/*    bundles/org.eclipse.swt/Eclipse\ SWT\ PI/gtk/library/
-	cp bundles/org.eclipse.swt/Eclipse\ SWT\ Program/gnome/library/* bundles/org.eclipse.swt/Eclipse\ SWT\ PI/gtk/library/
 	cp bundles/org.eclipse.swt/Eclipse\ SWT\ PI/common/library/*     bundles/org.eclipse.swt/Eclipse\ SWT\ PI/gtk/library/
 	cp bundles/org.eclipse.swt/Eclipse\ SWT\ WebKit/gtk/library/*    bundles/org.eclipse.swt/Eclipse\ SWT\ PI/gtk/library/
 
-	GTK_VERSION=3.0 dh_auto_build -- $(MAKE_ARGS) make_atk make_awt make_cairo make_glx make_gnome make_swt make_webkit
+	GTK_VERSION=3.0 dh_auto_build -- $(MAKE_ARGS) make_atk make_awt make_cairo make_glx make_swt make_webkit
 	rm -f bundles/org.eclipse.swt/Eclipse\ SWT\ PI/gtk/library/*.o
 	GTK_VERSION=2.0 dh_auto_build -- $(MAKE_ARGS) make_swtpi
 
@@ -52,6 +51,5 @@ override_dh_auto_clean:
 	rm -f bundles/org.eclipse.swt/Eclipse\ SWT\ PI/gtk/library/swt*
 	rm -f bundles/org.eclipse.swt/Eclipse\ SWT\ PI/gtk/library/cairo*
 	rm -f bundles/org.eclipse.swt/Eclipse\ SWT\ PI/gtk/library/glx*
-	rm -f bundles/org.eclipse.swt/Eclipse\ SWT\ PI/gtk/library/gnome*
 	rm -f bundles/org.eclipse.swt/Eclipse\ SWT\ PI/gtk/library/c*
 	rm -f bundles/org.eclipse.swt/Eclipse\ SWT\ PI/gtk/library/webkit*
-- 
2.14.1

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to