On Thu, Aug 15, 2019 at 12:52 PM, Xavier <y...@debian.org> wrote:
Le 15/08/2019 à 09:04, Pirate Praveen a écrit :


On Thu, Aug 15, 2019 at 12:07 PM, Xavier <y...@debian.org <mailto:y...@debian.org>> wrote:
Hi, "gulp build-babel-standalone" command succeeds here (7.5.5) with
 the following package: PACKAGE : DEB-VERSION => GOOD-VERSION
--------------- upgraded --------------- babel-loader : 7.1.5 => 8.0.6

This needs to be updated along with babel (babel-loader 8 needs babel 7).

 base64-js : 1.3.0 => 1.3.1 chalk : 2.3.0 => 2.4.2 color-convert :
1.9.0 => 1.9.3 globals : 11.1.0 => 11.12.0 ieee754 : 1.1.12 => 1.1.13
 js-tokens : 2.0.0 => 4.0.0 node-libs-browser : 2.2.0 => 2.2.1
regenerator-transform : 0.9.8 => 0.14.1 regexpu-core : 4.5.4 => 4.5.5
 resolve : 1.5.0 => 1.12.0 semver : 5.5.1 => 5.7.1 supports-color :
 4.4.0 => 5.5.0 to-fast-properties : 1.0.2 => 2.0.0 ---------------
 downgraded ----------------- isarray : 2.0.4 => 1.0.0 source-map :
 0.6.1 => 0.5.7 tapable : 1.0.0 => 0.2.9 webpack : 4.7.0 => 3.12.0

 We can adapt the webpack config to build with webpack 4.

 NB: this is an automatic script, results may be false or incomplete

Thanks! babel-standalone is for browser only, try the build target we
 use in rules.

The "bootstrap" target calls "build" which launches this step. Other
build part work, except this one. So if you think we don't need this, we
have to change debian/rules to not call "make bootstrap": instead,
launch only needed gulp steps.

Good then. I don't use babel-standalone directly, but I think some one else wanted this.

We must make it work with webpack 4,
we should try to make it work with source-map 0.6.1
and if its not very hard, update isarray 2 and tapable (if it is hard we can embed old versions)


-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@alioth-lists.debian.net
https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to