Your message dated Thu, 01 Dec 2011 23:39:26 +0000
with message-id <e1rwgdu-0004hx...@franck.debian.org>
and subject line Bug#650547: fixed in libv8 3.5.10.24-2
has caused the Debian Bug report #650547,
regarding libv8: FTBFS on i386: unused variable in lithium-codegen-ia32.cc
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
650547: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=650547
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Source: libv8
Version: 3.5.10.24-1
Severity: serious
Justification: fails to build from source (but built successfully in the past)

The latest libv8 upload fails to build on i386:

  ../src/ia32/lithium-codegen-ia32.cc:3178:12: error: variable 'key' set but 
not used [-Werror=unused-but-set-variable]
  cc1plus: all warnings being treated as errors
  
  make[2]: *** 
[/build/buildd-libv8_3.5.10.24-1-i386-CPx3sU/libv8-3.5.10.24/out/ia32.release/obj.target/v8_base/src/ia32/lithium-codegen-ia32.o]
 Error 1

Could you please take a look, and reconsider your use of -Werror in
official uploads (which become fragile as a result)?

Thanks!



--- End Message ---
--- Begin Message ---
Source: libv8
Source-Version: 3.5.10.24-2

We believe that the bug you reported is fixed in the latest version of
libv8, which is due to be installed in the Debian FTP archive:

libv8-3.5.10.24_3.5.10.24-2_amd64.deb
  to main/libv/libv8/libv8-3.5.10.24_3.5.10.24-2_amd64.deb
libv8-dbg_3.5.10.24-2_amd64.deb
  to main/libv/libv8/libv8-dbg_3.5.10.24-2_amd64.deb
libv8-dev_3.5.10.24-2_amd64.deb
  to main/libv/libv8/libv8-dev_3.5.10.24-2_amd64.deb
libv8_3.5.10.24-2.debian.tar.gz
  to main/libv/libv8/libv8_3.5.10.24-2.debian.tar.gz
libv8_3.5.10.24-2.dsc
  to main/libv/libv8/libv8_3.5.10.24-2.dsc



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 650...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Jérémy Lal <kapo...@melix.org> (supplier of updated libv8 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Thu, 01 Dec 2011 14:31:59 +0100
Source: libv8
Binary: libv8-dev libv8-3.5.10.24 libv8-dbg
Architecture: source amd64
Version: 3.5.10.24-2
Distribution: unstable
Urgency: low
Maintainer: Debian Javascript Maintainers 
<pkg-javascript-devel@lists.alioth.debian.org>
Changed-By: Jérémy Lal <kapo...@melix.org>
Description: 
 libv8-3.5.10.24 - v8 JavaScript engine - runtime library
 libv8-dbg  - v8 JavaScript engine - debugging symbols
 libv8-dev  - v8 JavaScript engine - development files
Closes: 650547 650548 650549
Changes: 
 libv8 (3.5.10.24-2) unstable; urgency=low
 .
   * Set -Wno-unused-but-set-variable, i386 build fail otherwise.
     Closes: bug#650547
   * Remove mipsel from architectures. Will be re-enabled when
     upstream really supports it.
     Closes: bug#650549
   * Disable default arm flags (debian/0014_disable_armv7_defaults.patch) and
     set them properly for armel and armhf, using GYPFLAGS variable in
     debian/rules. Closes: bug#650548
   * Remove 0009_unaligned_access_armel.patch, never proved it was needed.
   * Remove -fvisibility=hidden flag, applied upstream.
   * CCFLAGS are ignored by the build system, use CXXFLAGS instead.
Checksums-Sha1: 
 0ac3806693a88a2cf2f8f1df996ee4b03df96c93 1504 libv8_3.5.10.24-2.dsc
 1ee2e9fc01a24866f2676ef83542a59b6e1c87d0 25766 libv8_3.5.10.24-2.debian.tar.gz
 db123c7cda09e1f485bfaeb415b470b06bc635e0 80646 libv8-dev_3.5.10.24-2_amd64.deb
 8badaaba206ea57eb43431d71e2555872347da30 1414354 
libv8-3.5.10.24_3.5.10.24-2_amd64.deb
 17c03d397d71c514890048391c9e82a848fefc8c 24568048 
libv8-dbg_3.5.10.24-2_amd64.deb
Checksums-Sha256: 
 0e5dc007de52411892caeca6dfa538377e4f29aced8566a0267b50946b04c72a 1504 
libv8_3.5.10.24-2.dsc
 893820722baca141df68b9daadef7775c8afe19db983c848bec12d5e9fefa840 25766 
libv8_3.5.10.24-2.debian.tar.gz
 f363092ece6b5e21153c7b39f2dfeb91dcff08ce757c2b59fcbcaa9fc9920a6f 80646 
libv8-dev_3.5.10.24-2_amd64.deb
 9ecd560bf3460d8ca7f9436c068919b6c7d900213991ce29ff15be2394b9966f 1414354 
libv8-3.5.10.24_3.5.10.24-2_amd64.deb
 37538c20a1fb5a04da2c1680ab16ffb800a454e4952345ca7f71950d04abbd31 24568048 
libv8-dbg_3.5.10.24-2_amd64.deb
Files: 
 0529eae9134e3dd64165e8f1e31ca094 1504 libs optional libv8_3.5.10.24-2.dsc
 ff29d05ab469fcaa7c81a3d10f649b09 25766 libs optional 
libv8_3.5.10.24-2.debian.tar.gz
 0e1dbf60849bcf038d48c835357ead5b 80646 libdevel optional 
libv8-dev_3.5.10.24-2_amd64.deb
 38c173a3ab2be964e11076c9a4db2c6b 1414354 libs optional 
libv8-3.5.10.24_3.5.10.24-2_amd64.deb
 24d4e0c2acb7251acc2074ed8b315bdd 24568048 debug extra 
libv8-dbg_3.5.10.24-2_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iEYEARECAAYFAk7XgykACgkQDMRIEQdBQdyZogCgz2Nf5g2O9jFEKUuWYxt+9rlf
C0EAnRkgeBoWDIZuTff6YyH/4dV0ojkV
=EzgZ
-----END PGP SIGNATURE-----



--- End Message ---
_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to