On 05/12/2011 21:54, Ben Noordhuis wrote:
> On Mon, Dec 5, 2011 at 20:02, Jérémy Lal <kapo...@melix.org> wrote:
>> On 05/12/2011 17:51, Jérémy Lal wrote:
>>> Thanks to the abel guest access i got, libv8 builds and pass tests on armel 
>>> and armhf.
>>> I'm still having *one* test failing, if anyone has an idea about why :
>>>
>>>    var f = new Buffer('über', 'ucs2');
>>>    assert.deepEqual(f, new Buffer([252, 0, 98, 0, 101, 0, 114, 0]));
>>>
>>> Giving this result :
>>> https://buildd.debian.org/status/fetch.php?pkg=nodejs&arch=armel&ver=0.4.12-2&stamp=1323100281&file=log
>>>
>>> Couldn't be linked to some wrong endianness assumption ?
>>
>> It isn't, after doing some testing on abel, i observe this strange behavior :
>>   build/default/node 
>> /home/kapouer/nodejs/nodejs-0.4.12/test/simple/test-buffer.js
>> never outputs errors,
>> while
>>   python tools/test.py simple/test-buffer
>> always does.
>>
>> I'm stuck.
>>
>> Jérémy.
>>
>>
>> PS: wild cc-ing nodejs-dev, in case someone there already knows why :)
>>    the test mentionned above is the only one failing, and it's been there 
>> for a long time.
> 
> It looks like a off-by-one error. To wit:
> 
>   {"0":252,"1":0,"2":98,"3":0,"4":101,"5":0,"6":114,"7":0
>   {        "0":0,"1":98,"2":0,"3":101,"4":0,"5":114,"6":0,"7":120
> 
> It's quite possibly been fixed. Does it happen with v0.6.5?

Thank you for your suggestion,
Indeed, it doesn't. Now i'm searching why.

It doesn't seem to be in src/node_buffer.cc :
i just tried with a backported one and it doesn't change the failure,
same goes for lib/buffer.js.
Since it fails when launched trough test.py and not directly through 
command-line
node invocation, does it point to something particular i could bisect on ?

Note that i kept the same system libv8 version (3.5) for both 0.4.12 and 0.6.5 
tests,
it's unsupported but working quite well.

Jérémy.




_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to