Package: nodejs
Version: 0.6.14~dfsg1-1
Severity: important

The bug in http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=666051 also effects 
nodejs, as it is not possible to use it to connect to Facebook, Paypal, etc.

The following code in nodejs console after a minute or two throws an error and 
exits.

var https = require("https")
https.get({host: "graph.facebook.com", path: "/"},  function(res) { })

node.js:201
        throw e; // process.nextTick error, or 'error' event on first tick
              ^
Error: socket hang up
    at createHangUpError (http.js:1107:15)
    at CleartextStream.<anonymous> (http.js:1210:27)
    at CleartextStream.emit (events.js:88:20)
    at Array.0 (tls.js:792:22)
    at EventEmitter._tickCallback (node.js:192:41)

A possible solution is to use an older version of openssl as a dependency.

-- System Information:
Debian Release: 6.0.4
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages nodejs depends on:
ii  libc-ares2              1.7.5-1          library for asyncronous name resol
ii  libc6                   2.11.3-3         Embedded GNU C Library: Shared lib
ii  libev4                  1:4.11-1         high-performance event loop librar
ii  libgcc1                 1:4.4.5-8        GCC support library
ii  libssl1.0.0             1.0.1-2          SSL shared libraries
ii  libstdc++6              4.4.5-8          The GNU Standard C++ Library v3
ii  libv8-3.8.9.16          3.8.9.16-2       v8 JavaScript engine - runtime lib
ii  zlib1g                  1:1.2.3.4.dfsg-3 compression library - runtime

nodejs recommends no packages.

nodejs suggests no packages.

-- no debconf information



_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to