Package: node-express
Version: 2.5.9-1
Severity: grave
Justification: renders package unusable (uninstallable)

As you may have heard, nodejs's main executable is now /usr/bin/nodejs
rather than /usr/bin/node to avoid clashing with the unrelated "node"
package.  To accommodate that change, please update /usr/bin/express's

#!/usr/bin/env node

line to

#!/usr/bin/env nodejs

or better yet


and version node-express's dependency on nodejs to (>= 0.6.19~dfsg-1-3~).


-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (500, 'testing'), (500, 'stable'), (300, 'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.2.0-3-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages node-express depends on:
ii  node-connect  1.7.3-1
ii  node-mime     1.2.5-1
ii  node-mkdirp   0.3.1-2
ii  node-qs       0.4.2-1
ii  nodejs        0.6.19~dfsg1-2

node-express recommends no packages.

node-express suggests no packages.

-- no debconf information

Pkg-javascript-devel mailing list

Reply via email to