Your message dated Fri, 21 Sep 2012 22:41:01 +0000
with message-id <e1tfbu9-0000ta...@franck.debian.org>
and subject line Bug#686894: fixed in npm 1.1.4~dfsg-2
has caused the Debian Bug report #686894,
regarding npm: please run under nodejs, not node
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
686894: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=686894
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: npm
Version: 1.1.4~dfsg-1
Severity: grave
Justification: renders package unusable

As you may have heard, nodejs's main executable is now /usr/bin/nodejs
rather than /usr/bin/node to avoid clashing with the unrelated "node"
package.  To accommodate that change, please update the

#!/usr/bin/env node

lines in /usr/bin/node and /usr/share/npm/bin/npm-cli.js to

#!/usr/bin/env nodejs

or better yet

#!/usr/bin/nodejs

and version npm's dependency on nodejs to (>= 0.6.19~dfsg-1-3~).  I'd
suggest additionally updating the .../bin/node references in
/usr/share/npm/doc/cli/folders.md and
/usr/share/doc/npm/doc/folders.html, but that's less critical.

Thanks!

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (500, 'testing'), (500, 'stable'), (300, 'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.2.0-3-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages npm depends on:
ii  node-abbrev       1.0.3-1
ii  node-fstream      0.1.13-1
ii  node-graceful-fs  1.1.8-1
ii  node-ini          1.0.2-1
ii  node-minimatch    0.2.0-1
ii  node-mkdirp       0.3.1-2
ii  node-node-uuid    1.3.3-1
ii  node-nopt         1.0.10-2
ii  node-request      2.9.153-1
ii  node-rimraf       2.0.1-1
ii  node-semver       1.0.13-1
ii  node-tar          0.1.13-1
ii  node-which        1.0.5-1
ii  nodejs            0.6.19~dfsg1-2
ii  nodejs-dev        0.6.19~dfsg1-2

npm recommends no packages.

npm suggests no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
Source: npm
Source-Version: 1.1.4~dfsg-2

We believe that the bug you reported is fixed in the latest version of
npm, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 686...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Jonas Smedegaard <d...@jones.dk> (supplier of updated npm package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Sat, 22 Sep 2012 00:19:00 +0200
Source: npm
Binary: npm
Architecture: source all
Version: 1.1.4~dfsg-2
Distribution: unstable
Urgency: low
Maintainer: Debian Javascript Maintainers 
<pkg-javascript-devel@lists.alioth.debian.org>
Changed-By: Jonas Smedegaard <d...@jones.dk>
Description: 
 npm        - package manager for Node.js
Closes: 681356 686894 687052
Changes: 
 npm (1.1.4~dfsg-2) unstable; urgency=low
 .
   [ Jérémy Lal ]
   * debian/patches:
     + 1002_only_use_numeric_UIDs_and_GIDs_in_spawn.patch
       Upstream commit. Closes: #687052.
     + 2006_rename_node_to_nodejs.patch : apart from trivial rename of
       node to nodejs in shebangs and makefile, print a warning and refer
       to nodejs README on failure of a package lifecycle script.
       Closes: #686894.
   * debian/control:
     + Tighten nodejs version to the one after the rename.
     + Suggests: build-essential. Closes: #681356.
 .
   [ Jonas Smedegaard ]
   * Directly use github.com (not broken githubredir.debian.net).
   * Allow Debian-Maintainer uploads.
Checksums-Sha1: 
 c9fa8e5b359fd05671a82709c9ccb5c54396509b 2019 npm_1.1.4~dfsg-2.dsc
 adef774d129c1aceadb01da31c2e3d67b8ba8f3b 12640 npm_1.1.4~dfsg-2.debian.tar.gz
 1ebb8b20803d5c9b4d25e80e813053b7564e831d 344638 npm_1.1.4~dfsg-2_all.deb
Checksums-Sha256: 
 cc9d2a61235fca78d26529d3b1b6d070351883ae58288a3edcb823a0d3285f99 2019 
npm_1.1.4~dfsg-2.dsc
 221d63d2d29f5a3ca6204c6cce800770aa7104f51e8bcc59194d28fd358550a8 12640 
npm_1.1.4~dfsg-2.debian.tar.gz
 56bc822583febc7ba9368b60f75df64a1cb0e60d69dd69983e8ad159b70d7371 344638 
npm_1.1.4~dfsg-2_all.deb
Files: 
 0f941291cdfaae57999f6c51c758ce22 2019 web extra npm_1.1.4~dfsg-2.dsc
 cf306e3ba4c1304dda703e70b6bfdf56 12640 web extra npm_1.1.4~dfsg-2.debian.tar.gz
 4f3a5ea12edddb7f003374bc2a4e083b 344638 web extra npm_1.1.4~dfsg-2_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAEBCgAGBQJQXOrkAAoJECx8MUbBoAEhXZwP/07qytekZRWcpgvab4pB0e/D
s5PpXMJgnoznKfRx2iTAi2updAEKwPe43xjqCpjlfncpTVzo044pyEd/jCE6z+nJ
Rk2KqnZOFs44RZh4aoE1uXVQw7qnSVblO9EOmFXOuhTpjid0OsQu5tXFGzCDhQhk
KQLKIpg4NDyJnNXmQ/VEGUkhItxRlnWx2L/Vp0IgZxSXtRUNBQ6HO+ykt5l33rgW
VXZagHWkbi6lmIxSbrnWJLBXrbBHAdhnUbFqiPdjV+eOaPKNjH8fVeU49juXknTd
XfbdAVn7j6dISfIj2OQBvHaORCvUCd+o9xZuNxe/HTpbAZS0DX+AZr6Hh9F8ZDJS
E93UYmNZWHG0XDPjyBoW97u814KEPsxgZ+VwN3QW+UX+J/Jmci8BRrUo/1NEbRfu
Gb58ugFsne9Lt0X1vQ5sv4QsFWd1NXZFfFlEPuAecFz4pYxLn42AzvNJlAaOs2nr
ykYEl40OflMhIGfUT2oEq2gUMoT8LME9W5YI4Vhyb+7jBDoSD04lyyAjo/F8CI9x
lUqV2ez8TGUKD92iGBJA7mNIrGyLnG6Fgrd6lq0xZz1NJo7rilYYQLJOHFHl68DE
nSiGgc7AdgG4p8iFw5kTZcyIUvdvGOrzarlSNLGGc/unxy1zeJFeZ3eVRl5bXvcp
0BneDP/os1erEj4QHspS
=wIS9
-----END PGP SIGNATURE-----

--- End Message ---
_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to