Your message dated Sun, 23 Sep 2012 10:47:44 +0000
with message-id <e1tfjiy-0006fo...@franck.debian.org>
and subject line Bug#688030: fixed in less.js 1.3.0~20120310-4
has caused the Debian Bug report #688030,
regarding less.js: Fix FTBFS when executing tests due to rename node->nodejs
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
688030: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=688030
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: less.js
Version: 1.3.0~20120310-3
Severity: serious
Tags: patch
Justification: fails to build from source (but built successfully in the past)
User: ubuntu-de...@lists.ubuntu.com
Usertags: origin-ubuntu quantal ubuntu-patch

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Dear Maintainer,

In Ubuntu, the attached patch was applied to achieve the following:

  * Fix FTBFS due to renaming of node -> nodejs:
    - d/p/2003_use_nodejs_build.patch: Patch Makefile to use 'nodejs'
      instead of 'node' command when executing tests.

Thanks for considering the patch.


- -- System Information:
Debian Release: wheezy/sid
  APT prefers quantal-updates
  APT policy: (500, 'quantal-updates'), (500, 'quantal-security'), (500, 
'quantal')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.5.0-14-generic (SMP w/8 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iQIcBAEBCAAGBQJQWHDJAAoJEL/srsug59jDJ2QP/iY88jNO9+dvDe7Q7m8nEXmp
J05eP+IGde6nqdFs7MRfaFTFqIdaWd/G0rqknyRQ9WANXdJhUnPEYFexrKQAp0Ue
wdr/9gzpI6K4njPsBU3LI80G1YzVFTFCgqesiGUrVj2i97+pjbWuPnIykpm8pu7P
jCSGFQKZ/QyPR1MnyKJ3Xm+JUWZjx2f/DeQu5mlwxlSHJJbZHiRcdvY7bU6V9OAt
zobQm8UMXaWvri4NJUh6PbpWQgXYSWSjeL4zeyLlL5sUbFA3P1aEH2765BfvZSJu
rIFz89TFPIUojdgaqNJcor4lOJpUDRlveZAjeEhdQqemV8KW7SQtBNksJjNMRTeB
EiegHTUL0hW6w+uxu5aTUaLHenS+lSJakoXCSUuJxbagTljkn7WlHwbRyBcocwta
8K2hOMcpoQa8RvWWo8CQGMvLdAmhWs/BgauHlh3rnsqJWAjSVxcTodwIpUIim+Zo
l1UEWsqm4swr3t4UZ4CB9Y+ZjA2o7GeQLTVtmyCjoxmqY9f/aFz8YSz0JZeCxKm8
FIqzgZ+t4/8yhTg3EDj1YbINa8vO4zQuXjT12BYbwn5L+XAAhmFir9V41MIzLNAF
SACqxM1fnrqaKJRRY0bujI9D0Gy5FvKCoteg+uqdxrNkPELcde+slVFwKo9KCn+w
JmWgMqW6uZFpn+tVCt0x
=J0or
-----END PGP SIGNATURE-----
diff -Nru less.js-1.3.0~20120310/debian/changelog less.js-1.3.0~20120310/debian/changelog
diff -Nru less.js-1.3.0~20120310/debian/patches/2003_use_nodejs_build.patch less.js-1.3.0~20120310/debian/patches/2003_use_nodejs_build.patch
--- less.js-1.3.0~20120310/debian/patches/2003_use_nodejs_build.patch	1970-01-01 01:00:00.000000000 +0100
+++ less.js-1.3.0~20120310/debian/patches/2003_use_nodejs_build.patch	2012-09-18 13:57:14.000000000 +0100
@@ -0,0 +1,18 @@
+--- a/Makefile
++++ b/Makefile
+@@ -2,13 +2,13 @@
+ # Run all tests
+ #
+ test: 
+-	node test/less-test.js
++	nodejs test/less-test.js
+ 
+ #
+ # Run benchmark
+ #
+ benchmark:
+-	node benchmark/less-benchmark.js
++	nodejs benchmark/less-benchmark.js
+ 
+ #
+ # Build less.js
diff -Nru less.js-1.3.0~20120310/debian/patches/series less.js-1.3.0~20120310/debian/patches/series
--- less.js-1.3.0~20120310/debian/patches/series	2012-08-06 02:18:12.000000000 +0100
+++ less.js-1.3.0~20120310/debian/patches/series	2012-09-18 13:55:51.000000000 +0100
@@ -1,2 +1,3 @@
 2001_use_usr-bin-nodejs.patch
 2002_strip_local_PATH.patch
+2003_use_nodejs_build.patch

--- End Message ---
--- Begin Message ---
Source: less.js
Source-Version: 1.3.0~20120310-4

We believe that the bug you reported is fixed in the latest version of
less.js, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 688...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Jonas Smedegaard <d...@jones.dk> (supplier of updated less.js package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Sun, 23 Sep 2012 12:39:47 +0200
Source: less.js
Binary: libjs-less node-less
Architecture: source all
Version: 1.3.0~20120310-4
Distribution: unstable
Urgency: low
Maintainer: Debian Javascript Maintainers 
<pkg-javascript-devel@lists.alioth.debian.org>
Changed-By: Jonas Smedegaard <d...@jones.dk>
Description: 
 libjs-less - the LESS CSS meta-language - Javascript library
 node-less  - the LESS CSS meta-language - compiler and Node module
Closes: 688030
Changes: 
 less.js (1.3.0~20120310-4) unstable; urgency=low
 .
   [ Jérémy Lal ]
   * Update patch 2001 to rename node to nodejs also in Makefile,
     and in test outcome.
     Closes: bug#688030. Thanks to James Page.
 .
   [ Jonas Smedegaard ]
   * Directly use github.com (not unreliable githubredir.debian.net).
   * Update package relations:
     + Declare all package relations in rules file.
     + Stop conflict/replace obsolete unstable-only virtual libnode-less.
     + Stop provide bogus virtual lessc.
Checksums-Sha1: 
 5ffccade52a9c33b2088a395455535331abf16fa 2073 less.js_1.3.0~20120310-4.dsc
 62c5717f6db7ce11eb6e52971ca1e29f86e0d2f7 8114 
less.js_1.3.0~20120310-4.debian.tar.gz
 4bba5a8af3b7d114a78fcbbc386a20503b6813c7 52268 
libjs-less_1.3.0~20120310-4_all.deb
 b75312a32f34cbe8a2df7b2b736bc6d5dd15b6db 45288 
node-less_1.3.0~20120310-4_all.deb
Checksums-Sha256: 
 54b1c3c9beffc6128ee867c9d874a2a5193b1723726c1323941573e691501973 2073 
less.js_1.3.0~20120310-4.dsc
 cb2161c359118a565bb61c856da9ad37c1a708f45b251ed21849c03b7b5edf09 8114 
less.js_1.3.0~20120310-4.debian.tar.gz
 1e5de83f6d1281c0d9f2dc60764336eb09a8e0fb6cb4d8dead58c7f3a21a3b8c 52268 
libjs-less_1.3.0~20120310-4_all.deb
 ad28e37c123cfaa3f1503bb9b0092c147c00895bb9f1694d8124a20e2674e2ab 45288 
node-less_1.3.0~20120310-4_all.deb
Files: 
 e0f3e4586e5ab376afeedccc5c2d7e7c 2073 web optional less.js_1.3.0~20120310-4.dsc
 76f590332ea2c138dee37520a7b48160 8114 web optional 
less.js_1.3.0~20120310-4.debian.tar.gz
 2dd6adfbf6b941344a1e5d6ad7e10971 52268 web optional 
libjs-less_1.3.0~20120310-4_all.deb
 52c428d5bf8be9f02d4e7bb1b6ab91ec 45288 web optional 
node-less_1.3.0~20120310-4_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAEBCgAGBQJQXufoAAoJECx8MUbBoAEhkeoP/jQnVPslyYls7dssle0N46ZF
sZaanS6agTqdIq0oX6DsQv83IShsDsGOlTVs2Uhr1q6gQC+sEhLjKoI/Ra5iEk4/
gOAyD6tSP/arLOVoxC5+BKsKW3C/2g4JXC9mtGTclLNmr/odNisx6Vo8ck6VF0EC
xvQpVUBFKBTzX8xSQgAAhf+YJq5GgRtpccLF+rq2OTmf5Lc+1ugGO/vophsCCQS3
D/OzWIYKn9eEqzlyKBtcq1MargTprGIJClFjEL9ALBLSC0knWYn3rGSdV9Prskdo
TkthRx8RYQyWttFtJQnGuq+ttMOPdPx5VvB45Ppk/4J1ZY0PYYWAtbWHhZkYRmFm
N4PxOj3Csn9JbbNF+0uKSmvoGOXIypM6cZ7oX4vPX2yoxf3wVVoNKxVqDosZEUJB
fa3vEO3Cq6KbvJChSybNYGWZoaPE6urREtH0qVzEJj3qvcP7Hu/SDDSVqQYpJY/7
J3qZSQCoF4w8gtmH6tQx20gtYuL7Yu9UXwDv8xRoSntHTLcVuVV7DV+W3nzaqbv6
gojfspLRiw4YRqwwTv7MMCRiiLviXuH5Ghx+D7m9HQA0bAJSMX0EIb3EyQ6uhCKl
m0RtOTsqupnBw573s8zUdhQMck4fXWsbxrn1FfDVs2b9Xj1teTqp2fkeQZkzRJAN
zenLT1o2AKiNn/iNtp6v
=XT1l
-----END PGP SIGNATURE-----

--- End Message ---
_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to